Bug 1492467 - encryption installation crash everytime when you try to reuse an encrypted disk
Summary: encryption installation crash everytime when you try to reuse an encrypted disk
Keywords:
Status: CLOSED DUPLICATE of bug 1493862
Alias: None
Product: Fedora
Classification: Fedora
Component: python-blivet
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Blivet Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-17 14:00 UTC by lnie
Modified: 2017-09-21 06:51 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-21 06:51:54 UTC
Type: Bug


Attachments (Terms of Use)
anaconda.log (44.21 KB, text/plain)
2017-09-17 14:00 UTC, lnie
no flags Details
program.log (29.62 KB, text/plain)
2017-09-17 14:01 UTC, lnie
no flags Details
storage.log (184.07 KB, text/plain)
2017-09-17 14:02 UTC, lnie
no flags Details

Description lnie 2017-09-17 14:00:50 UTC
Created attachment 1326983 [details]
anaconda.log

Description of problem:


Version-Release number of selected component (if applicable):
20170916(both server.iso and workstation live are affected)

How reproducible:
always

Steps to Reproduce:
1.Do a encryption installation with virt-manager  
2.do another encryption server installation on that virt-machine:
a)clicking "Done",after select "Custom" and "encrypt my data" on Installation Destination page
b)unlock the disk decrypted on step1,and then delete all the partitions 
c)Clicking "click here to create them automatically "
3.you will see the crash a while after you click the "Begin installtion" button 

Actual results:


Expected results:


Additional info:

Comment 1 lnie 2017-09-17 14:01:58 UTC
Created attachment 1326984 [details]
program.log

Comment 2 lnie 2017-09-17 14:02:52 UTC
Created attachment 1326985 [details]
storage.log

Comment 3 Jiri Konecny 2017-09-18 08:15:00 UTC
This looks to me related to the storage library. Changing components.

Comment 4 lnie 2017-09-21 06:51:54 UTC
#bz1493862 provides more logs,duplicating.

*** This bug has been marked as a duplicate of bug 1493862 ***


Note You need to log in before you can comment on or make changes to this bug.