Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1492542 - Gluster v status client-list prints wrong output for multiplexed volume.
Summary: Gluster v status client-list prints wrong output for multiplexed volume.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: hari gowtham
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-18 06:17 UTC by hari gowtham
Modified: 2017-12-08 17:40 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.13.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-08 17:40:53 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description hari gowtham 2017-09-18 06:17:55 UTC
Description of problem:

the output for client-list prints more number of clients than it actually has. 


Version-Release number of selected component (if applicable):
master (not backported to  other branches so far)

How reproducible:
100%

Steps to Reproduce:
1.enable brick multiplexing (works fine for brick mux disabled)
2.create a volume and mount it (fuse mount is enough as a client)
3.gluster v status <volname> client-list


Actual results:
gluster v status v1 client-list
Client connections for volume v1
Name                                                       count
-----                                                     ------
fuse                                                           4

total clients for volume v1 : 4 
-----------------------------------------------------------------




Expected results:
gluster v status v1 client-list
Client connections for volume v1
Name                                                       count
-----                                                     ------
fuse                                                           1

total clients for volume v1 : 1
-----------------------------------------------------------------




Below is the status and number of clients for the volume:
gluster v status
Status of volume: v1
Gluster process                             TCP Port  RDMA Port  Online  Pid
------------------------------------------------------------------------------
Brick 192.168.122.17:/data/gluster/bricks/b
1                                           49152     0          Y       22707
Brick 192.168.122.17:/data/gluster/bricks/b
2                                           49152     0          Y       22707
Brick 192.168.122.17:/data/gluster/bricks/b
3                                           49152     0          Y       22707
Brick 192.168.122.17:/data/gluster/bricks/b
4                                           49152     0          Y       22707
 
Task Status of Volume v1
------------------------------------------------------------------------------
There are no active volume tasks

192.168.122.17:/v1 on /data/gluster/mount/v1 type fuse.glusterfs (rw,default_permissions,allow_other,max_read=131072)


Additional info:
The number of clients is increased because for a brick multiplexed volume the client to brick connection (xprt) is multiplexed and not one to one. 
Every client has the connection for every other server to it is populated those many number of times (number of brick in that process)

Comment 1 Worker Ant 2017-09-18 06:22:35 UTC
REVIEW: https://review.gluster.org/18308 (Tests: disabling the check for volume client-list) posted (#1) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 2 hari gowtham 2017-09-18 06:23:52 UTC
posted patch to disable the test under this ID itself so its easy to track and undo it when the fix is sent for this bug.

Comment 3 Worker Ant 2017-09-19 10:42:34 UTC
COMMIT: https://review.gluster.org/18308 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit dafffa7b8fdfd29edf6e92c31d74dd7abc8f4d6c
Author: hari gowtham <hgowtham@redhat.com>
Date:   Mon Sep 18 11:48:43 2017 +0530

    Tests: disabling the check for volume client-list
    
    The client-list command is broken for brick-multiplexed.
    Disabling it until the fix is in so that the regression test
    can be resumed for the other test cases.
    
    Change-Id: Idcb5a09db0eb46fbe71c215109b5c55924cc1209
    BUG: 1492542
    Signed-off-by: hari gowtham <hgowtham@redhat.com>
    Reviewed-on: https://review.gluster.org/18308
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Tested-by: Atin Mukherjee <amukherj@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 4 Worker Ant 2017-10-05 09:31:50 UTC
REVIEW: https://review.gluster.org/18433 (gluster: volume status clients command fix) posted (#1) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 5 Worker Ant 2017-10-11 10:28:08 UTC
REVIEW: https://review.gluster.org/18433 (gluster: volume status clients command fix) posted (#2) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 6 Worker Ant 2017-10-12 06:44:38 UTC
REVIEW: https://review.gluster.org/18433 (gluster: volume status clients command fix) posted (#3) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 7 Worker Ant 2017-10-12 07:28:44 UTC
REVIEW: https://review.gluster.org/18433 (gluster: volume status clients command fix) posted (#4) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 8 Worker Ant 2017-10-12 07:28:48 UTC
REVIEW: https://review.gluster.org/18504 (DO NOT MERGE: to test brick-mux on) posted (#1) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 9 Worker Ant 2017-10-24 09:34:02 UTC
REVIEW: https://review.gluster.org/18433 (gluster: volume status clients command fix) posted (#5) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 10 Worker Ant 2017-10-24 09:34:06 UTC
REVIEW: https://review.gluster.org/18504 (DO NOT MERGE: to test brick-mux on) posted (#2) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 11 Worker Ant 2017-10-24 09:42:43 UTC
REVIEW: https://review.gluster.org/18433 (Gluster: volume status clients command fix) posted (#6) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 12 Worker Ant 2017-10-24 09:42:47 UTC
REVIEW: https://review.gluster.org/18504 (DO NOT MERGE: to test brick-mux on) posted (#3) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 13 Shyamsundar 2017-12-08 17:40:53 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.13.0, please open a new bug report.

glusterfs-3.13.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-December/000087.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.