Bug 1492582 - [RGW:NFS]: Overwrite to an existing file fails with NFS version 3
Summary: [RGW:NFS]: Overwrite to an existing file fails with NFS version 3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 3.0
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: 3.0
Assignee: Matt Benjamin (redhat)
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-18 08:53 UTC by Vidushi Mishra
Modified: 2017-12-05 23:44 UTC (History)
9 users (show)

Fixed In Version: RHEL: ceph-12.2.1-21.el7cp nfs-ganesha-2.5.2-7.el7cp Ubuntu: ceph_12.2.1-24redhat1xenial nfs-ganesha_2.5.2-7redhat1xenial
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-05 23:44:17 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Ceph Project Bug Tracker 21854 0 None None None 2017-10-19 19:07:13 UTC
Gerrithub.io 382883 0 None None None 2017-10-19 19:55:43 UTC
Red Hat Product Errata RHBA-2017:3387 0 normal SHIPPED_LIVE Red Hat Ceph Storage 3.0 bug fix and enhancement update 2017-12-06 03:03:45 UTC

Description Vidushi Mishra 2017-09-18 08:53:25 UTC
Description of problem:
Overwrite to an existing file on the NFS mount fails with operation not permitted error. This is when we mount using NFS version 3.

[root@host mnt2]# cat test1/myfile2
welcome to world of ceph
[root@host mnt2]# echo  welcome to the world of rgw  > test1/myfile2
[root@host mnt2]# cat test1/myfile2
welcome to world of ceph



[root@host mnt2]# dd if=/dev/urandom of=test1/myfile3  bs=10M count=2
2+0 records in
2+0 records out
20971520 bytes (21 MB) copied, 0.765551 s, 27.4 MB/s
[root@host mnt2]# ls -lkh test1
total 40M
-rw-r--r--. 1 root root 20M Sep 18 07:58 myfile1
-rw-r--r--. 1 root root  25 Sep 18 08:41 myfile2
-rw-r--r--. 1 root root 20M Sep 18 08:44 myfile3
[root@host mnt2]# dd if=/dev/urandom of=test1/myfile3  bs=10M count=1
dd: closing output file ‘test1/myfile3’: Operation not permitted
[root@host mnt2]# ls -lkh test1
total 40M
-rw-r--r--. 1 root root 20M Sep 18 07:58 myfile1
-rw-r--r--. 1 root root  25 Sep 18 08:41 myfile2
-rw-r--r--. 1 root root 20M Sep 18 08:44 myfile3
[root@host mnt2]# 



Version-Release number of selected component (if applicable):
ceph version 12.2.0-2.el7cp
nfs-ganesha-rgw-2.5.2-2.el7cp.x86_64
nfs-ganesha-2.5.2-2.el7cp.x86_64

How reproducible:

2/2

Steps to reproduce :
1. Configure NFS server on an RGW  and configure NFS client and mount share with NFSv3.
2. Create few files and write some data.
3. overwrite on the above created files, fails with operation not permitted error.

Actual results:
Already existing file can't be modified with NFS version 3

Expected results:
File should be modified

Comment 15 errata-xmlrpc 2017-12-05 23:44:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3387


Note You need to log in before you can comment on or make changes to this bug.