Bug 1492610 - bodhi-client depends on python-dnf on el7 - which has been retired
Summary: bodhi-client depends on python-dnf on el7 - which has been retired
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: bodhi
Version: epel7
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Randy Barlow
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-18 10:01 UTC by Vinzenz Feenstra [evilissimo]
Modified: 2017-09-20 13:42 UTC (History)
6 users (show)

Fixed In Version: bodhi-2.10.1-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-20 13:42:11 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github fedora-infra bodhi issues 1812 None None None 2017-09-18 13:56:02 UTC

Description Vinzenz Feenstra [evilissimo] 2017-09-18 10:01:15 UTC
Description of problem:

bodhi-client depends on python-dnf that is no longer packaged for epel



Version-Release number of selected component (if applicable):
bodhi-client-2.9.1-1.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. `yum install bodhi-client` on CentOS7/RHEL7 with EPEL repositories

Actual results:
Error: Package: bodhi-client-2.9.1-1.el7.noarch (epel)
       Requires: python-dnf


Expected results:
That the package is installable


Additional info:

ignatenkobrain wrote on #fedora-buildsys@freenode: 
    evilissimo: so last week I finally retired dnf from epel7 because it had too many issues (including security) and it was impossible to fix that because version in EPEL is something like 2-4 years old

Comment 1 Devan Goodwin 2017-09-18 15:05:50 UTC
Impacting installations of tito as well.

Comment 2 Devan Goodwin 2017-09-18 15:08:22 UTC
Seems to impact a fairly large chunk of Fedora packager tooling, hope this is ok but I'm am going to bump severity and priority, please reset if this is not.

Comment 3 Fedora Update System 2017-09-18 17:16:16 UTC
bodhi-2.10.1-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-2c7d154fb3

Comment 4 Fedora Update System 2017-09-19 17:20:14 UTC
bodhi-2.10.1-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-2c7d154fb3

Comment 5 Fedora Update System 2017-09-19 21:20:36 UTC
bodhi-2.10.1-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.