Bug 149263 - Assertion failure on startup with ppp interface
Assertion failure on startup with ppp interface
Status: CLOSED DUPLICATE of bug 149183
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-21 14:25 EST by Brian Bruns
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-21 14:36:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Brian Bruns 2005-02-21 14:25:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041220 K-Meleon/0.9

Description of problem:
Bind refuses to start when a ppp interface exists on the system (in this case, a ppp interface created by the poptop PPTP server), with assertion failure.


Feb 21 14:11:05 everest named[29606]: starting BIND 9.3.1rc1 -u named
Feb 21 14:11:05 everest named[29606]: found 1 CPU, using 1 worker thread
Feb 21 14:11:05 everest named[29606]: loading configuration from '/etc/named.conf'
Feb 21 14:11:05 everest named[29606]: ifiter_getifaddrs.c:109: INSIST(ifa->ifa_a
ddr != ((void *)0)) failed
Feb 21 14:11:05 everest named[29606]: exiting (due to assertion failure)

With the ppp interface disconnected, bind starts normally.  Did not happen previously with 9.3.0 rpm.  Note that I do not have any way of testing a 'plain' ppp interface such as one used to dialup.  The rest of the interfaces are ethernet and loopback.

Version-Release number of selected component (if applicable):
bind-9.3.1rc1-1

How reproducible:
Always

Steps to Reproduce:
1. Connect PPTP client to server, which creates a ppp0 interface
2. Start bind via initscript
3. Startup fails
4. Disconnect PPTP client
5. Start bind via initscript
6. Startup completes with no errors 

Actual Results:  Bind failed to run

Expected Results:  Bind should be running

Additional info:

Kernel is 2.6.11-rc4-bk2, built from FC4 devel SRPM for Athlon XP 2000+ with all associated patches included in the SRPM, as well as mppe/mppc patch from http://www.polbox.com/h/hs001
Comment 1 Jason Vas Dias 2005-02-21 14:36:17 EST
This bug is fixed in bind-9.3.1rc1-2, now available via yum update /
ftp://download.fedora.redhat.com:/pub/fedora/linux/core/development .


*** This bug has been marked as a duplicate of 149183 ***

Note You need to log in before you can comment on or make changes to this bug.