Bug 149264 - Set default cursor position to text input box “Name”, “Add Cluster Node”
Set default cursor position to text input box “Name”, “Add Cluster Node”
Status: CLOSED NEXTRELEASE
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: redhat-config-cluster (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Parsons
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-21 14:32 EST by Paul Kennedy
Modified: 2015-04-19 20:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-15 14:46:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Kennedy 2005-02-21 14:32:20 EST
Description of problem:
Cluster -> Cluster Nodes -> Add a Cluster Node

When adding a node, in the “Node Properties” dialog box, the default
position of the cursor should start at “Cluster Node Name”. The
natural tendency of a user is to start typing. Because the default
location of cursor is at the Cancel button, user must move mouse or
tab to position to "Cluster Node Name" box in Node Properties dialog box.

Version-Release number of selected component (if applicable):
system-config-cluster-0.9.5-1.0

How reproducible:

Steps to Reproduce:
1. Naviagate: Cluster -> Cluster Nodes -> Add a Cluster Node
2. Enter node name.

  
Actual results:
Nothing appears

Expected results:
Entered text to appear in "Cluster Node Name" box.
Comment 1 Jim Parsons 2005-03-01 12:03:05 EST
will be in final - easyy fix
Comment 2 Jim Parsons 2005-03-07 16:47:34 EST
Now for new nodes, the dialog box appears with focus on 'Name' entry field. When
editing an existing nodes props, the focus is on the 'quorum votes', and the
value is highlighted, as quorum votes seems more likely to be changed than the
name in a running cluster.

Done in the 0.9.9 release
Comment 3 Derek Anderson 2005-03-15 14:46:25 EST
Verified in 0.9.12.

When creating new node name you can now start typing and it will be in
the node name field.  Press Enter in any field and the save (OK)
action is taken.

Modify an existing node and the focus is in the quorum votes field.

Note You need to log in before you can comment on or make changes to this bug.