Bug 149276 - RFE: 'rpm --import' does not honor $*_proxy variables
RFE: 'rpm --import' does not honor $*_proxy variables
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-21 16:22 EST by Enrico Scholz
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-12 07:29:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2005-02-21 16:22:08 EST
Description of problem:


| # set
| http_proxy=http://www-cache:3128/
| no_proxy=ultra.csn.tu-chemnitz.de
|
| # strace rpm --import 0x53ACA43A
| ...
| connect(3, {sa_family=AF_INET, sin_port=htons(11371), sin_addr=inet_addr("18.7.14.139")}, 16) = 0
|                                               ~~~~~                      ~~~~~~~~~~~~~

When the $*_proxy variables are set, 'rpm' (like any other http aware
application) should honor it.


Version-Release number of selected component (if applicable):

rpm-4.4.1-2
Comment 1 Jeff Johnson 2005-02-21 16:38:22 EST
Yep, the proxy support in rpm ain't been looked at seriously
since 1999. There is much that needs doing to make rpm
more network useful.
Comment 2 Marius Andreiana 2005-07-01 08:37:49 EDT
Confirming this bug in FC4
Comment 3 Red Hat Bugzilla 2007-08-21 01:19:44 EDT
User pnasrat@redhat.com's account has been closed
Comment 4 Panu Matilainen 2007-08-22 02:30:08 EDT
Reassigning to owner after bugzilla made a mess, sorry about the noise...
Comment 5 Panu Matilainen 2007-09-12 07:29:37 EDT
rpm.org upstream uses a helper (curl or similar) to operate on url's, so
http_proxy etc get honored if the helper does.

Note You need to log in before you can comment on or make changes to this bug.