Bug 149279 - megaraid device driver does not properly load during install
megaraid device driver does not properly load during install
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-21 16:48 EST by Jack
Modified: 2015-01-04 17:17 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-02 20:34:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jack 2005-02-21 16:48:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; 
SV1; .NET CLR 1.1.4322)

Description of problem:
I have an HP NetServer LC 3 with a Netraid 1Si controller and three 
SCSI-2 disks in a RAID-0 configuration.

I tried to install Fedora Core 3 on this platform, but it could not 
find any disks. I then tried installing Microsoft Windows, and it 
found the raid array and installed fine. I then tried installing 
Fedora Core 2, and again the disk array could not be found. Next, I 
pulled out an old backup copy of RedHat 7.0 and tried installing 
that. This install found the drives perfectly and performed a 
flawless installation with the megaraid device driver for the Netraid 
1Si controller. I then tried another backup copy, this time RedHat 
9.0, and it too installed flawlessly. At some point after the final 
open release of RedHat (9.0 Shrike) the megaraid device driver failed 
to initialize and properly identify the Netraid 1Si controller or 
disks. I no longer have Fedora Core 1 backup disks, so I am unable to 
attempt an install of this release. To sum up, megaraid last worked 
in RedHat 9.0, and quit working by Fedora Core 2 to present. The 
break occured with Core 1 or Core 2.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Insert Fedora Core 2 or 3 install disk 1.
2. Wait for installer to fully load.
3. Stare in disappointment as a dialog reports no disks have been 
found.
    

Expected Results:  It should have found the disk array and installed 
correctly as previous RedHat installations have done successfully.

Additional info:
Comment 1 Dan Carpenter 2005-06-25 18:27:11 EDT
Could you try the driver disk from:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=138590
Comment 2 Dave Jones 2005-07-15 14:08:53 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 3 Yan Kravchenko 2005-09-20 12:51:05 EDT
This problem still exists in FC 4.  Any help is very much appreciated.
Comment 4 Dave Jones 2005-10-02 20:34:56 EDT
This bug has been automatically closed as part of a mass update.
It had been in NEEDINFO state since July 2005.
If this bug still exists in current errata kernels, please reopen this bug.

There are a large number of inactive bugs in the database, and this is the only
way to purge them.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.