Bug 1493069 - [IBM] Review/update sysctl.conf.s390 default values
Summary: [IBM] Review/update sysctl.conf.s390 default values
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: initscripts
Version: 7.4
Hardware: s390
OS: Linux
high
high
Target Milestone: rc
: 7.6
Assignee: David Kaspar [Dee'Kej]
QA Contact: Daniel Rusek
Marie Dolezelova
URL:
Whiteboard:
: 1458916 (view as bug list)
Depends On:
Blocks: 1420851 1465901 1466365 1507957 1513404 1549617 1549689 1609081 1493072
TreeView+ depends on / blocked
 
Reported: 2017-09-19 10:01 UTC by David Kaspar [Dee'Kej]
Modified: 2018-10-30 10:17 UTC (History)
10 users (show)

Fixed In Version: initscripts-9.49.42-1.el7
Doc Type: Release Note
Doc Text:
`kernel.shmmax` and `kernel.shmall` updated to kernel defaults on IBM Z Previously, applications that required a large amount of memory in some cases terminated unexpectedly due to low values of the `kernel.shmmax` and `kernel.shmall` parameters on IBM Z. This update aligns the values of `kernel.shmmax` and `kernel.shmall` with kernel defaults, which helps avoid the described crashes.
Clone Of:
: 1493072 (view as bug list)
Environment:
Last Closed: 2018-10-30 10:15:57 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3131 None None None 2018-10-30 10:17:17 UTC
IBM Linux Technology Center 159107 None None None 2017-09-22 10:50:12 UTC

Description David Kaspar [Dee'Kej] 2017-09-19 10:01:52 UTC
Previously, Red Hat has updated the default values in
/usr/lib/sysctl.d/00-systen.conf for architectures other than s390.

Few months ago, we received a BZ report #1458916, that the default values for s390 were kept as they were before, and which are too low for some applications to run correctly.

Therefore, I would like to hereby ask IBM representatives, what should be correct default values on IBM's s390 (and s390x if needed) architectures for these settigs?

----------------------------------

# Kernel sysctl configuration file
#
# For binary values, 0 is disabled, 1 is enabled.  See sysctl(8) and
# sysctl.conf(5) for more details.

# Controls the use of TCP syncookies
net.ipv4.tcp_syncookies = 1

# Do not spend as much process time too early to write out dirty pages
vm.dirty_ratio = 40

# Increase the average time a process runs continuously and also improve the
# cache utilization and server style workload throughput at minor latency cost
kernel.sched_min_granularity_ns = 10000000
kernel.sched_wakeup_granularity_ns = 15000000
kernel.sched_tunable_scaling = 0
kernel.sched_latency_ns = 80000000

# Controls the maximum shared segment size, in bytes
kernel.shmmax = 4294967295

# Controls the maximum number of shared memory segments, in pages
kernel.shmall = 268435456

----------------------------------

(https://github.com/fedora-sysv/initscripts/blob/rhel7-branch/sysctl.conf.s390)

----------------------------------

Would IBM be okay with completely removing all of these settings, and using default kernel values?

Would the current config (used for all other architectures) https://github.com/fedora-sysv/initscripts/blob/rhel7-branch/sysctl.conf be sufficient for the needs of IBM s390 (and s390x) arch?

Thank you in advance!

----------------------------------

@dhorak: Please, forward this request to IBM. Quick response from IBM is welcomed.

Comment 5 IBM Bug Proxy 2017-11-29 15:15:46 UTC
------- Comment From epasch@de.ibm.com 2017-11-29 09:48 EDT-------
The kernel.shmmax and kernel.shmall = 268435456
can be removed. The same reason as given for the general file at

https://github.com/fedora-sysv/initscripts/commit/e3784a1aefb3f38a5a3f9ae69b3feff9c8ef5610#diff-5e6436c816034c6fd3829b55f323caad

applies here as well. It doesn't make sense to set the defaults twice.

Comment 6 David Kaspar [Dee'Kej] 2018-04-27 13:24:34 UTC
Pull-request has been submitted:
https://github.com/fedora-sysv/initscripts/pull/182

Comment 7 David Kaspar [Dee'Kej] 2018-04-27 13:27:40 UTC
*** Bug 1458916 has been marked as a duplicate of this bug. ***

Comment 20 errata-xmlrpc 2018-10-30 10:15:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3131


Note You need to log in before you can comment on or make changes to this bug.