Bug 1493096 - Failed stack update as director tries to delete/recreate networks/subnets/ports/vip's
Summary: Failed stack update as director tries to delete/recreate networks/subnets/por...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-heatclient
Version: 10.0 (Newton)
Hardware: All
OS: Linux
medium
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Steve Baker
QA Contact: Ronnie Rasouli
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-19 11:23 UTC by Luca Miccini
Modified: 2018-06-27 13:38 UTC (History)
11 users (show)

Fixed In Version: python-heatclient-1.14.0-0.20180213175737.2ce6aa1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:37:30 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 509203 'None' MERGED Don't override sections in deep_update 2020-09-25 08:50:05 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:38:54 UTC

Description Luca Miccini 2017-09-19 11:23:14 UTC
Description of problem:

Trying to re-deploy an already existing overcloud fails because director tries to delete and re-create networks/subnets and VIPs.

2017-09-15 11:44:24Z [ServiceNetMap]: UPDATE_COMPLETE  state changed
2017-09-15 11:45:31Z [overcloud-Networks-ldg7vrpnlbwe-ExternalNetwork-2mxurynqqauk.ExternalSubnet]: DELETE_FAILED  Conflict: resources.ExternalSubnet: Una
ble to complete operation on subnet 0be8c89c-dbd4-45c6-9f92-09710bd42efc: One or more ports have an IP allocation from this subnet.
Neutron server returns request_ids: ['req-b93a5f7b-96b2-43aa-92e3-1b45edf4f912']
2017-09-15 11:45:31Z [overcloud-Networks-ldg7vrpnlbwe-StorageNetwork-sskb6k6fxrtu.StorageSubnet]: DELETE_FAILED  Conflict: resources.StorageSubnet: Unable
 to complete operation on subnet b23a96bd-cc63-4a4b-aad2-2059f0e64e27: One or more ports have an IP allocation from this subnet.
Neutron server returns request_ids: ['req-c1e25e2c-df07-42c2-bfda-312cdb8393ce']
2017-09-15 11:45:31Z [overcloud-Networks-ldg7vrpnlbwe-ExternalNetwork-2mxurynqqauk]: DELETE_FAILED  Resource DELETE failed: Conflict: resources.ExternalSu
bnet: Unable to complete operation on subnet 0be8c89c-dbd4-45c6-9f92-09710bd42efc: One or more ports have an IP allocation from this subnet.
Neutron server returns request_ids: ['req-b93a5f7b-96b2-43aa
2017-09-15 11:45:31Z [overcloud-Networks-ldg7vrpnlbwe-StorageNetwork-sskb6k6fxrtu]: DELETE_FAILED  Resource DELETE failed: Conflict: resources.StorageSubn
et: Unable to complete operation on subnet b23a96bd-cc63-4a4b-aad2-2059f0e64e27: One or more ports have an IP allocation from this subnet.
Neutron server returns request_ids: ['req-c1e25e2c-df07-42c2-


Templates defining network configuration and options are unchanged, only changes are related to storage and ceilometer configuration parameters.

Version-Release number of selected component (if applicable):

osp10

heat-cfntools-1.3.0-2.el7ost.noarch
openstack-heat-api-7.0.5-1.el7ost.noarch
openstack-heat-api-cfn-7.0.5-1.el7ost.noarch
openstack-heat-common-7.0.5-1.el7ost.noarch
openstack-heat-engine-7.0.5-1.el7ost.noarch
openstack-heat-templates-0-0.12.1e6015dgit.el7ost.noarch
openstack-tripleo-0.0.8-0.2.4de13b3git.el7ost.noarch
openstack-tripleo-common-5.4.2-3.el7ost.noarch
openstack-tripleo-heat-templates-5.3.0-4.el7ost.noarch
openstack-tripleo-image-elements-5.3.0-2.el7ost.noarch
openstack-tripleo-puppet-elements-5.3.0-1.el7ost.noarch
openstack-tripleo-ui-1.2.0-1.el7ost.noarch
openstack-tripleo-validations-5.1.2-1.el7ost.noarch
puppet-heat-9.5.0-1.el7ost.noarch
puppet-tripleo-5.6.1-2.el7ost.noarch
python-heat-agent-0-0.12.1e6015dgit.el7ost.noarch
python-heatclient-1.5.2-1.el7ost.noarch
python-tripleoclient-5.4.2-2.el7ost.noarch


How reproducible:

unsure.

Steps to Reproduce:
1. n/a
2.
3.

Actual results:

2017-09-15 11:44:24Z [ServiceNetMap]: UPDATE_COMPLETE  state changed
2017-09-15 11:45:31Z [overcloud-Networks-ldg7vrpnlbwe-ExternalNetwork-2mxurynqqauk.ExternalSubnet]: DELETE_FAILED  Conflict: resources.ExternalSubnet: Una
ble to complete operation on subnet 0be8c89c-dbd4-45c6-9f92-09710bd42efc: One or more ports have an IP allocation from this subnet.
Neutron server returns request_ids: ['req-b93a5f7b-96b2-43aa-92e3-1b45edf4f912']
2017-09-15 11:45:31Z [overcloud-Networks-ldg7vrpnlbwe-StorageNetwork-sskb6k6fxrtu.StorageSubnet]: DELETE_FAILED  Conflict: resources.StorageSubnet: Unable
 to complete operation on subnet b23a96bd-cc63-4a4b-aad2-2059f0e64e27: One or more ports have an IP allocation from this subnet.
Neutron server returns request_ids: ['req-c1e25e2c-df07-42c2-bfda-312cdb8393ce']
2017-09-15 11:45:31Z [overcloud-Networks-ldg7vrpnlbwe-ExternalNetwork-2mxurynqqauk]: DELETE_FAILED  Resource DELETE failed: Conflict: resources.ExternalSu
bnet: Unable to complete operation on subnet 0be8c89c-dbd4-45c6-9f92-09710bd42efc: One or more ports have an IP allocation from this subnet.
Neutron server returns request_ids: ['req-b93a5f7b-96b2-43aa
2017-09-15 11:45:31Z [overcloud-Networks-ldg7vrpnlbwe-StorageNetwork-sskb6k6fxrtu]: DELETE_FAILED  Resource DELETE failed: Conflict: resources.StorageSubn
et: Unable to complete operation on subnet b23a96bd-cc63-4a4b-aad2-2059f0e64e27: One or more ports have an IP allocation from this subnet.
Neutron server returns request_ids: ['req-c1e25e2c-df07-42c2-

[stack@director10 ~]$ heat stack-list
WARNING (shell) "heat stack-list" is deprecated, please use "openstack stack list" instead
+--------------------------------------+------------+---------------+----------------------+----------------------+
| id                                   | stack_name | stack_status  | creation_time        | updated_time         |
+--------------------------------------+------------+---------------+----------------------+----------------------+
| 640ea84f-e7f1-4208-a5f4-25a9126139f2 | overcloud  | UPDATE_FAILED | 2017-04-10T22:36:27Z | 2017-09-15T11:43:55Z |
+--------------------------------------+------------+---------------+----------------------+----------------------+


Expected results:

stack to be updated successfully.

Additional info:

Comment 14 errata-xmlrpc 2018-06-27 13:37:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.