Bug 1493116 - ipa-server-upgrade fail when IPv6 is disabled
Summary: ipa-server-upgrade fail when IPv6 is disabled
Keywords:
Status: CLOSED DUPLICATE of bug 1477367
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: ipa-qe
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-19 12:10 UTC by Robert Marcano
Modified: 2017-09-25 14:09 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-25 14:09:36 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Robert Marcano 2017-09-19 12:10:22 UTC
Description of problem:

When IPv6 is disabled using recommended method:

  /etc/sysctl.conf:

  net.ipv6.conf.all.disable_ipv6 = 1
  net.ipv6.conf.default.disable_ipv6 = 1

ipa-server-upgrade fails trying to connect to port 8080 tcp on ::1 and time out (Checking if a service was started)

  /var/log/ipaupgrade.log:

  Failed to connect to port 8080 tcp on ::1

Reenabling IPv6 solves the upgrade, but if it is disabled again after upgrade, ipactl start fails with long wait times too and related services don't start.


Version-Release number of selected component (if applicable):

ipa-server-4.5.0-21.el7

How reproducible:

Always when IPv6 is disabled

Steps to Reproduce:
1. Disable IPv6
2. run ips-server-upgrade

Comment 3 Robert Marcano 2017-09-25 13:10:53 UTC
(In reply to Florence Blanc-Renaud from comment #2)
> According to
> https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/
> html/Linux_Domain_Identity_Authentication_and_Policy_Guide/installing-ipa.
> html#prerequisites
> IPv6 must be enabled on the system.

Fair, but it could be better to detect it and show a message. I know rpm updates should run unattended, but printing a message about how the IPA installation will not be upgraded and will remain down until IPV6 is reenabled and ipa-server-upgrade is run again could help a lot.

This case was a small customer that when the updated was installed was dumbfounded to find the server not working at all, did not understood the problem with the long timeouts.

Comment 4 Rob Crittenden 2017-09-25 14:09:36 UTC
Upgrade now checks for IPv6 

https://pagure.io/freeipa/c/f05afa4813f425e9fc9960f63100431a78310638

*** This bug has been marked as a duplicate of bug 1477367 ***


Note You need to log in before you can comment on or make changes to this bug.