Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.
Red Hat Satellite engineering is moving the tracking of its product development work on Satellite to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "Satellite project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs will be migrated starting at the end of May. If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "Satellite project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/SAT-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.

Bug 1493121

Summary: As user without "Tasks Manager" role, filtering tasks results in unhandled error
Product: Red Hat Satellite Reporter: Lukáš Hellebrandt <lhellebr>
Component: Tasks PluginAssignee: Ivan Necas <inecas>
Status: CLOSED ERRATA QA Contact: Lukáš Hellebrandt <lhellebr>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: UnspecifiedCC: akarsale, aruzicka, inecas, kgaikwad, lhellebr, mhulan
Target Milestone: 6.4.0Keywords: Triaged, VerifiedUpstream
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-10-16 18:52:20 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Lukáš Hellebrandt 2017-09-19 12:16:56 UTC
Description of problem:
When a user without "Tasks Manager" role applies some simple filter like "ITISBROKEN", the error is shown that the user should not see: it contains generic "Oops, we're sorry but something went wrong" and full SQL query (with option to show full stack trace).

This does not happen without filtering.
This does not happen for queries in form "column = value".

Even if the error is actually a correct result (is it? it happens only for queries of certain form), there should be more gracefull error like "Permission error" shown to the user.

How reproducible:
Deterministic

Steps to Reproduce:
1. Create a user, do not assign any role to it
2. Login as that user
3. Monitor -> Tasks -> fill in "ITISBROKEN" -> Search

Actual results:
Generic error with potentially sensitive information

Expected results:
No error at all (the behavior seems inconsistent to me) or at least some user friendly error

Comment 1 Brad Buckingham 2017-09-20 17:22:08 UTC
Was this behavior on 6.2.z or 6.3?  Thanks!

Comment 2 Lukáš Hellebrandt 2017-09-21 09:00:00 UTC
Both

Comment 4 Ivan Necas 2017-09-22 16:46:04 UTC
I can't reproduce the issue neither on upstream nightly nor sat 6.2 or 6.3 (see screenshot). Please provide as much info as possible (foreman-debug, screenshots of the failure) to be able to see what the cause might be, as it's not 100% reproducible.

Comment 5 Ivan Necas 2017-09-22 16:48:01 UTC
Np, I missed the fact with missing Task Viewer role

Comment 6 Ivan Necas 2017-09-22 19:15:19 UTC
Created redmine issue http://projects.theforeman.org/issues/21082 from this bug

Comment 7 Satellite Program 2017-09-22 20:18:07 UTC
Upstream bug assigned to inecas

Comment 8 Satellite Program 2017-09-22 20:18:12 UTC
Upstream bug assigned to inecas

Comment 9 Satellite Program 2017-10-04 18:31:05 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/21082 has been resolved.

Comment 10 Lukáš Hellebrandt 2018-06-28 10:04:17 UTC
Verified on Sat 6.4 snap 9.

Used reproducer from OP, result is "No entries found".

Comment 11 Bryan Kearney 2018-10-16 18:52:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2018:2927