Bug 149315 - Unable to boot from CD#1 and install from FTP
Unable to boot from CD#1 and install from FTP
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-22 06:35 EST by Milan Kerslager
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: RHEL-4.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-16 12:48:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Milan Kerslager 2005-02-22 06:35:34 EST
When pick CD#1 for x86, passing 'askmethod' to boot prompt, pick up FTP method
of installation, filling up FTP server, Anaconda wrote "CD media found", trying
to test CD#1 and refuses proceed installation even successful download of stage
files from my FTP server. When trying to skip media test, Anaconda fallback to
the screen with informations for FTP server (I have FTP tree under login/pass
not on public FTP tree). When trying to remove CD before FTP attempt, anaconda
wrote something like 'unable to mount CD' to the debug screen.

No error messages on installation screen even trying to test my CD.

RHEL3 installation works fine in this case.
Comment 1 Milan Kerslager 2005-02-22 06:47:18 EST
The problem is that Anaconda did not wrote error message because broken network
configuration (DHCP server offered already used IP). I saw debug messages about
transferring files from FTP server but no files was really transferred and no
error message was printed.
Comment 2 Jeremy Katz 2005-02-22 09:46:54 EST
The use of the CD for the second stage is actually an (intentional) optimization
to allow people to get graphical FTP/HTTP installs without requiring silly
amounts of RAM.  So it sounds like things were mostly working as expected other
than how the broken network configuration got handled.

I'm not sure how to handle that better, though.  We say that we're not able to
grab stuff and then should shunt you back to at least the ftp config screen.
Comment 3 Milan Kerslager 2005-02-22 10:28:54 EST
I wote for error message on the screen with <OK> button. The shunting back to
the ftp config screen works :) It seems like "unable to download file" warning
works but "unable to connect to FTP server" is silently discarted in some cases.

Also I'm confirming that FTP installation with GUI frontend works by using
boot.iso, CD#1 with askmethod and PXE boot via BootROM works with GUI too. Thank
you!
Comment 4 Milan Kerslager 2007-03-16 03:21:59 EDT
It seems that this bug has been already resolved 2 years ago.
Please close the bug as I'm unable to close it even I'm the submiter.
Comment 5 David Cantrell 2007-03-16 12:48:22 EDT
Closing per comment #4

Note You need to log in before you can comment on or make changes to this bug.