Bug 149316 - Server reboot causes Unregister-netdevice errors
Server reboot causes Unregister-netdevice errors
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-22 06:43 EST by John Horne
Modified: 2015-01-04 17:17 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-29 20:51:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Horne 2005-02-22 06:43:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
We run FC3 servers as VPN servers. If the server is rebooted or
shutdown whilst a virtual PPP interface is still present then the
console repeatedly shows:

  Unregister-netdevice: waiting for ppp1 to become free. Usage count = 2

The 'count' may vary at each reboot. The system does not
reboot/shutdown, so we have to do a power off and restart.

NOTE: the kernel has a patch applied to it to support MPPE/MPPC for
our VPN service. (Patch by Jan Dubiec can be found at:
http://www.polbox.com/h/hs001/).

We had this problem at FC2 but only ran that for a short time before
upgrading to FC3 - hence it wasn't reported as an FC2 bug.

Version-Release number of selected component (if applicable):
kernel-2.6.10-1.766_FC3

How reproducible:
Always

Steps to Reproduce:
1. Install FC3 with MPPE/MPPC patch. 
2. Connect to server over vpn (using pptp client); this will cause a
virtual PPP interface to be created.
3. Reboot server using 'reboot' command.
    

Actual Results:  Server gets tied up with console messages. Server
doesn't reboot.

Expected Results:  Server should shutdown all network interfaces and
then reboot.

Additional info:

This hasn't been 'tested' as such since our servers are live. However,
we have had cause to reboot the servers recently and this problem has
always occurred. (Yes, we do warn users that we will be rebooting but
there is always someone who doesn't logout. Hence a ppp interface is
usually still present at reboot time.)
Comment 1 Dave Jones 2005-07-15 15:53:58 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 2 John Horne 2005-07-18 07:14:02 EDT
Okay I will try the new kernel. However, the servers have a modified kernel (for
mppe/mppc) so it will take a little time.



John.
Comment 3 John Horne 2005-07-20 06:41:52 EDT
Yes, the latest FC3 kernel (2.6.12-1.1372_FC3) fixes the problem. I rebooted the
server and logged in as a vpn user (which creates a virtual ppp interface).
Twice shutting down the server from the console worked fine, despite the ppp
interface being present. I also rebooted the server remotely, with a ppp
interface present, and it rebooted fine - no error messages and no looping.

As far as I am concerned you can close this bug report.

Note You need to log in before you can comment on or make changes to this bug.