Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1493226 - segment host mapping tests are failing
Summary: segment host mapping tests are failing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-networking-ovn
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: beta
: 12.0 (Pike)
Assignee: Assaf Muller
QA Contact: Ofer Blaut
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-19 16:12 UTC by Arie Bregman
Modified: 2019-09-09 16:48 UTC (History)
7 users (show)

Fixed In Version: python-networking-ovn-3.0.1-0.20171005161553.0cde8a5.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-13 22:10:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 493970 0 None MERGED Fix gate mtu tests 2020-04-06 11:50:36 UTC
Red Hat Product Errata RHEA-2017:3462 0 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-16 01:43:25 UTC

Description Arie Bregman 2017-09-19 16:12:10 UTC
Description of problem:

The following tests fail:

networking_ovn.tests.unit.ml2.test_mech_driver.TestOVNMechansimDriverSegment.test_clear_segment_host_mapping

networking_ovn.tests.unit.ml2.test_mech_driver.TestOVNMechansimDriverSegment.test_update_segment_host_mapping

The failure is: 

{"NeutronError": {"type": "InvalidInput", "message": "Invalid input for operation: Requested MTU is too big, maximum is 1450.", "detail": ""}}


Version-Release number of selected component (if applicable):  latest OSP 12


How reproducible: 100%


Steps to Reproduce:
1. Clone networking-ovn and checkout rhos-12.0-patches branch
2. Run unit tests

Actual results:

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/neutron/tests/base.py", line 118, in func
    return f(self, *args, **kwargs)
  File "networking_ovn/tests/unit/ml2/test_mech_driver.py", line 1325, in test_clear_segment_host_mapping
    _, host = self._test_segment_host_mapping()
  File "networking_ovn/tests/unit/ml2/test_mech_driver.py", line 1307, in _test_segment_host_mapping
    network_type='geneve')['segment']
  File "/usr/lib/python2.7/site-packages/neutron/tests/unit/extensions/test_segment.py", line 124, in _test_create_segment
    segment = self.segment(**keys)
  File "/usr/lib/python2.7/site-packages/neutron/tests/unit/extensions/test_segment.py", line 120, in segment
    self.fmt, tenant_id=self._tenant_id, **kwargs)
  File "/usr/lib/python2.7/site-packages/neutron/tests/unit/extensions/test_segment.py", line 114, in _make_segment
    code=res.status_int, explanation=str(res))
webob.exc.HTTPClientError: 400 Bad Request
Content-Length: 142
Content-Type: application/json; charset=utf8

{"NeutronError": {"type": "InvalidInput", "message": "Invalid input for operation: Requested MTU is too big, maximum is 1450.", "detail": ""}}


Expected results: Tests passed successfully

Comment 2 Lucas Alvares Gomes 2017-10-23 13:21:49 UTC
Looks like [0] should fix these MTU problems, it has been ported to stable/pike upstream as well. Perhaps we just need a rebase downstream ?

[0] https://review.openstack.org/#/q/12f0d9f3992ce3f08d68d8102ec5d5f9b138c756

Comment 8 errata-xmlrpc 2017-12-13 22:10:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462


Note You need to log in before you can comment on or make changes to this bug.