Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1493233 - Version conflict of wxPython-devel-3.0.2.0-19.fc26.{x86_64,i686} stops all updates of Fedora 26
Summary: Version conflict of wxPython-devel-3.0.2.0-19.fc26.{x86_64,i686} stops all up...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wxPython
Version: 26
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Scott Talbert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-19 16:39 UTC by Edgar Hoch
Modified: 2017-09-30 06:44 UTC (History)
4 users (show)

Fixed In Version: wxPython-3.0.2.0-20.fc26 wxPython-3.0.2.0-20.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-28 19:58:07 UTC
Type: Bug


Attachments (Terms of Use)

Description Edgar Hoch 2017-09-19 16:39:09 UTC
Description of problem:

On our Fedora 26 hosts no updates are installed since about a week. We use dnf-automatic-install which installs updates automatically every night.

When I run dnf upgrade in a shell then I get the following error, and upgrade is aborted:

Error: Transaction check error:
  file /usr/include/wx-3.0/wx/wxPython/i_files/_core_ex.pyc conflicts between attempted installs of wxPython-devel-3.0.2.0-19.fc26.i686 and wxPython-devel-3.0.2.0-19.fc26.x86_64
  file /usr/include/wx-3.0/wx/wxPython/i_files/_core_ex.pyo conflicts between attempted installs of wxPython-devel-3.0.2.0-19.fc26.i686 and wxPython-devel-3.0.2.0-19.fc26.x86_64


Please can you fix this problem as soon as possible, because not updates are installed when wxPython-devel in multilib version (64 and 32 bit) is installed!


Version-Release number of selected component (if applicable):

Package conflict:
wxPython-devel-3.0.2.0-19.fc26.i686
wxPython-devel-3.0.2.0-19.fc26.x86_64

Installed version on our hosts:
wxPython-devel-3.0.2.0-13.fc26.i686
wxPython-devel-3.0.2.0-13.fc26.x86_64


How reproducible:
Always

Steps to Reproduce:
1. Install a version of wxPython-devel before wxPython-devel-3.0.2.0-19 in both x86_64 and i686 architecture.
2. dnf upgrade

Actual results:
Upgrade is aborted.

Expected results:
Updates are installed.

Additional info:
"dnf remove wxPython-devel" solves the dnf upgrade abort problem on our hosts, but this is not a good solution...

Comment 1 Fedora Update System 2017-09-20 13:38:36 UTC
wxPython-3.0.2.0-20.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-7577597c17

Comment 2 Fedora Update System 2017-09-20 13:39:01 UTC
wxPython-3.0.2.0-20.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-14efee944c

Comment 3 Fedora Update System 2017-09-20 23:51:16 UTC
wxPython-3.0.2.0-20.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-14efee944c

Comment 4 Fedora Update System 2017-09-21 23:57:16 UTC
wxPython-3.0.2.0-20.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-7577597c17

Comment 5 Fedora Update System 2017-09-28 19:58:07 UTC
wxPython-3.0.2.0-20.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2017-09-30 06:44:43 UTC
wxPython-3.0.2.0-20.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.