Bug 1493410 - ipa-server-upgrade timeouts on wait_for_open ports expecting IPA services listening on IPv6 ports [rhel-7.4.z]
Summary: ipa-server-upgrade timeouts on wait_for_open ports expecting IPA services lis...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.4
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: ipa-qe
URL:
Whiteboard:
: 1492100 (view as bug list)
Depends On: 1477367
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-20 07:04 UTC by Oneata Mircea Teodor
Modified: 2017-10-19 15:12 UTC (History)
21 users (show)

Fixed In Version: ipa-4.5.0-21.el7_4.2.2
Doc Type: If docs needed, set a value
Doc Text:
Prior to this update, Identity Management (IdM) did not operate with the IPv6 stack disabled on the machine due to the use of a unified Linux networking API to handle both IPv6 and IPv4 connections. Consequently, it was not possible to upgrade the Red Hat Enterprise Linux IdM. The bug has been fixed, and validation of the IPv6 stack now works as expected.
Clone Of: 1477367
Environment:
Last Closed: 2017-10-19 15:12:49 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2935 normal SHIPPED_LIVE ipa bug fix update 2017-10-19 18:49:19 UTC

Description Oneata Mircea Teodor 2017-09-20 07:04:40 UTC
This bug has been copied from bug #1477367 and has been proposed to be backported to 7.4 z-stream (EUS).

Comment 7 Nikhil Dehadrai 2017-09-29 10:28:01 UTC
IPA server version: ipa-server-4.5.0-21.el7_4.2.2.x86_64


Verified the bug on the basis of following observations:

1) When IPA server (having IPv6 disabled) is upgraded from RHEL 7.3.z > RHEL 7.4update1, the upgrade fails with following error:

[root@dhcp200-204 ~]# rpm -q ipa-server
ipa-server-4.4.0-14.el7_3.7.x86_64
[root@dhcp200-204 ~]# ip addr | grep inet6
[root@dhcp200-204 ~]# # Add repo for RHEL 7.4 update1
[root@dhcp200-204 ~]# yum -y update 'ipa*' sssd

IPA server upgrade failed: Inspect /var/log/ipaupgrade.log and run command ipa-server-upgrade manually.
Timeout exceeded
The ipa-server-upgrade command failed. See /var/log/ipaupgrade.log for more information

[root@dhcp200-204 ~]# tail -1 /var/log/ipaupgrade.log 
2017-09-26T12:04:32Z ERROR The ipa-server-upgrade command failed. See /var/log/ipaupgrade.log for more information
[root@dhcp200-204 ~]# tail -f /var/log/ipaupgrade.log 
  File "/usr/lib/python2.7/site-packages/ipaplatform/base/services.py", line 300, in start
    self.wait_for_open_ports(self.service_instance(instance_name))
  File "/usr/lib/python2.7/site-packages/ipaplatform/base/services.py", line 270, in wait_for_open_ports
    self.api.env.startup_timeout)
  File "/usr/lib/python2.7/site-packages/ipapython/ipautil.py", line 1227, in wait_for_open_ports
    raise socket.timeout("Timeout exceeded")

2017-09-26T12:04:32Z DEBUG The ipa-server-upgrade command failed, exception: timeout: Timeout exceeded
2017-09-26T12:04:32Z ERROR Timeout exceeded
2017-09-26T12:04:32Z ERROR The ipa-server-upgrade command failed. See /var/log/ipaupgrade.log for more information
^C
[root@dhcp200-204 ~]# rpm -q ipa-server
ipa-server-4.5.0-21.el7_4.1.2.x86_64

2) When IPA server (having IPv6 disabled) is upgraded from RHEL 7.3.z > RHEL 7.4update2, the upgrade still fails but this this time with following error logging:

[root@dhcp200-204 ~]# rpm -q ipa-server
ipa-server-4.4.0-14.el7_3.7.x86_64
[root@dhcp200-204 ~]# ip addr | grep inet6
[root@dhcp200-204 ~]# # Add repo for RHEL 7.4 update2
[root@dhcp200-204 ~]# yum -y update 'ipa*' sssd

IPv6 stack is enabled in the kernel but there is no interface that has ::1 address assigned. Add ::1 address resolution to 'lo' interface. You might need to enable IPv6 on the interface 'lo' in sysctl.conf.
The ipa-server-upgrade command failed. See /var/log/ipaupgrade.log for more information

[root@dhcp200-204 ~]# ipactl status
Directory Service: STOPPED
Directory Service must be running in order to obtain status of other services
ipa: INFO: The ipactl command was successful
[root@dhcp200-204 ~]# rpm -q ipa-server
ipa-server-4.5.0-21.el7_4.2.2.x86_64

[root@dhcp200-204 ~]# tail -f /var/log/ipaupgrade.log 
2017-09-26T12:36:45Z ERROR IPv6 stack is enabled in the kernel but there is no interface that has ::1 address assigned. Add ::1 address resolution to 'lo' interface. You might need to enable IPv6 on the interface 'lo' in sysctl.conf.
2017-09-26T12:36:45Z DEBUG   File "/usr/lib/python2.7/site-packages/ipapython/admintool.py", line 172, in execute
    return_value = self.run()
  File "/usr/lib/python2.7/site-packages/ipaserver/install/ipa_server_upgrade.py", line 45, in run
    server.upgrade_check(self.options)
  File "/usr/lib/python2.7/site-packages/ipaserver/install/server/upgrade.py", line 1866, in upgrade_check
    sys.exit(1)

2017-09-26T12:36:45Z DEBUG The ipa-server-upgrade command failed, exception: SystemExit: 1
2017-09-26T12:36:45Z ERROR The ipa-server-upgrade command failed. See /var/log/ipaupgrade.log for more information

Thus based on above observations and comment#6, marking status of bug to "VERIFIED"

Comment 9 Petr Vobornik 2017-10-13 11:14:07 UTC
*** Bug 1492100 has been marked as a duplicate of this bug. ***

Comment 11 errata-xmlrpc 2017-10-19 15:12:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2935


Note You need to log in before you can comment on or make changes to this bug.