Bug 1493476 - [ rgw ]: Enabling Lifecycle on a bucket, for expiration day=0, getting XML error [NEEDINFO]
Summary: [ rgw ]: Enabling Lifecycle on a bucket, for expiration day=0, getting XML ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 4.0
Assignee: Matt Benjamin (redhat)
QA Contact: Tejas
Bara Ancincova
URL:
Whiteboard:
Depends On:
Blocks: 1730176 1494421
TreeView+ depends on / blocked
 
Reported: 2017-09-20 09:48 UTC by Shreekar
Modified: 2020-01-31 12:45 UTC (History)
11 users (show)

Fixed In Version: ceph-14.2.4-14.el8cp, ceph-14.2.4-2.el7cp
Doc Type: Bug Fix
Doc Text:
.The `Expiration, Days` S3 Lifecycle parameter can now be set to `0` The Ceph Object Gateway did not accept the value of `0` for the `Expiration, Days` Lifecycle configuration parameter. Consequently, setting the expiration to `0` could not be used to trigger background delete operation of objects. With this update, `Expiration, Days` can be set to `0` as expected.
Clone Of:
Environment:
Last Closed: 2020-01-31 12:44:52 UTC
Target Upstream Version:
bancinco: needinfo? (mbenjamin)


Attachments (Terms of Use)
Test case which sets expiration of 0 day (1.19 KB, text/plain)
2017-09-20 11:46 UTC, Shreekar
no flags Details


Links
System ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 38389 None None None 2019-10-10 15:39:02 UTC
Red Hat Product Errata RHBA-2020:0312 None None None 2020-01-31 12:45:25 UTC

Description Shreekar 2017-09-20 09:48:11 UTC
Description of problem:
Enable lifecycle on a bucket and set the number of days to 0, which expires objects immediately. It returned XML error instead of deleting objects.

Version-Release number of selected component (if applicable):
Ceph 3.0 

How reproducible:
Always

Steps to Reproduce:
1.Set up a ceph 3.0 cluster.
2.Enable lifecycle on a bucket.
3.Set expiration for objects to 0 day(s).
4.Objects  will get deleted immediately.

Actual results:

[root@magna118 ~]# python tc11198.py 
log/0ABC.txt
Traceback (most recent call last):
  File "tc11198.py", line 38, in <module>
    mybucket.configure_lifecycle(lifecycle)
  File "/usr/lib/python2.7/site-packages/boto-2.48.0-py2.7.egg/boto/s3/bucket.py", line 1366, in configure_lifecycle
    response.status, response.reason, body)
boto.exception.S3ResponseError: S3ResponseError: 400 Bad Request
<?xml version="1.0" encoding="UTF-8"?><Error><Code>InvalidArgument</Code><BucketName>redhat</BucketName><RequestId>tx0000000000000000001f7-0059bb820b-1077-default</RequestId><HostId>1077-default-default</HostId></Error>


Expected results:
Objects will expire immediately.


Additional info:
Test case: CEPH 11198 Specify the number of days in lifecycle rule to 0

Comment 3 Shreekar 2017-09-20 11:46:35 UTC
Created attachment 1328402 [details]
Test case which sets expiration of 0 day

Comment 18 Giridhar Ramaraju 2019-08-05 13:10:19 UTC
Updating the QA Contact to a Hemant. Hemant will be rerouting them to the appropriate QE Associate. 

Regards,
Giri

Comment 19 Giridhar Ramaraju 2019-08-05 13:11:24 UTC
Updating the QA Contact to a Hemant. Hemant will be rerouting them to the appropriate QE Associate. 

Regards,
Giri

Comment 28 errata-xmlrpc 2020-01-31 12:44:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0312


Note You need to log in before you can comment on or make changes to this bug.