Due to a recent update on Javascript code a full page refresh on your browser might be needed.
Bug 1493531 - In case full PKINIT configuration is failing during server/replica install the error message should be more meaningful.
Summary: In case full PKINIT configuration is failing during server/replica install th...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.4
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: ipa-qe
URL:
Whiteboard:
Depends On:
Blocks: 1506528
TreeView+ depends on / blocked
 
Reported: 2017-09-20 12:15 UTC by Thorsten Scherf
Modified: 2018-04-10 16:47 UTC (History)
9 users (show)

Fixed In Version: ipa-4.5.4-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1506528 (view as bug list)
Environment:
Last Closed: 2018-04-10 16:46:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0918 None None None 2018-04-10 16:47:24 UTC

Description Thorsten Scherf 2017-09-20 12:15:27 UTC
Description of problem:
When ipa-replica-installed is executed, part of the configuration is to setup PKINIT. In case an IPA CA exists in the topology and the installer has not been executed with --no-pkinit, an IPA CA signed certificate for the KDC is requested through certmonger. In case the CA is not reachable, certmonger creates a self-signed certificate for the KDC. The error message shown on the screen is confusing, because it says that PKINIT onfiguration failed in total:

ERROR    PKINIT certificate request failed: Certificate issuance failed (CA_UNREACHABLE)                                                        
ERROR    Failed to configure PKINIT    

Here we should better say that full PKINIT configuration failed but local PKINIT has been configured with a self-signed KDC certificate.


Version-Release number of selected component (if applicable):
ipa-server-4.5.0-21.el7_4.1.2.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Aleksei Slaikovskii 2017-10-04 08:28:20 UTC
Hello, thought it will be very useful to have steps to reproduce here for a further process.

Steps to reproduce:
  1. Get machines for master and replica e.g. with Fedora 25
  2. Add freeipa 4.5 copr:
> # dnf copr enable @freeipa/freeipa-4.5
  3. Update machines and install ipa-server:
> # dnf update -y && dnf install ipa-server
  4. Install master, e.g.:
> master # ipa-server-install --setup-dns --auto-forwarders
  5. Add a breakpoint to /usr/lib/python2.7/site-packages/ipaserver/install/krbinstance.py at line 492 right after method definition on replica machine:
> 491: def issue_ipa_ca_signed_pkinit_certs(self):
> 492:     import pdb; pdb.set_trace()
  6. Run replica installation:
> replica # ipa-client-install
> replica # ipa-replica-install
  7. Wait until it will hit a breakpoint and then stop pki-tomcatd@pki-tomcat service on master
> master # systemctl stop pki-tomcatd@pki-tomcat
  8. Continue execution on replica.

Actual results:
> ipa         : ERROR    PKINIT certificate request failed: Certificate issuance failed (CA_UNREACHABLE)
> ipa         : ERROR    Failed to configure PKINIT

Expected results:
> Here we should better say that full PKINIT configuration failed but local PKINIT has been configured with a self-signed KDC certificate.

Comment 2 Petr Vobornik 2017-10-16 08:54:16 UTC
Upstream ticket: https://pagure.io/freeipa/issue/7179

Comment 7 Mohammad Rizwan 2017-11-21 14:01:57 UTC
verified using steps provided in comment#1


Version:
ipa-server-4.5.4-4.el7.x86_64

Actual result:

.....
.....
Done configuring certificate server (pki-tomcatd).
Configuring Kerberos KDC (krb5kdc)
  [1/1]: installing X509 Certificate for PKINIT
Full PKINIT configuration did not succeed
The setup will only install bits essential to the server functionality
You can enable PKINIT after the setup completed using 'ipa-pkinit-manage'
Done configuring Kerberos KDC (krb5kdc).
Applying LDAP updates
Upgrading IPA:. Estimated time: 1 minute 30 seconds
  [1/9]: stopping directory server
  [2/9]: saving configuration
....
....

Comment 11 errata-xmlrpc 2018-04-10 16:46:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0918


Note You need to log in before you can comment on or make changes to this bug.