Bug 1493749 - FTP to IPv6 link-local addresses with scope identifier is no longer working
Summary: FTP to IPv6 link-local addresses with scope identifier is no longer working
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: tnftp
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-20 19:56 UTC by Peter Bieringer
Modified: 2017-09-20 20:18 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-20 20:18:24 UTC
Type: Bug


Attachments (Terms of Use)

Description Peter Bieringer 2017-09-20 19:56:44 UTC
Description of problem:
looks like some longer time ago, tnftp lost capability of connecting to link-local addresses using scope identifier


Version-Release number of selected component (if applicable):
tnftp-20141031-1.el7.x86_64


How reproducible:
always

Steps to Reproduce:
/usr/bin/tnftp -v -d fe80::***%eth0


Actual results:
isipv6addr: got 0 for fe80::***%eth0
fetch_ftp: `fe80::***%eth0'
fetch_ftp: user `<null>' pass `<null>' host fe80 port <null> path `:***%eth0' dir `<null>' file `:***%eth0'
tnftp: Can't lookup `fe80:ftp': Name or service not known
tnftp: Can't connect or login to host `fe80:?'


Expected results:
(found an older ftp from Ubuntu LTS 12):
isipv6addr: got 1 for fe80::***%eth0
ftp: Can't connect to `fe80::***%eth0:21': Connection refused
ftp: Can't connect to `fe80::***%eth0:ftp'
ftp> 

Additional info:
Filed bug also here, but don't know whether this is the proper place...
https://github.com/hharte/tnftp/issues/2

Comment 1 Peter Bieringer 2017-09-20 20:18:24 UTC
closed, layer 8 problem....non-existent interface specified :-(


Note You need to log in before you can comment on or make changes to this bug.