Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
Red Hat Satellite engineering is moving the tracking of its product development work on Satellite to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "Satellite project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs will be migrated starting at the end of May. If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "Satellite project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/SAT-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Description of problem:
Tried to upgrade to Satellite 6.3 from Satellite 6.2.11.
pulp database upgrade task fails with:
E11000 duplicate key error index: pulp_database.units_yum_repo_metadata_file.$data_type_1_repo_id_1 dup key: { : "productid", : "Demo62-Dev-Combined-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_7_Server_-_Extras_RPMs_x86_64" }
Running a query on the pulp_database, I found these duplicate entries:
2 productid;Demo62-Dev-Combined-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_7_Server_-_Extras_RPMs_x86_64
2 productid;Demo62-Dev-Small-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_7_Server_-_Extras_RPMs_x86_64
3 productid;Demo62-Library-Combined-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_7_Server_-_Extras_RPMs_x86_64
5 productid;Demo62-Library-Small-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_7_Server_-_Extras_RPMs_x86_64
2 productid;Demo62-QA-Small-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_7_Server_-_Extras_RPMs_x86_64
This aligns with my current Content View publish/promote configuration/history:
* 2 Promotions of LE:Dev from CV:Combined
* 2 Promotions of LE:Dev from Small
* 3 versions of CV:Combined
* 5 versions of CV:Small
* 2 Promotions of LE:QA from CV:Small
Version-Release number of selected component (if applicable):
Satellite 6.2.11
How reproducible:
Steps to Reproduce:
1. Create a CV
2. Publish at least 2 versions of it
3. Promote at least 1 environment of it (other than Library)
Actual results:
satellite-installer has a fatal error due to pulp migration task attempting to overlay a unique key on the pulp database.
Expected results:
satellite-installer does not error after pulp migration adds the unique key to the pulp database.
Additional info:
Billy, could you provide the full output from pulp-manage-db?
Also there should be a traceback either on the console or in the system log related to this. That would be very helpful to see as well.
Thanks Tanya,
Sorry about the delay in getting to this BZ
regarding why we drop the collections: if you try to publish a repository (such as when publishing a cv), if there's a distribution in the repo that isn't actually on the filesystem, pulp will error.
I added a pulp-manage-db step to the reset pulp data steps:
https://github.com/RedHatSatellite/satellite-clone/pull/256
Thanks again for looking into this!
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.
For information on the advisory, and where to find the updated
files, follow the link below.
If the solution does not work for you, open a new bug report.
https://access.redhat.com/errata/RHBA-2018:0033
Description of problem: Tried to upgrade to Satellite 6.3 from Satellite 6.2.11. pulp database upgrade task fails with: E11000 duplicate key error index: pulp_database.units_yum_repo_metadata_file.$data_type_1_repo_id_1 dup key: { : "productid", : "Demo62-Dev-Combined-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_7_Server_-_Extras_RPMs_x86_64" } Running a query on the pulp_database, I found these duplicate entries: 2 productid;Demo62-Dev-Combined-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_7_Server_-_Extras_RPMs_x86_64 2 productid;Demo62-Dev-Small-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_7_Server_-_Extras_RPMs_x86_64 3 productid;Demo62-Library-Combined-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_7_Server_-_Extras_RPMs_x86_64 5 productid;Demo62-Library-Small-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_7_Server_-_Extras_RPMs_x86_64 2 productid;Demo62-QA-Small-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_7_Server_-_Extras_RPMs_x86_64 This aligns with my current Content View publish/promote configuration/history: * 2 Promotions of LE:Dev from CV:Combined * 2 Promotions of LE:Dev from Small * 3 versions of CV:Combined * 5 versions of CV:Small * 2 Promotions of LE:QA from CV:Small Version-Release number of selected component (if applicable): Satellite 6.2.11 How reproducible: Steps to Reproduce: 1. Create a CV 2. Publish at least 2 versions of it 3. Promote at least 1 environment of it (other than Library) Actual results: satellite-installer has a fatal error due to pulp migration task attempting to overlay a unique key on the pulp database. Expected results: satellite-installer does not error after pulp migration adds the unique key to the pulp database. Additional info: