Bug 14939 - Install: __glXActiveScreens from libdri.a is unresolved
Summary: Install: __glXActiveScreens from libdri.a is unresolved
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard: Winston gold
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-01 01:01 UTC by Brent Nordquist
Modified: 2014-03-17 02:15 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-10 19:31:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brent Nordquist 2000-08-01 01:01:01 UTC
During install of Pinstripe Beta-5, I saw the following on the console:

...
(II) Module ramdac: vendor = "The XFree86 Project"
	compiled for 4.0.1, module version = 0.1.0
Symbol __glXActiveScreens from module
/usr/X11R6/lib/modules/extensions/libdri.a is unresolved!
(II) NV(0): Using XFree86 Acceleration Architecture (XAA)
...

This is with a Diamond Viper V550 (RIVA TNT)... additional machine details
on request.

Comment 1 Bill Nottingham 2000-08-01 16:16:19 UTC
Do you happen to have the NVidia binary drivers installed?

Comment 2 Brent Nordquist 2000-08-01 17:52:25 UTC
This was a stock install of Pinstripe Beta-5... I literally did nothing to the
XFree86 software or configuration.  Note that this message appeared during the
installation (was visible in F1 at the point where the first graphical install
screen (language selection) appeared).

Comment 3 Bill Nottingham 2000-08-02 16:56:20 UTC
Do you get this after the install?

Comment 4 Glen Foster 2000-08-04 15:06:32 UTC
This defect is considered MUST-FIX for Winston Gold-release

Comment 5 Bill Nottingham 2000-08-14 19:30:07 UTC
closed, lack of input.

Comment 6 Brent Nordquist 2000-08-14 19:38:18 UTC
Sorry re: lack of input.  I keep forgetting to check this one when I'm home. 
It's not a show-stopper as far as I'm concerned, since the install was
successful.

Comment 7 Bill Nottingham 2000-08-14 19:54:01 UTC
It's almost certainly because the X config for the installer
has

	Load "dri"

without

	Load "glx"

Since we don't use dri in the install, it's not a real problem.


Note You need to log in before you can comment on or make changes to this bug.