Bug 1493946 - Please update to v6.7.1
Summary: Please update to v6.7.1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: python-pyvmomi
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Raphael Groner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-21 08:04 UTC by Frank Büttner
Modified: 2018-11-21 00:43 UTC (History)
4 users (show)

Fixed In Version: python-pyvmomi-6.7.1-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-21 00:43:05 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1626231 None None None Never
Red Hat Bugzilla 1645072 None None None Never

Internal Links: 1626231 1645072

Description Frank Büttner 2017-09-21 08:04:16 UTC
Description of problem:
In version 6.5 the SoapAdapter has problems with utf8 characters.

Version-Release number of selected component (if applicable):
python2-pyvmomi-6.5-1.el7.noarch

How reproducible:
Every time.

Steps to Reproduce:
1. create an vm snapshot with Unicode chars.


Actual results:
An soap error about the Unicode.

Expected results:
an vm snapshot


Additional info:
v6.5.0.2017.5-1:
Remove sso.py and it's dependencies(lxml and pyOpenSSL) as they don't compatible with certain OS.

v6.5.0.2017.5:
- Add sso.py to support get bearer/hok token from sso server
- Fixes #519, #448, #420, #421 Fix SoapAdapter serializer to support serializing unicode chars.
- Fix #487: Remove custom getattr in _HTTPSConnection
- Add user-agent header when connecting to vsphere

Comment 1 Raphael Groner 2018-03-06 15:59:59 UTC
Ping? Any news here?
It would be great to have a current version in EPEL.

Comment 2 Raphael Groner 2018-04-06 20:54:31 UTC
Another friendly reminder.

Comment 3 Peter Oliver 2018-09-30 20:24:47 UTC
It appears that primary contact Michael Rice isn't active in Fedora, hasn't made any commits since the package was originally released, and so presumably isn't interested in its ongoing maintenance.

Starting the non-responsive maintainer process.  https://fedoraproject.org/wiki/Policy_for_nonresponsive_package_maintainers

Comment 4 Peter Oliver 2018-09-30 20:25:53 UTC
Pull request addressing this issue: https://src.fedoraproject.org/rpms/python-pyvmomi/pull-request/2

Comment 5 Peter Oliver 2018-09-30 20:27:07 UTC
Re-adding needinfo, which was cleared by accident.

Comment 6 Raphael Groner 2018-09-30 21:46:59 UTC
Thanks for a bump to v6.7 .

Comment 7 Peter Oliver 2018-10-09 19:53:08 UTC
Raised FESCo issue https://pagure.io/fesco/issue/1998.

Comment 8 Raphael Groner 2018-10-21 18:46:24 UTC
Current version of upstream is v6.7.0.2018.9

python2 subpackage was dropped in rawhide, do we still need it in epel7?

Comment 9 Raphael Groner 2018-10-31 22:21:50 UTC
There's some issue with dependencies:

+ cd pyvmomi-6.7.1
+ /usr/bin/python3 setup.py test
running test
Searching for vcrpy==1.12.0
Reading https://pypi.org/simple/vcrpy/
Download error on https://pypi.org/simple/vcrpy/: [Errno -2] Name or service not known -- Some packages may not be found!
Couldn't retrieve index page for 'vcrpy'
Scanning index of all packages (this may take a while)
Reading https://pypi.org/simple/
Download error on https://pypi.org/simple/: [Errno -2] Name or service not known -- Some packages may not be found!
No local packages or working download links found for vcrpy==1.12.0
error: Could not find suitable distribution for Requirement.parse('vcrpy==1.12.0')

Comment 10 Raphael Groner 2018-11-01 07:35:30 UTC
https://github.com/vmware/pyvmomi/issues/735

Comment 11 Raphael Groner 2018-11-01 11:18:41 UTC
Currently, python36 is not possible in EPEL7 due to missing dependency.

Comment 12 Fedora Update System 2018-11-01 11:32:30 UTC
python-pyvmomi-6.7.1-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-8bc6005183

Comment 13 Fedora Update System 2018-11-01 16:47:51 UTC
python-pyvmomi-6.7.1-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-8bc6005183

Comment 14 Fedora Update System 2018-11-21 00:43:05 UTC
python-pyvmomi-6.7.1-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.