Bug 1493955 - iptables -I FORWARD -d 172.30.0.0/16 -i eth1 -j ACCEPT' is needed while using flannel for openshift deployment on openstack for pod to pod communication present on different nodes.
Summary: iptables -I FORWARD -d 172.30.0.0/16 -i eth1 -j ACCEPT' is needed while using...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 3.9.0
Assignee: Ivan Chavero
QA Contact: Meng Bo
URL:
Whiteboard:
: 1490820 (view as bug list)
Depends On: 1537105
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-21 08:24 UTC by Miheer Salunke
Modified: 2018-03-28 14:06 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-28 14:06:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift openshift-ansible pull 5853 0 None None None 2017-10-30 12:50:12 UTC
Red Hat Product Errata RHBA-2018:0489 0 None None None 2018-03-28 14:06:48 UTC

Description Miheer Salunke 2017-09-21 08:24:37 UTC
Description of problem:

After deploying OCP 3.5 on OpenStack 10 is it required

You need to set the following in the forward chain for pod to pod communication present on different nodes->

ansible nodes -b -m shell -a 'iptables -I FORWARD -d 172.30.0.0/16 -i eth1 -j ACCEPT'

where  172.30.0.0/16 is cluster or pod cidr and eth1 is used by flannel.

Version-Release number of selected component (if applicable):
 openshift 3.5 on Openstack 10, VMS have RHEL version 7.3

How reproducible:
Always

Steps to Reproduce:
1. deploy openshift 3.5 on Openstack 10, VMS have RHEL version 7.3
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Ben Bennett 2017-09-22 17:49:01 UTC
The rule:
  iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE

was also needed

Comment 3 Ben Bennett 2017-10-17 15:00:19 UTC
Ivan, can you work with the installer team to see how we can get the above rules added to the ansible installer.

Comment 4 Ivan Chavero 2017-10-25 18:13:28 UTC
Created WIP Pull Request https://github.com/openshift/openshift-ansible/pull/5853

Comment 5 Ben Bennett 2017-12-07 14:12:56 UTC
*** Bug 1490820 has been marked as a duplicate of this bug. ***

Comment 9 Meng Bo 2018-01-30 08:01:01 UTC
Tested with openshift-ansible-3.9.0-0.31.0.git.0.e0a0ad8.el7.noarch.rpm the following iptables rules are added

-A POSTROUTING -o eth0 -m comment --comment "Allow external network access" -j MASQUERADE
-A FORWARD -d 10.128.0.0/14 -i eth0 -m comment --comment "Pod to Pod communication" -j ACCEPT

Comment 12 errata-xmlrpc 2018-03-28 14:06:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0489


Note You need to log in before you can comment on or make changes to this bug.