Bug 1494061 - gnome-software doesn't show F25->F27 upgrade even though it should
Summary: gnome-software doesn't show F25->F27 upgrade even though it should
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-software
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: https://fedoraproject.org/wiki/Common...
Depends On:
Blocks: F27FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2017-09-21 12:20 UTC by Kamil Páral
Modified: 2017-11-01 16:42 UTC (History)
7 users (show)

Fixed In Version: gnome-software-3.22.7-4.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-01 16:42:54 UTC


Attachments (Terms of Use)
fedora.json (10.36 KB, text/plain)
2017-09-21 12:21 UTC, Kamil Páral
no flags Details
journal (154.81 KB, text/plain)
2017-09-21 12:22 UTC, Kamil Páral
no flags Details

Description Kamil Páral 2017-09-21 12:20:40 UTC
Description of problem:
When following
https://fedoraproject.org/wiki/QA:Testcase_upgrade_gnome-software_previous_workstation
a fully updated F25 shows a banner for F26, not F27. (If I try the same on F26, it shows a banner for F27 correctly).

It seems some logic is broken, it should prefer N+2 upgrade before N+1 upgrade.

In ~/.cache/gnome-software/3.22/upgrades/fedora.json I see:

{
  "collections": [
    {
      "allow_retire": false,
      "branchname": "f27",
      "date_created": "2017-09-19 16:44:28",
      "date_updated": "2017-09-19 16:44:28",
      "dist_tag": ".fc27",
      "koji_name": null,
      "name": "Fedora",
      "status": "Under Development",
      "version": "27"
    },
    {
      "allow_retire": false,
      "branchname": "f26",
      "date_created": "2017-02-28 20:24:57",
      "date_updated": "2017-07-11 14:04:59",
      "dist_tag": ".fc26",
      "koji_name": "f26",
      "name": "Fedora",
      "status": "Active",
      "version": "26"
    },
...

The "koji_name" is null, not sure if it matter, otherwise looks valid.


Version-Release number of selected component (if applicable):
gnome-software-3.22.7-2.fc25.x86_64

How reproducible:
100%

Steps to Reproduce:
1. install a fully updated F25 Workstation
2. follow https://fedoraproject.org/wiki/QA:Testcase_upgrade_gnome-software_previous_workstation

Comment 1 Kamil Páral 2017-09-21 12:21:26 UTC
Created attachment 1328980 [details]
fedora.json

Comment 2 Kamil Páral 2017-09-21 12:22:21 UTC
Created attachment 1328981 [details]
journal

Comment 3 Kamil Páral 2017-09-21 12:24:06 UTC
Proposing as a blocker. The criterion says:
"For each one of the release-blocking package sets, it must be possible to successfully complete a direct upgrade from fully updated installations of the last two stable Fedora releases with that package set installed. "
https://fedoraproject.org/wiki/Fedora_27_Beta_Release_Criteria#Upgrade_requirements

The current workaround seems to be to update to F26 first, then to F27.

Comment 4 Kamil Páral 2017-09-21 17:43:43 UTC
Discussed during blocker review [1]:

RejectedBlocker (beta) - There is an workaround to update to F26 or to use another tool.

[1] https://meetbot-raw.fedoraproject.org/fedora-meeting-1/2017-09-21/

Re-proposing as Final.

Comment 5 Kamil Páral 2017-10-02 16:53:42 UTC
Discussed at blocker review meeting [1]:

AcceptedBlocker (Final) - This violates "For each one of the release-blocking package sets, it must be possible to successfully complete a direct upgrade from fully updated installations of the last two stable Fedora releases with that package set installed." for gnome-software on F25.

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2017-10-02/

Comment 6 Adam Williamson 2017-10-13 22:15:32 UTC
Perhaps this may be a case of 'preferring stable upgrades to in-development ones'...does it work if you change the status of Fedora 27 from 'Under Development' to 'Active'?

Comment 7 Adam Williamson 2017-10-13 22:21:17 UTC
Well, having looked at the code, that doesn't look likely, but I can't honestly see how it could be going wrong. Bit odd. Code is https://git.gnome.org/browse/gnome-software/tree/src/plugins/gs-plugin-fedora-distro-upgrades.c?id=79e0e64c8985860def644225c92d80200cd9aef9 , if you want to take a look.

Comment 8 Kamil Páral 2017-10-17 09:33:18 UTC
(In reply to Adam Williamson from comment #6)
> does it work if you change the status of Fedora 27 from 'Under
> Development' to 'Active'?

No, doesn't help.

Comment 9 Adam Williamson 2017-10-20 00:25:44 UTC
As the issue here is in F25, this should be a previous release blocker.

Comment 10 Fedora Update System 2017-10-24 16:19:30 UTC
gnome-software-3.24.3-3.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-4bbc227910

Comment 11 Fedora Update System 2017-10-24 16:19:39 UTC
gnome-software-3.22.7-4.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-c7e6d7da2b

Comment 12 Adam Williamson 2017-10-24 22:22:58 UTC
Note: I adjusted the F26 update to *not* have 'close bugs on stable' checked, because this bug is specifically about 25 -> 27 not showing up, so we only want this bug to be closed when the update goes stable for 25, not 26.

Comment 13 Kamil Páral 2017-10-25 12:28:17 UTC
(In reply to Fedora Update System from comment #11)
> gnome-software-3.22.7-4.fc25 has been submitted as an update to Fedora 25.
> https://bodhi.fedoraproject.org/updates/FEDORA-2017-c7e6d7da2b

This update fixes this problem. However, the upgraded system receives a notification that the upgrade failed (even though it hadn't):
https://bugzilla.gnome.org/show_bug.cgi?id=789477

Comment 14 Fedora Update System 2017-10-26 01:11:18 UTC
gnome-software-3.22.7-4.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-c7e6d7da2b

Comment 15 Fedora Update System 2017-10-26 01:33:25 UTC
gnome-software-3.24.3-3.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-4bbc227910

Comment 16 Fedora Update System 2017-11-01 00:08:36 UTC
gnome-software-3.24.3-3.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2017-11-01 16:42:54 UTC
gnome-software-3.22.7-4.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.