Bug 149407 - nfs-utils makes a nfsnobody user which on 64b platforms is 4294967294
Summary: nfs-utils makes a nfsnobody user which on 64b platforms is 4294967294
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: nfs-utils (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On: 146214
Blocks: 156320 156322
TreeView+ depends on / blocked
 
Reported: 2005-02-22 20:36 UTC by Kent Baxley
Modified: 2007-11-30 22:07 UTC (History)
4 users (show)

Fixed In Version: RHBA-2005-697
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 18:53:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:697 qe-ready SHIPPED_LIVE nfs-utils bug fix update 2005-09-28 04:00:00 UTC

Description Kent Baxley 2005-02-22 20:36:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041215 Firefox/1.0 Red Hat/1.0-12.EL4

Description of problem:
 nfs-utils makes a nfsnobody user which on 64b platforms is 4294967294

 106  # Define the correct unsigned uid value for 32 or 64 bit archs
  107  %ifarch %{all_32bit_archs}
  108  %define nfsnobody_uid   65534
  109  %else
  110  %define nfsnobody_uid   4294967294
  111  %endif
  112
  113  # If UID 65534 (or 4294967294 64bit archs) is unassigned, create user "nfsnobody"
  114  cat /etc/passwd | cut -d':' -f 3 | grep --quiet %{nfsnobody_uid} 2>/dev/null
  115  if [ "$?" -eq 1 ]; then
  116          /usr/sbin/useradd -c "Anonymous NFS User" -r \
  117                  -s /sbin/nologin -u %{nfsnobody_uid} -d /var/lib/nfs nfsnobody 2>/dev/null || :
  118  fi

From the lastlog man page they have:

CAVEATS
      Large  gaps in uid numbers will cause the lastlog program to run longer
      with no output to the screen (i.e. if mmdf=800 and last  uid=170,  pro-
      gram will appear to hang as it processes uid 171-799).

Consequently when the nfs-utils package is installed /var/log/lastlog gets turned into a HUGE sparse file and lastlog takes a long time to run because of the huge gap.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install the nfs-utils package


  

Actual Results:  /var/log/lastlog is turned into a really large sparse file.  Lastlog takes a long time to run.  The customer discovered this when one of their backup like systems died when confronted with the 1.2TB lastlog file.

Expected Results:  The lastlog should not have been so large.  

Additional info:

This bugzilla is tied to IT #64891.  It has been discussed that nfs-utils needs to have an option in it to not add the nfsnobody user to the last database.  

Bugzilla ID 146214 mentions a new shadow-utils from CVS in which there is a new option "-l".  This option tells useradd not to add the user to the last database. 

nfs-utils somehow needs to use this option so it does not add the nfsnobody user to the last database.

Comment 11 Steve Dickson 2005-07-08 12:28:08 UTC
*** Bug 146214 has been marked as a duplicate of this bug. ***

Comment 13 Ray Ferguson 2005-07-20 12:55:51 UTC
This also has an intersting effect on backup utilities that interact with 
lastlog.  IBMs tivoli client spooled through 64GB before I killed it. 

Comment 20 Peter Vrabec 2005-07-27 09:58:24 UTC
Also RHEL4/U2 update is already built 2:4.0.3-49.RHEL4

Comment 22 Steve Dickson 2005-07-27 11:34:10 UTC
This is fixed in RHEL3 with nfs-utils-1.0.6-41EL
and is fixed in RHEL4 with nfs-utils-1.0.6-60.EL4

Comment 25 Steve Dickson 2005-08-02 16:56:42 UTC
This fix is also in nfs-utils-1.0.7-11 available through the FC4 testing channel

Comment 26 Steve Dickson 2005-08-02 17:25:59 UTC
Note: the updated RHEL3 and RHEL4 versions of both the nfs-utils
and newly required shadow-utils packages are available in:

http://people.redhat.com/steved/bz149407/

Comment 28 Red Hat Bugzilla 2005-09-28 18:53:06 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-697.html


Comment 29 Rex Dieter 2005-10-05 12:45:50 UTC
FYI: the added
Requires: shadow-utils 
should really be:
Requires(pre): shadow-utils
as nfs-utils certainly doesn't Require (the newer) shadow-utils after it's
already been installed.  (Or should I file this as a separate bug?)


Note You need to log in before you can comment on or make changes to this bug.