Bug 1494207 - stack trace when client calls 'enabled_repos'
Summary: stack trace when client calls 'enabled_repos'
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Repositories
Version: 6.2.11
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-21 16:45 UTC by Chris Duryee
Modified: 2018-10-03 19:20 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-03 19:20:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 21155 None None None 2017-09-28 20:48:31 UTC

Description Chris Duryee 2017-09-21 16:45:43 UTC
Description of problem:

Occasionally, clients may receive a 500 when calling a PUT on '/rhsm/systems/<UUID>/enabled_repos'.  Short version of error is:


NoMethodError: undefined method `save_bound_repos_by_path!' for nil:NilClass
 | /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.0.0.144/app/controllers/katello/api/rhsm/candlepin_proxies_controller.rb:176:in `block in enabled_repos'
 | /usr/share/foreman/app/models/concerns/foreman/thread_session.rb:72:in `as'
 | /usr/share/foreman/app/models/concerns/foreman/thread_session.rb:78:in `as_anonymous_admin'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.0.0.144/app/controllers/katello/api/rhsm/candlepin_proxies_controller.rb:175:in `enabled_repos'


See attachment for full error from log, including request params.

Version-Release number of selected component (if applicable): 6.2.11 w/ a few hotfixes

I'm not sure how to reproduce this issue, I saw it while looking for an unrelated issue.

Comment 4 Brad Buckingham 2017-09-28 20:48:30 UTC
Created redmine issue http://projects.theforeman.org/issues/21155 from this bug

Comment 5 Bryan Kearney 2018-10-03 19:20:24 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Rich Jerrido or Bryan Kearney. Thank you.


Note You need to log in before you can comment on or make changes to this bug.