Bug 1494221 - Use mariadb-connector-c instead of mysql-libs or mariadb-libs
Summary: Use mariadb-connector-c instead of mysql-libs or mariadb-libs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cqrlog
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Shaw
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1486480
TreeView+ depends on / blocked
 
Reported: 2017-09-21 17:43 UTC by Michal Schorm
Modified: 2018-01-16 17:09 UTC (History)
2 users (show)

Fixed In Version: cqrlog-2.2.0-1.fc26 cqrlog-2.2.0-1.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-16 16:47:29 UTC


Attachments (Terms of Use)

Description Michal Schorm 2017-09-21 17:43:46 UTC
Hello, please apply following command to the package SPECfile:

sed -i "s/mariadb-libs/mariadb-connector-c/" $(fedpkg gimmespec) ;

I've tested, that after the command ^ the package builds successfuly in KOJI.
However, if the RPM don't generate the Requires for the client library automatically, I doubt that the package even use it. Please chceck it and drop the requires, if I'm right.


This change is currently applicable to the Rawhide (f28) only.




For more information check the tracking bugzilla.

Comment 1 Richard Shaw 2017-09-22 12:44:36 UTC
I'll take a look. The mariadb-libs is a Requires not BuildRequires so it would not affect building at all regardless.

I don't run rawhide at all so I'll have to figure out how to test it. Perhaps xnest in a mock chroot.

Comment 2 Richard Shaw 2017-09-22 12:48:02 UTC
Ok, I grepped through the source and it's looking for libmysqlclient.so

# repoquery --disablerepo=* --enablerepo=rawhide --whatprovides "libmysqlclient.so*"
Fedora - Rawhide - Developmental packages for t 5.6 MB/s |  67 MB     00:11
Last metadata expiration check: 0:00:40 ago on Fri 22 Sep 2017 07:45:37 AM CDT.
community-mysql-libs-0:5.7.19-6.fc28.i686
community-mysql-libs-0:5.7.19-6.fc28.x86_64
mariadb-connector-c-0:3.0.2-7.fc28.i686
mariadb-connector-c-0:3.0.2-7.fc28.x86_64
mariadb-libs-3:10.2.8-2.fc28.i686
mariadb-libs-3:10.2.8-2.fc28.x86_64

I'll go ahead and make the change and fix it later if there's any problems.

Comment 3 Fedora Update System 2017-12-31 17:22:15 UTC
cqrlog-2.2.0-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-ba7e224290

Comment 4 Fedora Update System 2017-12-31 17:22:33 UTC
cqrlog-2.2.0-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-28c0a3a38e

Comment 5 Fedora Update System 2017-12-31 19:33:11 UTC
cqrlog-2.2.0-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-ba7e224290

Comment 6 Fedora Update System 2017-12-31 22:07:51 UTC
cqrlog-2.2.0-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-28c0a3a38e

Comment 7 Mike Pittaro 2018-01-01 01:41:03 UTC
Still seems broken under Fedora 27.  I installed cqrlog-2.2.0-1.fc27 from the rpm.

cqrlog generates the error:

Error during connection to database: Can not load default MySQL library ("libmysqlclient.so.16" or "libmysqlclient.so"). Check your installation.

I have mariadb-libs and mariadb-connector-c installed:

mariadb-connector-c.x86_64                                   3.0.2-15.fc27                             @updates
mariadb-libs.x86_64                                          3:10.2.9-3.fc27                           @fedora 

The mariadb-connector-c package is actually empty, while the libs are in mariadb-libs:

root@microhertz ~]# rpm -ql mariadb-libs 
/etc/ld.so.conf.d/mariadb-x86_64.conf
/etc/my.cnf.d/client.cnf
/usr/lib/.build-id
/usr/lib/.build-id/a5
/usr/lib/.build-id/a5/c17835b924d9830cc6b91764d3c3e80f650d05
/usr/lib64/mysql/libmariadb.so.3
/usr/lib64/mysql/libmysqlclient.so.18

[root@microhertz ~]# rpm -ql mariadb-connector-c
(contains no files)


Per the note in the build at https://koji.fedoraproject.org/koji/buildinfo?buildID=996495 the mariadb-connector-c package is supposed to be empty.

cqrlog is looking for a version .16, version .18 is installed, and I suspect  a version mismatch but I don't track mariadb, so no suggestions on what to do.

Comment 8 Richard Shaw 2018-01-01 15:44:40 UTC
Not seeing the same thing on my system. It's looking for .18 and it's installed. I don't think the problem is related to this BZ but something new. 

I've posted to the cqrlog forums to see if someone can point me in the right direction.

It looks like mariadb-connector-c basically pulls in mariadb-libs...

$ rpm -q --requires mariadb-connector-c
mariadb-libs
rpmlib(BuiltinLuaScripts) <= 4.2.2-1
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1

Comment 9 Mike Pittaro 2018-01-03 04:10:19 UTC
My problem was resolved by installing mariadb-libs 3:10.2.10-2.fc27 from updates-testing.

Comment 10 Fedora Update System 2018-01-16 16:47:29 UTC
cqrlog-2.2.0-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2018-01-16 17:09:15 UTC
cqrlog-2.2.0-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.