Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1494273 - Need a new version of python-crane
Summary: Need a new version of python-crane
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Installer
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-21 21:52 UTC by Partha Aji
Modified: 2019-04-01 20:26 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-26 19:00:57 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Partha Aji 2017-09-21 21:52:38 UTC
To pull docker content from Satellite one is going to need the newer version of python-crane 

python-crane-3.0.0-1.el7.noarch and greater.

Comment 1 Mike McCune 2017-09-21 21:54:48 UTC
Without this, users can't docker pull from any Satellite docker repo with 6.3.

flagging regression, just needs a new package version.

Comment 4 Michael Hrivnak 2017-09-25 21:49:09 UTC
I suspect this may have been a miscommunication. dkliban or ipanova, can you comment on whether this is true, and if so, why?

Crane 3.0 specifically added manifest list support, which doesn't arrive in pulp until 2.14. That version of pulp is not currently anticipated to be in sat 6.3.

Comment 5 Ina Panova 2017-09-26 16:03:33 UTC
sat6.3 wich uses pulp2.13 should go with crane 2.1 and not 3.0.

The bug which was preventing to sync docker images  with sat6.3 was fixed in docker *plugin* and goes with pulp 2.13.4


Partha, can this bz be closed?


Note You need to log in before you can comment on or make changes to this bug.