Bug 1494363 - Couldn't log into review.gluster.org with GitHub account
Summary: Couldn't log into review.gluster.org with GitHub account
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: project-infrastructure
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nigel Babu
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-22 06:47 UTC by Zhang Huan
Modified: 2017-10-12 05:59 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-12 05:59:00 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Zhang Huan 2017-09-22 06:47:00 UTC
Description of problem:
Couldn't log into review.gluster.org with my GitHub account, I got the response of "forbidden". I have tried logging out and logging in GitHub again, but still have the same result.

I have been successfully logging into review.gluster.org before, but it was > 2 years ago.

Username of my GitHub account is zhanghuan.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Nigel Babu 2017-09-25 11:28:41 UTC
Hi Zhang, so you might be one of the people affected by the Gerrit migration we did last year when Gerrit enforced a few username-related values. I'll get Gerrit staging up again and we can work out how to get your account working again.

Comment 2 Nigel Babu 2017-10-11 05:01:07 UTC
Hi Zhang,

Staging is back online. Could you confirm that logging in fails for you on staging: https://gerrit-stage.rht.gluster.org

Comment 3 Zhang Huan 2017-10-11 06:03:23 UTC
No, logging in still fails with the result of "Forbidden".

Comment 4 Nigel Babu 2017-10-11 06:59:08 UTC
Can you try again now?

Comment 5 Nigel Babu 2017-10-11 07:03:55 UTC
I've added an entry to your account that *should* potentially make gerrit-github auth work again. Let's see if it pulls it off.

Comment 6 Zhang Huan 2017-10-11 08:54:02 UTC
Nigel,

No, still doesn't work. Same output.

I thought it might be helpful if I revoke OAuth authorization to gluster.org. After doing that, I cannot even open that link. The output is "Server Error" :-)

Comment 7 Nigel Babu 2017-10-11 09:18:09 UTC
Okay, let's see if we can get Gerrit to create you a new account. Can you try to login now. I've removed some evidence of your old account. Hopefully, this means Gerrit will create a new account for you.

Comment 8 Nigel Babu 2017-10-11 09:18:28 UTC
Reminder, try this on https://gerrit-stage.rht.gluster.org

Comment 9 Zhang Huan 2017-10-11 09:57:08 UTC
Yes, it is https://gerrit-stage.rht.gluster.org that I opened. I do that again just now. the output is "Server Error".

Comment 10 Nigel Babu 2017-10-11 10:27:55 UTC
Ah, the Server Error could have been my fault. Can you give it a shot again?

Comment 11 Zhang Huan 2017-10-12 01:55:41 UTC
I can log in via link https://gerrit-stage.rht.gluster.org, and I can list issues now. But there are problems while opening code changes, the output is page not found.

Also, I tried opening review.gluster.org, but the output is "server error" now. I can open it yesterday.

Comment 12 Nigel Babu 2017-10-12 04:11:11 UTC
Excellent. The code changes problem is expected. There's a bug in our ansible configuration that we've not gotten around to fixing.

Problems with review.gluster.org is also expected since I haven't made any of the DB changes there that I've done on staging. Now that we know it's working, I'll make the db changes in production as well.

Comment 13 Nigel Babu 2017-10-12 04:51:34 UTC
I've made the changes for review.gluster.org database. Could you try to login now?

Comment 14 Zhang Huan 2017-10-12 04:52:56 UTC
No, still has the output of "server error"

Comment 15 Nigel Babu 2017-10-12 05:25:45 UTC
I see this: Server returned HTTP response code: 401 for URL: https://api.github.com/user

Can you try deleting the oauth permissions for review.gluster.org and try again?

Comment 16 Zhang Huan 2017-10-12 05:38:06 UTC
There is no oauth authorization for review.gluster.org, I have deleted it yesterday. There is only authorization for gerrit-stage.rht.gluster.org, which should be created this morning. I have tried delete it then open review.gluster.org again, but still get the "server error".

Comment 17 Nigel Babu 2017-10-12 05:42:49 UTC
That's strange. So when you click "Sign-in with Github", you're not redirected to Github at all? You just see Server Error?

Comment 18 Zhang Huan 2017-10-12 05:57:08 UTC
It is OK now. I can log in via my GitHub account and I can list changes and code changes of them.

The problem should be related to cookie or cache of my browser. After I deleted them, I could open the page and then login is OK.

Sorry for the mess, and thank you for your help.

Comment 19 Nigel Babu 2017-10-12 05:59:00 UTC
Hurray! Thank you for your patience as I fixed things up.


Note You need to log in before you can comment on or make changes to this bug.