Bug 149444 - up2date --dry-run --upgrade-to-release changes registered base channel
Summary: up2date --dry-run --upgrade-to-release changes registered base channel
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jason Connor
QA Contact: Beth Nackashi
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 155571 156320
TreeView+ depends on / blocked
 
Reported: 2005-02-23 00:41 UTC by Chris Snook
Modified: 2014-03-31 01:37 UTC (History)
3 users (show)

Fixed In Version: RHBA-2005-712
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 17:14:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:712 qe-ready SHIPPED_LIVE up2date bug fix update 2005-09-28 04:00:00 UTC

Description Chris Snook 2005-02-23 00:41:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3) Gecko/20050104 Red Hat/1.4.3-3.0.7

Description of problem:
The --dry-run flag is not completely honored when using --upgrade-to-release.  While it does not install packages, it does change the registered base channel on RHN, wiping out dependent channels in the process.  This is bad, as attempting to up2date again without changing it back will cause an upgrade, unless something happens to block the upgrade.

Version-Release number of selected component (if applicable):
up2date-4.2.57-2

How reproducible:
Always

Steps to Reproduce:
1. Install RHEL 3 AS, and register with RHN.
2. up2date --dry-run --upgrade-to-release 4AS
3. Log in to RHN and see that your base channel has changed, and you are no longer subscribed to extras.

Actual Results:  My system was changed to an AS 4 system on RHN, though no packages were installed.

Expected Results:  Nothing, besides the list of updated packages and the warnings about dependency problems that should prevent one from upgrading a running RHEL 3 system to RHEL 4 anyway.

Additional info:

While upgrading from RHEL 3 to RHEL 4 isn't something that should be done with up2date, a user could reasonably assume that using the --dry-run flag with --upgrade-to-release to show them what packages are being replaced/obsoleted in the new version is a safe thing to do, and then mess up their system the next time they try to up2date a package.

Comment 2 Adrian Likins 2005-04-19 18:50:29 UTC
fixed in up2date-4.4.15

Comment 3 Chris Snook 2005-04-19 19:25:34 UTC
Thanks!  Will this fix be backported to RHEL 3 and RHEL 2.1?

Comment 4 Debbie McGrath 2005-06-08 14:20:50 UTC
This bug is considered MustFix for RHEL 3 U6 by RHN Engineering.

Comment 6 Debbie McGrath 2005-06-21 21:27:56 UTC
Dev & PM ACKs for U6

Comment 10 Beth Nackashi 2005-07-18 17:10:02 UTC
On i386, I reproduced this problem with up2date-4.2.57, then verified it was
fixed with up2date-4.4.30-3.

Also verified the fix on pseries.  Due to lack of available resources, that was it.

Comment 11 Beth Nackashi 2005-07-18 17:40:14 UTC
wait!  I found a x86_64 box.  Verifying ......... verifying ....... ok.  Done.

Comment 12 Beth Nackashi 2005-07-18 18:53:57 UTC
And an ia64 box!  verifying ......... done.

Bottom line:  Verified on i386, pseries, x86_64, and ia64.

Comment 13 Todd Warner 2005-09-23 21:46:27 UTC
PROD_READY is a deprecated state. This bug is now RELEASE_PENDING.

Comment 14 Red Hat Bugzilla 2005-09-28 17:14:14 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-712.html



Note You need to log in before you can comment on or make changes to this bug.