Bug 1494487 - openshift_disable_check did not take effect during upgrade
Summary: openshift_disable_check did not take effect during upgrade
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cluster Version Operator
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Luke Meyer
QA Contact: liujia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-22 11:14 UTC by liujia
Modified: 2017-10-09 06:16 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-03 18:51:39 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description liujia 2017-09-22 11:14:28 UTC
Description of problem:
Upgrade with specified openshift_disable_check to disable disk_availability,memory_availability, Upgrade still failed for disk and memory check.

Failure summary:


  1. Hosts:    x.x.x.x
     Play:     Verify Host Requirements
     Task:     openshift_health_check
     Message:  One or more checks failed
     Details:  check "memory_availability":
               Available memory (3.5 GiB) is too far below recommended value (8.0 GiB)

  2. Hosts:    x.x.x.x
     Play:     Verify Host Requirements
     Task:     openshift_health_check
     Message:  One or more checks failed
     Details:  check "disk_availability":
               Available disk space in "/var" (6.8 GB) is below minimum recommended (10.0 GB)
               
               check "memory_availability":
               Available memory (3.5 GiB) is too far below recommended value (16.0 GiB)

  3. Hosts:    x.x.x.x
     Play:     Verify Host Requirements
     Task:     openshift_health_check
     Message:  One or more checks failed
     Details:  check "disk_availability":
               Available disk space in "/var" (2.2 GB) is below minimum recommended (5.0 GB)
               
               check "memory_availability":
               Available memory (3.5 GiB) is too far below recommended value (8.0 GiB)
The execution of "/usr/share/ansible/openshift-ansible/playbooks/byo/openshift-cluster/upgrades/v3_7/upgrade.yml" includes checks designed to fail early if the requirements of the playbook are not met. One or more of these checks failed. To disregard these results,explicitly disable checks by setting an Ansible variable:
   openshift_disable_check=disk_availability,memory_availability

Version-Release number of the following components:

Version-Release number of the following components:
atomic-openshift-utils-3.7.0-0.127.0.git.0.b9941e4.el7.noarch

How reproducible:
always

Steps to Reproduce:
1. Install ocp
2. Edit inventory hosts file to add openshift_disable_check variable
<--snip-->
openshift_disable_check=disk_availability,memory_availability,package_availability,docker_image_availability,docker_storage,package_version
3. Run upgrade


Actual results:
Upgrade failed for openshift_health_check

Expected results:
Upgrade succeed with no openshift_health_check.

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 3 liujia 2017-09-25 06:22:10 UTC
Seems can workaround by setting following vars, unmasked "urgent".
openshift_check_min_host_disk_gb=1
openshift_check_min_host_memory_gb=1

Comment 4 Luke Meyer 2017-10-03 18:51:39 UTC
I think openshift_disable_check is working fine. The problem is that you've specified it twice in your inventory file:

openshift_disable_check=disk_availability,memory_availability,package_availability,docker_image_availability,docker_storage,package_version
openshift_disable_check=docker_storage

Of course it uses the last one.

Feel free to reopen if it's still a problem.

Comment 5 liujia 2017-10-09 06:16:36 UTC
Thx, it's a wrong configure. Sorry for the mistake.


Note You need to log in before you can comment on or make changes to this bug.