Bug 149449 - X crashes or hangs when running dual head
X crashes or hangs when running dual head
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2005-02-23 00:03 EST by Tony Howard
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-05-17 01:52:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 2597 None None None Never

  None (edit)
Description Tony Howard 2005-02-23 00:03:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041111 Firefox/1.0

Description of problem:
'm trying to get X working with 2 video cards - the builtin graphics (Intel 845G chipset) using the i810 driver, and a pci Nvidia GeForce4 MX 4000 using the
Nvidia 6629 driver.  I'm using kernel 2.6.10.  When I boot the machine, the
BIOS has an option to select whether the primary graphics should be AGP or
PCI. When I set it to AGP, I can start X on the Intel graphics, but when I
try the Nvidia, the X server crashes.  When I set the primary graphics
device to PCI, X will start on the Nvidia card, but I get these errors
when I try to start it on the Intel:

(EE) I810(0): Cannot read V_BIOS
(EE) I810(0): VBE initialization failed.

I've tried running both X servers separately, and together - same
results.  I've also tried the NoInt10 option for the i810 driver, but it
still won't start.  I think X is always querying the BIOS for
information about the video card, and the BIOS returns info for whatever
card is set as the primary, regardless of which one X is set to use.
Here are the config files I'm using:

X only on i810:
X only on nvidia:
X on both:

Here are the logs from when I try to start the X server:
X on i810, bios set to AGP, works:
X on i810, bios set to PCI, X won't start:
X on nvidia, bios set to AGP, X crashes:
X on nvidia, bios set to PCI, works:

I also tried the vesa driver, but it says that it can't find a device
matching the device id I put in the config file. 

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Set the BIOS to use 1 video card (agp/pci) as primary
2. Configure X for the other video card
3. Start the X server

Actual Results:  When BIOS is PCI, X with i810 driver fails to start.  When BIOS is AGP, X on nvidia crashes, and I can't kill the crashed process.

Expected Results:  The server should start successfully.

Additional info:
Comment 1 Mike A. Harris 2005-02-23 18:16:37 EST
Thanks for the report.  For users who are experiencing problems
installing, configuring, or using the unsupported 3rd party
proprietary "nvidia" video driver, Nvidia provides indirect
customer support via an online web based support forum.  Nvidia
monitors these web forums for commonly reported problems and
passes them on to Nvidia engineers for investigation.  Once
they've isolated a particular problem, it is often fixed in
a future video driver update.

The NVNews Nvidia Linux driver forum is located at:


Once you have reported this issue in the Nvidia web forums,
others who may have experienced the particular problem may
be able to assist.  If there is a real bug occuring, Nvidia
will be able to determine this, and will likely resolve the
issue in a future driver update for the operating system
releases that they officially support.

While Red Hat does not support the proprietary nvidia driver,
users requiring technical support may also find the various
X.Org, XFree86, and Red Hat mailing lists helpful in finding

X.Org mailing lists:

XFree86 mailing lists:

Red Hat mailing lists:

Setting status to "NOTABUG" (unsupported).

Comment 2 Tony Howard 2005-02-25 12:51:33 EST
When I set the bios to use PCI as primary display, I'm not actually using any 
nvidia drivers.  The machine boots using the kernel console driver for the 
nvidia card.  When I try to start the X server for the builtin graphics (i810 
driver), the server crashes.  Please see: 
X only on i810: 
X on i810, bios set to PCI, X won't start: 
I probably shouldn't have added the part about what happens when I try to use 
the nvidia X drivers, but nvidia console plus i810 X server should work, 
Comment 3 Mike A. Harris 2005-04-15 09:25:50 EDT
Please report this problem to X.Org developers via X.org bugzilla, located
at http://bugs.freedesktop.org in the "xorg" component, as this is most likely
a generic problem that is not distribution specific.  Nvidia also has a
component there for their proprietary driver.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.
Comment 4 Mike A. Harris 2005-04-15 09:27:00 EDT
Setting status to "NEEDINFO", and awaiting upstream bug report for
Comment 5 Tony Howard 2005-04-18 10:46:17 EDT
(In reply to comment #4) 
> Setting status to "NEEDINFO", and awaiting upstream bug report for 
> tracking. 
I have already reported this on the X.org bugzilla site, here. 
The bug I opened actually encompasses 2 problems - one being running the 
i810 driver with PCI as the primary video device, and the other being running 
the proprietary nvidia driver with AGP as the primary video device.  I 
reported them together since I suspected that the underlying problem was not 
specific to the video card driver. 
Comment 6 Mike A. Harris 2005-05-17 01:52:13 EDT
Thanks for the URL.  Adding to our upstream tracker.

Note You need to log in before you can comment on or make changes to this bug.