Bug 1494513 - ovirt-host package is unintentionally removed during firewalld configuration on the host
Summary: ovirt-host package is unintentionally removed during firewalld configuration ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-ansible-roles
Version: 2.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-4.2.0
: ---
Assignee: Ondra Machacek
QA Contact: Pavol Brilla
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-22 11:57 UTC by Sandro Bonazzola
Modified: 2019-05-16 13:20 UTC (History)
2 users (show)

Fixed In Version: ovirt-ansible-roles-1.1.1-0.el7ev
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-15 18:00:47 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github oVirt ovirt-ansible issues 96 0 None None None 2017-09-22 17:05:37 UTC
Github oVirt ovirt-ansible pull 97 0 None None None 2017-09-25 12:25:30 UTC
Red Hat Product Errata RHEA-2018:1534 0 None None None 2018-05-15 18:01:13 UTC

Description Sandro Bonazzola 2017-09-22 11:57:44 UTC
Description of problem:
ovirt-host package is removed on deployed hosts

Version-Release number of selected component (if applicable):
ovirt-engine-4.2.0-0.0.master.20170920172148.git8366a0b.el7.centos.noarch
ovirt-host-deploy-1.7.0-0.0.master.20170912090102.git1eeb5a2.el7.centos.noarch

How reproducible:
tried only once

Steps to Reproduce:
Using CentOS minimal.
1. Install from http://resources.ovirt.org/pub/yum-repo/ovirt-release42-pre.rpm
2. Deploy an host
3. check if ovirt-host is installed

Actual results:

rpm -qv ovirt-host
package ovirt-host is not installed

Expected results:
ovirt-host should be installed.

Additional info:
I installed the host withi a firewalld cluster.
Manually installing ovirt-host:
=================================================================================================================
 Package                    Arch    Version                                                 Repository      Size
=================================================================================================================
Installing:
 ovirt-host                 noarch  4.2.0-0.0.master.20170913090858.git0bfa7ab.el7.centos   ovirt-4.2-pre  7.6 k
Installing for dependencies:
 cockpit-ovirt-dashboard    noarch  0.11.1-0.0.master.el7.centos                            ovirt-4.2-pre  3.3 M
 iptables-services          x86_64  1.4.21-18.0.1.el7.centos                                base            51 k
 ovirt-hosted-engine-setup  noarch  2.2.0-0.0.master.20170919052946.git896e399.el7.centos   ovirt-4.2-pre  331 k

Transaction Summary
=================================================================================================================
Install  1 Package (+3 Dependent packages)


I've the feeling this is caused by some ansible command in post-deploy phase.
Note that this cause also not being able to deploy additional hosts for hosted engine on clusters with firewalld enabled.

Comment 4 Pavol Brilla 2018-01-17 10:06:25 UTC
# yum list ovirt-engine
ovirt-engine.noarch     4.2.1.1-0.1.el7       @rhv-4.2x


# yum list ovirt-host
ovirt-host.x86_64    4.2.1-1.el7ev     @rhv-4-mgmt-agentx


Host added succesfully

Comment 9 errata-xmlrpc 2018-05-15 18:00:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1534

Comment 10 Franta Kust 2019-05-16 13:09:30 UTC
BZ<2>Jira Resync


Note You need to log in before you can comment on or make changes to this bug.