Bug 149459 - 2 * bad format in printf problems
2 * bad format in printf problems
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: cfengine (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Sheltren
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-23 06:35 EST by David Binderman
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-05 17:47:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Binderman 2005-02-23 06:35:09 EST
Description of problem:

I just tried to compile package cfengine-2.1.9-2 from 
Redhat Fedora Extras development tree.

The compiler said

1.

eval.c(653): warning #267: the format string requires additional arguments

The source code is

      Debug4("Checking AND Atom %s?\n");

%s specifier, not trailing parameter.

2.

cfexecd.c(931): warning #269: invalid format string conversion

The source code is

sscanf(to,"%s@%.64s",domain);

. not valid in %s specifier. Maybe

sscanf(to,"%s@%64s",domain);

was what the programmer intended ?


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Michael Schwendt 2005-02-23 09:35:17 EST
Please see whether you can reproduce this with the newer cfengine from
Fedora Core Development.
Comment 2 Jeff Sheltren 2005-03-25 11:26:16 EST
Are you compiling with gcc4?  If so, there are some issues with the current
release and I'm working with the author to get it fixed.  If you're using gcc3,
it should compile fine.  You can also try version 2.1.13 which is now in extras.
Comment 3 David Binderman 2005-03-25 12:08:34 EST
>Are you compiling with gcc4? 

No - Intel 8.1 - much better error messages - see above.

>You can also try version 2.1.13 which is now in extras.

Sorry, but I won't be able to do this. Suggest you might like
to use Mark 1 eyeball to confirm that the problems I found are
gone in the latest version.
Comment 4 Jeff Sheltren 2005-07-05 17:47:55 EDT
OK, I've passed on your errors to Mark (the author of cfengine).  Hopefully they
will get fixed in the next upstream release.

Note You need to log in before you can comment on or make changes to this bug.