Bug 149463 - local variable used before set
Summary: local variable used before set
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: conglomerate   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phillip Compton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-23 11:42 UTC by David Binderman
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-25 19:52:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Binderman 2005-02-23 11:42:28 UTC
Description of problem:

I just tried to compile package conglomerate-0.9.0-1 from 
Redhat Fedora Extras development tree.

The compiler said

cong-error-file-save.c(162): remark #592: variable "volume_capacity"
is used before its value is set

The source code is

	char* volume_capacity_string =
gnome_vfs_format_file_size_for_display(volume_capacity);

Suggest initialise volume_capacity before first use.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Phillip Compton 2005-02-24 19:22:02 UTC
WFM, no error on FC3.

Can you provide some additional information:
which release of Fedora are you using?
are you using any kind of build system?
is there anything custom about your system (not core + extras)?

Comment 2 Michael Schwendt 2005-02-24 20:36:05 UTC
He's looking for compiler warnings, probably adding -Wall to rpm
optflags and rebuilding all of Extras.

This one is not a bug. Rationale given in lines 152-159.


Comment 3 David Binderman 2005-02-25 09:38:16 UTC
>are you using any kind of build system?

The clue is in the remark message - I hope you can recognise
that it isn't a message produced by the GNU C compiler.

In fact, I am using the most excellent Intel C compiler
- better messages (see above) and better code generation.

For conglomerate, this does appear to be code that is
"work in progress" - plenty of commented out bits.


Note You need to log in before you can comment on or make changes to this bug.