Bug 149465 - __prelink_undo_cmd related MD5 sum mismatch when a package has a copy of libgcc_s.so.1 during rpmbuild
__prelink_undo_cmd related MD5 sum mismatch when a package has a copy of libg...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
http://people.redhat.com/caolanm/rpmt...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-23 07:24 EST by Caolan McNamara
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-23 10:43:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
testcase (39.02 KB, application/x-rpm)
2005-02-23 07:25 EST, Caolan McNamara
no flags Details

  None (edit)
Description Caolan McNamara 2005-02-23 07:24:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041220

Description of problem:
Given an src.rpm like the above, rpm --install the result of rpmbuild -bb gives the error 

cpio: MD5 sum mismatch

this is an odd edge case which affect openoffice.org developers who build the upstream openoffice.org 1.9.X under fedora where as part of the openoffice.org packaging libgcc_so.1 is copied into their install set.

Version-Release number of selected component (if applicable):
rpm-4.4.1-2

How reproducible:
Always

Steps to Reproduce:
1. rpmbuild -bs rpmtest-1.0-1.src.rpm
2. rpm --install rpmtest-1.0-1.i386.rpm
  

Actual Results:  cpio: MD5 sum mismatch

Additional info:
Comment 1 Caolan McNamara 2005-02-23 07:25:22 EST
Created attachment 111331 [details]
testcase
Comment 2 Jeff Johnson 2005-02-23 08:03:27 EST
The attached rpmtest-1.0-1.src.rpm builds and installs for me.
Comment 3 Fridrich Strba 2005-02-23 08:25:31 EST
The result for me:

RedHat Enterprise Linux 3 -- rpm-build-4.2.3-13 -- installs OK
RedHat Enterprise Linux 4 -- rpm-build-4.3.3-7_nonptl -- md5 sum mismatch
Fedora Core 3 -- rpm-build-4.3.2-21 -- md5 sum misamatch
Comment 4 R P Herrold 2005-02-23 09:08:07 EST
working on YDL 4


[herrold@emac rpmtest-bug149465]$ rpmbuild -bs rpmtest-1.0-1.src.rpm
error: File /home/herrold/build/rpmtest-bug149465/rpmtest-1.0-1.src.rpm does not
appear to be a specfile.
[herrold@emac rpmtest-bug149465]$ rpmbuild --rebuild rpmtest-1.0-1.src.rpm >
/dev/null 2>&1
[herrold@emac rpmtest-bug149465]$ sudo rpm -Uvh
/home/herrold/rpmbuild/RPMS/ppc/rpmtest-1.0-1.ppc.rpm
Preparing...                ########################################### [100%]
   1:rpmtest                ########################################### [100%]
[herrold@emac rpmtest-bug149465]$ uname -a
Linux emac.first.lan 2.6.8-1.ydl.7 #1 Wed Sep 22 18:46:40 EDT 2004 ppc ppc ppc
GNU/Linux
[herrold@emac rpmtest-bug149465]$       
Comment 5 Sarantis Paskalis 2005-02-23 09:58:04 EST
FC3 with updates failing for me.

I noticed this strange line in the rpm building output just before the Provides:
and Requires: stuff

prelink: /var/tmp/rpmtest-1.0-root/usr/lib/rpmtest/libgcc_s.so.1: prelinked file
was modified



Comment 6 Caolan McNamara 2005-02-23 10:37:10 EST
Yeah, that's it. With prelink installed I have the problem. If I
comment out the undo line in /etc/rpm/macros.prelink then it works
fine. Perhaps this is a prelink issue then.
Comment 7 Jakub Jelinek 2005-02-23 10:43:40 EST
You should never package prelinked binaries or shared libraries.
Making a local copy of an already installed library is silly, you should instead
simply use the system library and require (perhaps automatically) the package
that provides it.
If you really want to do something this silly, either build the package on
unprelinked system or unprelink it in the makefile.
I.e. either replace cp /lib/libgcc_s.so.1 . with prelink -uo ./libgcc_s.so.1
/lib/libgcc_s.so.1 or
cp /lib/libgcc_s.so.1 . && prelink -u ./libgcc_s.so.1
Comment 8 Toralf 2006-02-16 05:40:34 EST
(In reply to comment #7)
> You should never package prelinked binaries or shared libraries.
> Making a local copy of an already installed library is silly
I think that remark is what's silly, especially from someone at @redhat.com,
since you (i.e. Red Hat) actually recommend distributing your own copy of some
of the libraries that are also bundled with the OS. See

https://www.redhat.com/f/pdf/rhel4/AppCompat.pdf

Note that libgcc_s is not included in the list of "Core Libraries".

Just thought I might mention it since we just ran into the same problem here...

Note You need to log in before you can comment on or make changes to this bug.