Bug 1494931 - Dnf not showing subpackages from a Copr repo
Summary: Dnf not showing subpackages from a Copr repo
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core
Version: 25
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Jaroslav Mracek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-24 07:13 UTC by srakitnican
Modified: 2017-10-17 10:24 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-17 10:24:26 UTC
Type: Bug


Attachments (Terms of Use)

Description srakitnican 2017-09-24 07:13:56 UTC
Description of problem: dnf shows only main packages for a Copr repo.


Version-Release number of selected component (if applicable):
dnf-1.1.10-6.fc25.noarch
dnf-plugins-core-0.1.21-5.fc25.noarch


How reproducible: Always


Steps to Reproduce:
1. dnf copr enable srakitnican/moksha-desktop
2. dnf repo-pkgs srakitnican-moksha-desktop list all

Actual results:
Available Packages
moksha-desktop.src                   0.2.1-1.fc25     srakitnican-moksha-desktop
moksha-desktop-debuginfo.x86_64      0.2.1-1.fc25     srakitnican-moksha-desktop
moksha-desktop-devel.x86_64          0.2.1-1.fc25     srakitnican-moksha-desktop
moksha-e_dbus.src                    1.7.10-1.fc25    srakitnican-moksha-desktop
moksha-e_dbus-debuginfo.x86_64       1.7.10-1.fc25    srakitnican-moksha-desktop
moksha-e_dbus-devel.x86_64           1.7.10-1.fc25    srakitnican-moksha-desktop
moksha-module-clipboard.src          0.0.1-1.20170922git5fb4d43.fc25
                                                      srakitnican-moksha-desktop
moksha-module-clipboard-debuginfo.x86_64
                                     0.0.1-1.20170922git5fb4d43.fc25
                                                      srakitnican-moksha-desktop
moksha-modules-extra.src             0.0.1-1.20170918git752dafe.fc25
                                                      srakitnican-moksha-desktop
moksha-pulsemixer.src                0.0.1-1.20170919git254b36b.fc25
                                                      srakitnican-moksha-desktop
moksha-pulsemixer.x86_64             0.0.1-1.20170919git254b36b.fc25
                                                      srakitnican-moksha-desktop
moksha-pulsemixer-debuginfo.x86_64   0.0.1-1.20170919git254b36b.fc25
                                                      srakitnican-moksha-desktop



Expected results: There are 24 subpackages from moksha-modules-extra alone which are expected to be shown.


Additional info:

Comment 1 Daniel Mach 2017-09-27 11:41:08 UTC
Can you confirm the problem persists with --refresh option?

Comment 2 srakitnican 2017-09-27 14:01:49 UTC
(In reply to Daniel Mach from comment #1)
> Can you confirm the problem persists with --refresh option?

With the --refresh option I get the same output. Actually I think it is showing the packages that are available to install. I am noticing now there are only source and debug packages listed here, except moksha-pulsemixer.x86_64 which I have available to upgrade all other x86_64 packages are installed already.

At the same time "installed" option does not show the installed packages, although I've installed them from command line, not from repository so I am guessing it is working as expected then.

Comment 3 Jaroslav Mracek 2017-10-13 15:26:54 UTC
If I good understand, the problem is not reproducible anymore, therefore we can close it. Please if you will experience the problem again, don't hesitate to reopen the bug report.

Comment 4 srakitnican 2017-10-14 22:34:54 UTC
Hi,

I am getting a different result, not necessarily a correct one now, not sure why, was there a fix?
There is definitely something strange going on, maybe rebuilt package triggered this different behavior. There are many packages listed now, but there are still missing packages from this list.


$ sudo dnf repo-pkgs srakitnican-moksha-desktop list all
Last metadata expiration check: 1:25:20 ago on Sat Oct 14 23:03:59 2017.
Installed Packages
moksha-emprint.x86_64                      0.0.1-2.20171002git5296b81.fc25    @srakitnican-moksha-desktop
moksha-module-alarm.x86_64                 0.0.1-2.20171002git5296b81.fc25    @srakitnican-moksha-desktop
moksha-module-calendar.x86_64              0.0.1-2.20171002git5296b81.fc25    @srakitnican-moksha-desktop
moksha-module-cpu.x86_64                   0.0.1-2.20171002git5296b81.fc25    @srakitnican-moksha-desktop
moksha-module-deskshow.x86_64              0.0.1-2.20171002git5296b81.fc25    @srakitnican-moksha-desktop
moksha-module-diskio.x86_64                0.0.1-2.20171002git5296b81.fc25    @srakitnican-moksha-desktop
moksha-module-engage.x86_64                0.0.1-2.20171002git5296b81.fc25    @srakitnican-moksha-desktop
moksha-module-flame.x86_64                 0.0.1-2.20171002git5296b81.fc25    @srakitnican-moksha-desktop
moksha-module-forecasts.x86_64             0.0.1-2.20171002git5296b81.fc25    @srakitnican-moksha-desktop
moksha-module-mail.x86_64                  0.0.1-2.20171002git5296b81.fc25    @srakitnican-moksha-desktop
moksha-module-mem.x86_64                   0.0.1-2.20171002git5296b81.fc25    @srakitnican-moksha-desktop
moksha-module-net.x86_64                   0.0.1-2.20171002git5296b81.fc25    @srakitnican-moksha-desktop
moksha-module-news.x86_64                  0.0.1-2.20171002git5296b81.fc25    @srakitnican-moksha-desktop
moksha-module-penguins.x86_64              0.0.1-2.20171002git5296b81.fc25    @srakitnican-moksha-desktop
moksha-module-photo.x86_64                 0.0.1-2.20171002git5296b81.fc25    @srakitnican-moksha-desktop
moksha-module-places.x86_64                0.0.1-2.20171002git5296b81.fc25    @srakitnican-moksha-desktop
moksha-module-rain.x86_64                  0.0.1-2.20171002git5296b81.fc25    @srakitnican-moksha-desktop
moksha-module-screenshot.x86_64            0.0.1-2.20171002git5296b81.fc25    @srakitnican-moksha-desktop
moksha-module-share.x86_64                 0.0.1-2.20171002git5296b81.fc25    @srakitnican-moksha-desktop
moksha-module-slideshow.x86_64             0.0.1-2.20171002git5296b81.fc25    @srakitnican-moksha-desktop
moksha-module-snow.x86_64                  0.0.1-2.20171002git5296b81.fc25    @srakitnican-moksha-desktop
moksha-module-tclock.x86_64                0.0.1-2.20171002git5296b81.fc25    @srakitnican-moksha-desktop
moksha-module-trash.x86_64                 0.0.1-2.20171002git5296b81.fc25    @srakitnican-moksha-desktop
moksha-module-winlist-ng.x86_64            0.0.1-2.20171002git5296b81.fc25    @srakitnican-moksha-desktop
moksha-module-winselector.x86_64           0.0.1-2.20171002git5296b81.fc25    @srakitnican-moksha-desktop
moksha-modules-extra.x86_64                0.0.1-2.20171002git5296b81.fc25    @srakitnican-moksha-desktop
moksha-modules-extra-debuginfo.x86_64      0.0.1-2.20171002git5296b81.fc25    @srakitnican-moksha-desktop
moksha-pulsemixer.x86_64                   0.0.1-1.20170919git254b36b.fc25    @srakitnican-moksha-desktop
Available Packages
moksha-desktop.src                         0.2.1-1.fc25                       srakitnican-moksha-desktop 
moksha-desktop-debuginfo.x86_64            0.2.1-1.fc25                       srakitnican-moksha-desktop 
moksha-desktop-devel.x86_64                0.2.1-1.fc25                       srakitnican-moksha-desktop 
moksha-e_dbus.src                          1.7.10-1.fc25                      srakitnican-moksha-desktop 
moksha-e_dbus-debuginfo.x86_64             1.7.10-1.fc25                      srakitnican-moksha-desktop 
moksha-e_dbus-devel.x86_64                 1.7.10-1.fc25                      srakitnican-moksha-desktop 
moksha-module-clipboard.src                0.0.1-1.20170922git5fb4d43.fc25    srakitnican-moksha-desktop 
moksha-module-clipboard-debuginfo.x86_64   0.0.1-1.20170922git5fb4d43.fc25    srakitnican-moksha-desktop 
moksha-modules-extra.src                   0.0.1-2.20171002git5296b81.fc25    srakitnican-moksha-desktop 
moksha-pulsemixer.src                      0.0.1-1.20170919git254b36b.fc25    srakitnican-moksha-desktop 
moksha-pulsemixer-debuginfo.x86_64         0.0.1-1.20170919git254b36b.fc25    srakitnican-moksha-desktop 

Missing packages:
moksha-desktop-0.2.1-1.fc25.x86_64.rpm
moksha-desktop-data-0.2.1-1.fc25.noarch.rpm
moksha-e_dbus-1.7.10-1.fc25.x86_64.rpm
moksha-module-clipboard-0.0.1-1.20170922git5fb4d43.fc25.x86_64.rpm

https://copr.fedorainfracloud.org/coprs/srakitnican/moksha-desktop/packages/

Comment 5 srakitnican 2017-10-15 05:55:20 UTC
So the issue is maybe that the packages were installed from command line, in that case I am not sure how should repo-pkgs behave, but I would expect the packages appear in some of the lists, Installed/Available etc..

$ sudo dnf list installed moksha-desktop{,-data} moksha-e_dbus moksha-module-clipboard
Last metadata expiration check: 8:48:43 ago on Sat Oct 14 23:03:59 2017.
Installed Packages
moksha-desktop.x86_64                        0.2.1-1.fc25                                   @System      
moksha-desktop-data.noarch                   0.2.1-1.fc25                                   @System      
moksha-e_dbus.x86_64                         1.7.10-1.fc25                                  @@commandline
moksha-module-clipboard.x86_64               0.0.1-1.20170922git5fb4d43.fc25                @System

Comment 6 Jaroslav Mracek 2017-10-17 10:24:26 UTC
Here is very difficult how to implement. List command has strange logic to me. It shows installed packages and available only packages with higher version. Command repo-pkgs adds additional rule to show only installed packages from selected repository. But rule for available remains. If you want to see all packages please use repoquery command. It doesn't apply any fancy selection and output can be even formatted. I am sorry, the behavior is strange but correct.


Note You need to log in before you can comment on or make changes to this bug.