Bug 149501 - some themes has lost icons
some themes has lost icons
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdeartwork (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2005-02-23 12:36 EST by shrek-m
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-23 07:14:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Bug Screenshot (341.15 KB, image/png)
2005-03-30 21:56 EST, Sean Earp
no flags Details
gnome menu edu - jpg (47.96 KB, image/jpeg)
2005-03-31 16:07 EST, shrek-m
no flags Details
gnome menu grafik - jpg (60.95 KB, image/jpeg)
2005-03-31 16:10 EST, shrek-m
no flags Details

  None (edit)
Description shrek-m 2005-02-23 12:36:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041020

Description of problem:
the icons (computer, desktop, trash, 1/2 menus eg. edutainment, ...) are lost after the last (i guess redhat-artwork) rawhide update.

# grep redhat-artwork /var/log/yum.log*
/var/log/yum.log.1:Feb 20 12:08:43 Updated: redhat-artwork.ppc 0.120-5
/var/log/yum.log.1:Feb 20 13:06:38 Updated: redhat-artwork.ppc 0.120-5

theme details
window = smokey-blue
windowborder = crux
icons = gnome

if i try to add a new icon eg for "Computer" (rihght-click, properties, embleme) there is an empty icon list.

Version-Release number of selected component (if applicable):
redhat-artwork.ppc 0.120-5

How reproducible:
Always

Steps to Reproduce:
1. rawhide update
2. reboot
3. login

Actual Results:  the most icons are lost

Additional info:

bluecurve is ok
Comment 1 Sean Earp 2005-03-27 02:23:55 EST
I can confirm the problem.  I just did a format of my hard drive, did a clean
install of FC4Test1 followed by a full yum update, and when I log into GNOME, I
get the horrendously ugly default icons, gnome foot, mozilla browser icon, etc.

If I change to Bluecurve, most of the icons change to their pretty Red Hat
equivelants, although the GNOME foot never goes away.  KDE seems to work okay,
so I am not sure if this is a problem with one of the GNOME components or
redhat-artwork.  

I am currently using:
[smearp@localhost ~]$ rpm -q redhat-artwork
redhat-artwork-0.121-1

For that matter, when logged into the GNOME desktop, all the icons are missing
for KDE programs.  I will log into KDE and report back as to whether or not they
show up there...

Please let me know if there is anything I can do to help pinpoint the problem. 
Thanks!
Comment 2 Sean Earp 2005-03-27 02:37:02 EST
An addendum to the above.  The icons for everything show up fine in KDE 
(including the aforementioned KDE programs with no icons in GNOME).  For the
life of me I can't figure out how to switch themes in KDE or I'd try it (Control
center just lets you switch KDE theme components...)

-Sean
Comment 3 John (J5) Palmieri 2005-03-30 12:05:30 EST
Default theme has switch from bluecurve to gnome icon's using the clearlooks
engine.  I'll look into some of the issues such as the mozilla icon showing up
instead of a generic web browser icon when the design team gets back.  As for
emblems not showing up I could not reproduce that error as they are fine with
all themes on my computer.  Can either of you take a screenshot of your desktops
and point out where the problems are.  Thanks.
Comment 4 Sean Earp 2005-03-30 21:56:59 EST
Created attachment 112498 [details]
Bug Screenshot

I am attaching a screenshot showing all of my reported problems (The default
GNOME foot, browser icon, desktop icons, and missing KDE icons).  Please let me
know if there is anything else I can do to help pinpoint the problem.  Thanks!
Comment 5 shrek-m 2005-03-31 16:05:10 EST
$ rpm -qa *artwork*
kdeartwork-icons-3.4.0-1
kdeartwork-3.4.0-1
redhat-artwork-0.121-2


+ desktop-icons (computer,home,trash) are ok now
+ right-click/properties/embleme = icons are ok now

- the menu-icons  (kde icons ?) are lost, see attchments
Comment 6 shrek-m 2005-03-31 16:07:59 EST
Created attachment 112541 [details]
gnome menu edu - jpg
Comment 7 shrek-m 2005-03-31 16:10:12 EST
Created attachment 112542 [details]
gnome menu grafik - jpg
Comment 8 John (J5) Palmieri 2005-04-14 16:46:57 EDT
Are the kde icons still not showing up?
Comment 9 shrek-m 2005-04-16 17:22:36 EDT
no,
clean fc4t2 install without kde*

# yum install kdeedu kdeartwork-icons
# yum update *artwork*

logout/login
reboot

the kde-icons are not showing up in edutainment
Comment 10 John (J5) Palmieri 2005-04-16 17:32:17 EDT
Reassinging to kdeartwork.  This looks like perhaps we need to run
gtk-update-icon-cache in the post to update the gnome icon cash with the new icons.
Comment 11 shrek-m 2005-04-16 17:50:20 EDT
the icons are lost in the most cases.

the icons are ok in this few theme-icons.
themedetails
  window = *
  windowborder = *
  icons = bluecurve, crystal svg, slick icons (kde classic, kde locolor)
Comment 12 Sean Earp 2005-04-17 21:31:26 EDT
The KDE icons do not show up in a clean install of FC4T2 that's been yum updated
to rawhide today.  They do show up fine in Bluecurve, but not in Clearlooks.

-Sean
Comment 13 Sean Earp 2005-04-17 21:36:40 EDT
And a quick related question...  Separate from the missing KDE artwork in GNOME,
is GNOME in Fedora (using clearlooks) supposed to be using the default GNOME
artwork, or should redhat-artwork be overriding the gnome foot, and ugly default
Mozilla and Email icons on the GNOME panel? 

-Sean
Comment 14 John (J5) Palmieri 2005-04-18 11:08:39 EDT
(In reply to comment #13)
Thi sis fixed in rawhide.  We are shipping Clearlooks w/ the Bluecurve icon set
Comment 15 Ngo Than 2005-04-18 13:19:03 EDT
The problem is that the most icons of kde applications are installed
under /usr/share/icons/crystalsvg and it works fine with Bluecurve because
Bluecurve icon theme is inherited from crystalsvg!

I don't think it's a bug in kde. If you add this line in
/usr/share/icons/Clearlooks/index.theme in section "[Icon Theme]", it should work.

Inherits=hicolor,crystalsvg 
Comment 16 shrek-m 2005-04-18 19:47:28 EDT
thanks, this is the solution,
it is ok now for Clearlocks.

fyi
the most  index.theme  have  Inherits=gnome
i added your line in gnome/index.theme 
not the directly way (theme->gnome->crystalsvg) but it is ok now for other themes.

# head -3 /usr/share/icons/gnome/index.theme
[Icon Theme]
Inherits=hicolor,crystalsvg
Name=GNOME
Comment 17 John (J5) Palmieri 2005-04-20 17:56:48 EDT
Sorry than, throwing it back to you.  I was informed that according to the
freedesktop icon theme spec all application icons need to be installed to
/usr/share/icons/hicolor/48x48/apps/.  The kdeedu package already does this for
kturtle (well it throws 24x24 and 32x32 icons in but it should throw in the
48x48 according to the spec).  kdeartwork and all the other kde packages that
have application icons need to do this.

Link to the icon spec:
http://standards.freedesktop.org/icon-theme-spec/icon-theme-spec-latest.html
Comment 18 Ngo Than 2005-06-23 07:14:15 EDT
it's already fixed in current FC4 release. 

Note You need to log in before you can comment on or make changes to this bug.