Bug 1495099 - font rendering got changed after urw-base35-fonts-20170801-1 update
Summary: font rendering got changed after urw-base35-fonts-20170801-1 update
Keywords:
Status: CLOSED DUPLICATE of bug 1494850
Alias: None
Product: Fedora
Classification: Fedora
Component: urw-base35-fonts
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Kaspar // Dee'Kej
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-25 08:12 UTC by Parag Nemade
Modified: 2017-09-25 15:03 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-25 15:03:16 UTC
Type: Bug


Attachments (Terms of Use)

Description Parag Nemade 2017-09-25 08:12:29 UTC
Description of problem:
I was just thinking what package now changed the font rendering and found its this urw-base35-fonts package actually.
I compared RC2 image results with my working F27 updates-testing packages applied system and found this
serif: URWBookman-Light.t1: "URW Bookman" "Light"
sans-serif: URWGothic-Book.t1: "URW Gothic" "Book"
monospace: NimbusMonoPS-Regular.t1: "Nimbus Mono PS" "Regular"

whereas this should have been using the default font names
serif: DejaVuSerif.ttf: "DejaVu Serif" "Book"
sans-serif: DejaVuSans.ttf: "DejaVu Sans" "Book"
monospace: DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"


Version-Release number of selected component (if applicable):
urw-base35-fonts-20170801-1

How reproducible:
always

Steps to Reproduce:
1. just fc-match for serif, sans-serif, monospace
2.
3.

Actual results:
Changed the default fonts

Expected results:
should keep default fonts

Additional info:

Comment 1 Parag Nemade 2017-09-25 08:19:18 UTC
Plus the another issue is that I can't even downgrade this package

$ sudo dnf downgrade urw-base35-fonts
Last metadata expiration check: 4:42:18 ago on Mon 25 Sep 2017 09:04:50 AM IST.
Packages for argument urw-base35-fonts available, but not installed.
Error: Nothing to do.

I have this package installed so I tried to remove it but can't 
[parag@f27 master]$ sudo dnf remove  urw-base35-fonts --assumeno
Dependencies resolved.
===============================================================================
 Package                  Arch   Version                Repository        Size
===============================================================================
Removing:
 urw-base35-fonts         noarch 20170801-1.fc27        @updates-testing 5.3 k
Removing depended packages:
 ImageMagick              x86_64 1:6.9.9.13-1.fc27      @updates-testing 538 k
 ImageMagick-libs         x86_64 1:6.9.9.13-1.fc27      @updates-testing 7.8 M
 autotrace                x86_64 0.31.1-49.fc27         @fedora          360 k
 bluez-cups               x86_64 5.47-2.fc27            @updates-testing 166 k
 cups                     x86_64 1:2.2.4-4.fc27         @updates-testing 5.0 M
 cups-filters             x86_64 1.16.1-1.fc27          @System          2.2 M
 evince                   x86_64 3.26.0-1.fc27          @updates-testing 9.4 M
 evince-djvu              x86_64 3.26.0-1.fc27          @updates-testing  55 k
 evince-libs              x86_64 3.26.0-1.fc27          @updates-testing 1.2 M
 evince-nautilus          x86_64 3.26.0-1.fc27          @updates-testing  19 k
 fontforge                x86_64 20170731-2.fc27        @fedora           18 M
 foomatic                 x86_64 4.0.12-17.fc27         @System          634 k
 foomatic-db              noarch 4.0-54.20170503.fc27   @System          8.2 M
 foomatic-db-ppds         noarch 4.0-54.20170503.fc27   @System           50 M
 gegl                     x86_64 0.2.0-34.fc27          @fedora          2.9 M
 ghostscript              x86_64 9.20-12.fc27           @System            0  
 ghostscript-core         x86_64 9.20-12.fc27           @System           22 M
 ghostscript-x11          x86_64 9.20-12.fc27           @System           96 k
 gimp                     x86_64 2:2.8.22-2.fc27.2      @fedora           64 M
 gnome-documents          x86_64 3.26.0-2.fc27          @updates-testing 2.2 M
 gnome-documents-libs     x86_64 3.26.0-2.fc27          @updates-testing 1.4 M
 graphviz                 x86_64 2.40.1-10.fc27         @fedora          7.4 M
 gutenprint-cups          x86_64 5.2.13-3.fc27          @System          787 k
 hplip                    x86_64 3.17.9-1.fc27          @updates-testing  19 M
 libspectre               x86_64 0.2.8-4.fc27           @System           88 k
 libwmf                   x86_64 0.2.8.4-53.fc27        @updates-testing 439 k
 plotutils                x86_64 2.6-18.fc27            @fedora          4.4 M
 pstoedit                 x86_64 3.70-8.fc27            @fedora          1.7 M
 suitesparse              x86_64 4.4.6-10.fc27          @fedora          3.5 M
 sushi                    x86_64 3.24.0-3.fc27          @System          315 k
 xpdf                     x86_64 1:4.00-2.fc27          @fedora           12 M
Removing unused dependencies:
 OpenEXR-libs             x86_64 2.2.0-10.fc27          @fedora          3.0 M
 atlas                    x86_64 3.10.3-1.fc27          @fedora           24 M
 babl                     x86_64 0.1.30-1.fc27          @fedora          694 k
 dcraw                    x86_64 9.27.0-5.fc27          @fedora          527 k
 fftw-libs-double         x86_64 3.3.5-7.fc27           @fedora          2.7 M
 gimp-libs                x86_64 2:2.8.22-2.fc27.2      @fedora          5.4 M
 gts                      x86_64 0.7.6-32.20121130.fc27 @fedora          599 k
 ilmbase                  x86_64 2.2.0-10.fc27          @fedora          524 k
 lasi                     x86_64 1.1.2-9.fc27           @fedora           99 k
 libEMF                   x86_64 1.0.9-4.fc27           @fedora          270 k
 libXaw                   x86_64 1.0.13-7.fc27          @fedora          489 k
 libopenraw               x86_64 0.1.2-3.fc27           @fedora          544 k
 libpaper                 x86_64 1.1.24-16.fc27         @fedora           85 k
 libspiro                 x86_64 20150131-6.fc27        @fedora           69 k
 libuninameslist          x86_64 20170701-3.fc27        @fedora          2.9 M
 libwmf-lite              x86_64 0.2.8.4-53.fc27        @updates-testing 146 k
 netpbm                   x86_64 10.79.00-3.fc27        @fedora          511 k
 tbb                      x86_64 2017.7-3.fc27          @fedora          336 k
 urw-base35-d050000l-fonts
                          noarch 20170801-1.fc27        @updates-testing  55 k
 urw-base35-standard-symbols-ps-fonts
                          noarch 20170801-1.fc27        @updates-testing  44 k
 xorg-x11-fonts-ISO8859-1-100dpi
                          noarch 7.5-18.fc27            @fedora          1.0 M
 xorg-x11-fonts-ISO8859-1-75dpi
                          noarch 7.5-18.fc27            @fedora          899 k

Transaction Summary
===============================================================================
Remove  23 Packages

Freed space: 289 M
Operation aborted.

Comment 2 Parag Nemade 2017-09-25 08:27:47 UTC
continuing from last comment, not sure if its a bug in dnf that is not allowing me to downgrade. Removing will remove many packages which I don't want to remove.

Comment 3 Parag Nemade 2017-09-25 08:43:26 UTC
By simply moving the numeric order from 35 to 58 solved the issue on my machine now.

Comment 4 David Kaspar // Dee'Kej 2017-09-25 15:03:16 UTC
Hello, thanks for the bug report!

I have fix ready, but I'm currently testing it myself. Please, hold on there for a little longer. Thank you!

*** This bug has been marked as a duplicate of bug 1494850 ***


Note You need to log in before you can comment on or make changes to this bug.