Bug 1495155 - [RFE] The 'Register Content Host' page in the UI should inform users to use the bootstrap.py script.
Summary: [RFE] The 'Register Content Host' page in the UI should inform users to use ...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Hosts - Content
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: jcallaha
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-25 10:29 UTC by Rich Jerrido
Modified: 2019-05-02 18:52 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-02 18:52:46 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Rich Jerrido 2017-09-25 10:29:22 UTC
Description of problem:

The Satellite UI should inform the user to use bootstrap.py to register hosts. Currently today, the user is informed to download the katello-ca-consumer RPM and run subscription-manager. While this works, there are a number of other items that the user may wish to do that bootstrap.py covers. 



Steps to Reproduce:
1. Open Satellite UI
2. visit Hosts->Content Hosts->Register Content Host
3.

Actual results:

User is given commands similar to the following


Select a Content Source:

Install the pre-built bootstrap RPM:

rpm -Uvh http://satellite.example.com/pub/katello-ca-consumer-latest.noarch.rpm

Run subscription-manager in a console on the client host. You may use an Activation Key to register:

subscription-manager register --org="Example" --activationkey="<Activation Key Name>"

or authenticate with a username and password:

subscription-manager register --org="Example" --environment="Library"

If you want to use client tools such as katello-agent or puppet, the satellite-tools repository will need to be enabled

subscription-manager repos --enable=rhel-\*-satellite-tools-\*-rpms

Install katello-agent for remote actions and displaying errata information:

yum -y install katello-agent



Expected results:

User should be provided an example that uses bootstrap.py

Additional info:

bootstrap.py examples are here (https://access.redhat.com/articles/2280691) for reference.

Comment 1 Bryan Kearney 2019-04-01 12:13:10 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Red Hat Technical Support or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 2 Bryan Kearney 2019-05-02 18:52:46 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.