Bug 1495163 - [downstream clone - 4.1.7] Live Storage Migration fails, live merge is not invoked, leaving snapshot locked [NEEDINFO]
Summary: [downstream clone - 4.1.7] Live Storage Migration fails, live merge is not in...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.1.6
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ovirt-4.1.7
: ---
Assignee: Benny Zlotnik
QA Contact: Lilach Zitnitski
URL:
Whiteboard:
Depends On: 1494711
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-25 11:20 UTC by rhev-integ
Modified: 2021-05-01 16:53 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1494711
Environment:
Last Closed: 2017-11-07 17:27:54 UTC
oVirt Team: Storage
Target Upstream Version:
eedri: needinfo? (amarchuk)


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3138 0 normal SHIPPED_LIVE Red Hat Virtualization Manager (ovirt-engine) 4.1.7 2017-11-07 22:22:33 UTC

Description rhev-integ 2017-09-25 11:20:36 UTC
+++ This bug is a downstream clone. The original bug is: +++
+++   bug 1494711 +++
======================================================================

Description of problem:

Live Storage Migration was performed against VMs with multiple disks. All volumes were moved successfully to the new storage domain, but in both cases the snapshot deletion for one disk was not even attempted, and the snapshot was left in a locked state.


Version-Release number of selected component (if applicable):

RHEV 4.1.6
RHVH 4,1,6


How reproducible:

Not.


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

(Originally by Gordon Watson)

Comment 8 rhev-integ 2017-09-25 11:21:10 UTC
Benny, can you take a look please?

(Originally by Allon Mureinik)

Comment 11 Allon Mureinik 2017-09-25 11:45:59 UTC
Eyal - this BZ was marked as MODIFIED since it was fixed by a patch to an upstream BZ 1484825 which was merged before this one was filed.

Can you assist in manually adding it to the errtum, as there's no patch with this BZ link to drive the process?

TIA,
Allon

Comment 14 Lilach Zitnitski 2017-10-01 08:59:23 UTC
--------------------------------------
Tested with the following code:
----------------------------------------
rhevm-4.1.7.2-0.1.el7.noarch
vdsm-4.19.33-1.el7ev.x86_64

Tested with the following scenario:

Steps to Reproduce:
1. create vm with multiple disks
2. start live migrating all disks 

Actual results:
all disks moved to the new storage domain and all lsm auto generated snapshots were deleted after lsm completed. 

Expected results:

Moving to VERIFIED!

Comment 16 errata-xmlrpc 2017-11-07 17:27:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3138


Note You need to log in before you can comment on or make changes to this bug.