Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1495215 - bootstrap.py fails when trying to register FIPs compliant clients
Summary: bootstrap.py fails when trying to register FIPs compliant clients
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Bootstrap
Version: 6.2.10
Hardware: All
OS: Linux
high
high
Target Milestone: Unspecified
Assignee: Rich Jerrido
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-25 14:06 UTC by Amy Farley
Modified: 2020-12-14 10:14 UTC (History)
1 user (show)

Fixed In Version: katello-client-bootstrap-1.5.0-1.el7sat
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-21 16:54:17 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Amy Farley 2017-09-25 14:06:29 UTC
Description of problem:

When trying to register FIPs compliant clients to a Sat6, getting this failure:

Notice: /File[/var/lib/puppet/lib/puppet/parser/functions]/ensure: created
md5_dgst.c(82): OpenSSL internal error, assertion failed: Digest MD5 forbidden in FIPS mode!
sh: line 1:  3303 Aborted                 /usr/bin/puppet agent --test --noop --tags no_such_tag --waitforcert 10

Version-Release number of selected component (if applicable):

If we make this change to the client's puppet.conf, it gets overwritten and still fails with same error.


How reproducible:
Everytime

Steps to Reproduce:
1. Run bootstrap.ps -> fails
2. add  ' digest_algorithm = sha256' to puppet.conf
3. remove client's  /var/lib/puppet and retry

Actual results:
It still fails, same error

Expected results:
Registered client

Additional info:

Comment 2 Rich Jerrido 2018-01-22 18:11:51 UTC
Moving to POST as (https://github.com/Katello/katello-client-bootstrap/pull/236) has been merged upstream.

Comment 3 Satellite Program 2018-02-21 16:54:17 UTC
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA.
> 
> For information on the advisory, and where to find the updated files, follow the link below.
> 
> If the solution does not work for you, open a new bug report.
> 
> https://access.redhat.com/errata/RHSA-2018:0336


Note You need to log in before you can comment on or make changes to this bug.