Bug 149528 - unmatched data types
unmatched data types
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: diradmin (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-23 14:59 EST by David Binderman
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-03 07:50:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Binderman 2005-02-23 14:59:36 EST
Description of problem:

I just tried to compile package diradmin-1.5.1-5 from 
Redhat Fedora Extras development tree.

The compiler said

charset.c(185): warning #967: conversion from "char" to "const
gchar={char} *";
sizes do not match

The source code is

                        tempstring = g_strdup(tempstring2);

but
        char*tempstring,tempstring2;

You can't call g_strdup on a char, only a char *. Maybe 

        char *tempstring, *tempstring2;

was intended by the programmer ?


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Michael Schwendt 2005-02-23 17:26:37 EST
A typical mistake done by C programmers.
Comment 2 Matthias Saou 2005-04-07 15:38:54 EDT
Can you check if this has been fixed in 1.6.0 already?
Comment 3 Michael Schwendt 2005-04-07 17:22:32 EDT
Not fixed in 1.6.0.
Comment 4 Matthias Saou 2005-05-03 07:50:57 EDT
Thanks for the bug report.  At the moment, the Fedora developers don't have
time to work on this particular issue. The best way to make sure your problem
will get looked on is to report it to the authors of the program. Most 
upstream authors use a bug tracking system like bugzilla, and more people
who know the code will be looking at the bug report there.

The upstream bug tracking system to use is:
http://diradmin.open-it.org/lists.php

Please make sure the bug isn't already in the upstream bug tracker before
filing it.
Comment 5 David Binderman 2005-05-03 08:05:32 EDT
>At the moment, the Fedora developers don't have
>time to work on this particular issue.

Fair enough. I am willing to wait for a bugfix.

>The best way to make sure your problem
>will get looked on is to report it to the authors of the program

I tried this, but failed. All I got was an opportunity to subscribe
to a couple of mailing lists, which is slightly less than useful
for my purpose.

Comment 6 Matthias Saou 2005-05-03 08:20:00 EDT
Same for me. The project isn't very active, unfortunately.

Note You need to log in before you can comment on or make changes to this bug.