Bug 149531 - multiple tracebacks in Red Hat Login module, no way to skip past
multiple tracebacks in Red Hat Login module, no way to skip past
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
:
Depends On:
Blocks: FC4Blocker
  Show dependency treegraph
 
Reported: 2005-02-23 15:19 EST by Charles R. Anderson
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-30 18:20:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles R. Anderson 2005-02-23 15:19:02 EST
Description of problem:

There is no way to skip past the Red Hat Login creation due to tracebacks.

Version-Release number of selected component (if applicable):

firstboot-1.3.33-1
  
Actual results:

Traceback (most recent call last):
  File "/usr/share/firstboot/firstbootWindow.py", line 292, in nextClicked
    result = module.apply(self.notebook)
  File "/usr/share/firstboot/modules/rhn_login_gui.py", line 182, in apply
    self.parent.setPage("rhn_optout_gui")
  File "/usr/share/firstboot/firstbootWindow.py", line 219, in setPage
    self.nextPage = self.moduleNameToNotebookIndex[modulename]
KeyError: 'rhn_optout_gui'

Traceback (most recent call last):
  File "/usr/share/firstboot/firstbootWindow.py", line 292, in nextClicked
    result = module.apply(self.notebook)
  File "/usr/share/firstboot/modules/rhn_optout_gui.py", line 127, in apply
    self.parent.setPage("create_user")
  File "/usr/share/firstboot/firstbootWindow.py", line 219, in setPage
    self.nextPage = self.moduleNameToNotebookIndex[modulename]
KeyError: 'create_user'
Comment 1 Jeremy Katz 2005-04-27 20:59:56 EDT
Adrian -- have we disabled the rhn stuff for fc4?
Comment 2 Adrian Likins 2005-05-19 14:40:18 EDT
It should get skipped with the default /etc/sysconfig/rhn/sources (aka, no
"up2date default" line). If that exists, it will run the RHN stuff. 

These errors were fixed in 1.3.34
Comment 3 Warren Togami 2005-05-28 04:32:27 EDT
May 27th latest up2date /etc/sysconfig/rhn/sources contains "up2date default"
line.  Where is the built package that fixes this, or is Comment #2 backwards?
Comment 4 Warren Togami 2005-05-30 18:20:35 EDT
My mistake, /etc/sysconfig/rhn/sources is in fedora-release, which is not fixed
in rawhide, but is fixed in CVS for the final fedora-release-4-1 build, so
consider this done.

Note You need to log in before you can comment on or make changes to this bug.