Bug 1495356 - nfs-ganesha service fails to start with systemd due to permission denied on /var/log/ganesha
Summary: nfs-ganesha service fails to start with systemd due to permission denied on /...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Build
Version: 3.0
Hardware: Unspecified
OS: Linux
high
high
Target Milestone: rc
: 3.0
Assignee: Ali Maredia
QA Contact: Ramakrishnan Periyasamy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-25 22:10 UTC by Ali Maredia
Modified: 2017-12-05 23:45 UTC (History)
7 users (show)

Fixed In Version: nfs-ganesha-2.5.2-3.el7cp
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-05 23:45:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gerrithub.io 379661 0 None None None 2017-09-26 00:36:59 UTC
Github nfs-ganesha nfs-ganesha issues 212 0 None None None 2017-09-26 00:36:29 UTC
Red Hat Bugzilla 1494670 0 unspecified CLOSED selinux (nfs-ganesha): /var/log/ganesha.log moves to /var/log/ganesha/... 2021-02-22 00:41:40 UTC
Red Hat Product Errata RHBA-2017:3387 0 normal SHIPPED_LIVE Red Hat Ceph Storage 3.0 bug fix and enhancement update 2017-12-06 03:03:45 UTC

Internal Links: 1494670

Description Ali Maredia 2017-09-25 22:10:13 UTC
Description of problem on github:

https://github.com/nfs-ganesha/nfs-ganesha/issues/212

Additional info:

The downstream nfs-ganesha.spec-in.cmake file must be changed to fix this issue.

Comment 8 Ali Maredia 2017-10-24 16:40:49 UTC
Vidushi,

nfs-ganesha should be able to start with systemd on RHEL 7.4. SELinux should be on, which it is by default.

Comment 9 Ramakrishnan Periyasamy 2017-10-26 09:47:18 UTC
Hi Ali,

Ganesha service is not coming up with build: "nfs-ganesha-rgw-2.5.2-11.el7cp.x86_64"

Steps followed to verify the bug:
================================
1. Configured Ceph RGW
2. Installed ganesha and configured ganesha as in this document: https://access.qa.redhat.com/documentation/en-us/red_hat_ceph_storage/2/html-single/object_gateway_guide_for_red_hat_enterprise_linux/#exporting_the_namespace_to_nfs_ganesha
3. Started ganesha service using command "/usr/bin/ganesha.nfsd -f /etc/ganesha/ganesha.conf" without "sudo". Ganesha service not started.

Command output:
===============
[ubuntu@host118 ~]$ /usr/bin/ganesha.nfsd -f /etc/ganesha/ganesha.conf
[ubuntu@host118 ~]$ !ps
ps aux | grep nfs
ubuntu   15874  0.0  0.0 112660   972 pts/1    S+   09:28   0:00 grep --color=auto nfs
============================================

Additional Info: 
As per the github issue 212 in bug description /var/log/ganesha should be owned by ganesha:root for the ganesha service to start.

But after nfs installation "/var/log/ganesha" folder is still owned by ganesha:ganesha

[ubuntu@host118 ~]$ ll /var/log/ | grep ganesha
drwxr-xr-x. 2 ganesha ganesha    4096 Oct 25 14:50 ganesha
============================================

Planning to move this bug to assigned state. Let me know your view on this. Thanks

Regards,
Ramakrishnan

Comment 10 Ramakrishnan Periyasamy 2017-10-26 09:57:31 UTC
There is no info about nfs-ganesha in systemctl or in systemd

[ubuntu@host118 ~]$ systemctl --all | grep ganesha
  user-10103.slice                                                                         loaded    active   active    User Slice of ganesha
[ubuntu@host118 systemd]$ find . | grep ganesh
[ubuntu@host118 systemd]$ ls
bootchart.conf  coredump.conf  journald.conf  logind.conf  system  system.conf  user  user.conf
[ubuntu@host118 systemd]$ 

Ceph Build: ceph version 12.2.1-25.el7cp (899fcaceb921cbeb5d875ee24dc4ceb0ef0280a1) luminous (stable)

NFS Build:
[ubuntu@host118 systemd]$ sudo rpm -qa | grep nfs
nfs-ganesha-rgw-2.5.2-11.el7cp.x86_64
nfs-ganesha-2.5.2-11.el7cp.x86_64
nfs-utils-1.3.0-0.48.el7_4.x86_64
libnfsidmap-0.25-17.el7.x86_64

Comment 15 Ramakrishnan Periyasamy 2017-10-27 11:58:29 UTC
Tried some more Tests:

1. Start/Stop/Restart of "sudo systemctl <> nfs-ganesha" worked without any issues.
2. After node reboot ganesha service not comes up --> Is this expected or separate bug needs to filed ?
3. Ceph-object-gateway document need to be updated for nfs service start command.

Comment 18 Ramakrishnan Periyasamy 2017-10-30 04:19:58 UTC
Moving this bug to verified state.

As mentioned in comment12 service is starting without any issues.

Filed doc bug for command update bz:1507208

Ran NFS Teuthology Automation scripts on the NFS mount which worked fine without any issues.

Comment 21 errata-xmlrpc 2017-12-05 23:45:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3387


Note You need to log in before you can comment on or make changes to this bug.