Bug 149550 - xterm w/font fixed crashes on tk man pages
xterm w/font fixed crashes on tk man pages
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xterm (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-23 17:13 EST by Peter Dalgaard
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-07 10:07:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Dalgaard 2005-02-23 17:13:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
With the default fixed font, xterm crashes with a BadName error upon
display of certain man pages. As far as I can see, the culprit is the
revision bar displayed on the right hand side of some pages.

As you can surely imagine, this gets to be quite a pain if you are
using xterms for your standard terminal, as is default in Xfce sessions. 


Version-Release number of selected component (if applicable):
xterm-192-1

How reproducible:
Always

Steps to Reproduce:
1.start an xterm (-fn fixed if you have defaults set otherwise) 
2.enter "man n button"
3.scroll down about 8 lines
    

Actual Results:  xterm dies with
xterm:  warning, error event received:
X Error of failed request:  BadName (named color or font does not exist)
  Major opcode of failed request:  77 (X_ImageText16)
  Serial number of failed request:  395
  Current serial number in output stream:  401


Expected Results:  xterm would not die ;-)

Additional info:

A workaround seems to be to use xterm with any other font than fixed.
In particular, xterm -fn 6x13 is indistinguishable from fixed and does
not have the problem.

Using a remote xterm running on SuSE 9.1 has the same issue. However,
it does not happen with one running on RedHat8.
Comment 1 Mike A. Harris 2005-03-06 11:39:54 EST
Are you running these commands to a remote machine via ssh
with X11 forwarding?

If so, if you invoke ssh as "ssh -Y remotehost", does the
problem go away?
Comment 2 Mike A. Harris 2005-03-06 11:40:17 EST
Setting status to "NEEDINFO"
Comment 3 Peter Dalgaard 2005-03-07 03:28:06 EST
Hm, the problem seems to have vanished altogether now...

It was perfectly reproducible before, and happened on the local
machine. (I've been bitten by the ssh -Y thing before, and have    
"ForwardX11Trusted yes" against the relevant machine). 

I can only conjecture that something like the font server had gotten
itself wedged. 
Comment 4 Mike A. Harris 2005-03-07 10:07:14 EST
Ok, if the problem happens again, please reopen the bug.

Setting status to "WORKSFORME", as the problem has vanished,
as indicated in comment #3.
Comment 5 bperkins 2006-12-10 23:45:05 EST
I noticed the same problem with xterm in fc6, it went away when I restarted xfs
and restarted the x server.  Seemed to only affect the default "fixed" font.  

When I restarted xfs, I couldn't start any xclients, so I'm not sure whether
that helped or not.

Note You need to log in before you can comment on or make changes to this bug.