Bug 1495509 - [abrt] dnfdragora-gui: perform(): __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.freedesktop.DBus.Python.dnf.exceptions.RepoError: Traceback (most recent call last): [NEEDINFO]
Summary: [abrt] dnfdragora-gui: perform(): __init__.py:250:_handle_dbus_error:dnfdaemo...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnfdragora
Version: 27
Hardware: armv7l
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Björn 'besser82' Esser
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:abebb8bbb799acc8bd0b1b61acf...
: 1513694 1528777 1536151 1536783 1538348 1541664 1553983 1557797 1561951 1564676 1565441 1571521 1572018 1572877 (view as bug list)
Depends On:
Blocks: F27FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2017-09-26 08:36 UTC by Alessio
Modified: 2018-11-04 16:40 UTC (History)
76 users (show)

Fixed In Version: dnfdragora-1.0.1-8.git20171229.24e4647.fc27 dnfdragora-1.0.1-8.git20171229.24e4647.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-31 21:27:46 UTC
awilliam: needinfo? (besser82)


Attachments (Terms of Use)
File: backtrace (9.15 KB, text/plain)
2017-09-26 08:36 UTC, Alessio
no flags Details
File: cgroup (276 bytes, text/plain)
2017-09-26 08:36 UTC, Alessio
no flags Details
File: cpuinfo (388 bytes, text/plain)
2017-09-26 08:36 UTC, Alessio
no flags Details
File: environ (1.41 KB, text/plain)
2017-09-26 08:37 UTC, Alessio
no flags Details
File: mountinfo (2.78 KB, text/plain)
2017-09-26 08:37 UTC, Alessio
no flags Details
File: namespaces (102 bytes, text/plain)
2017-09-26 08:37 UTC, Alessio
no flags Details
File: open_fds (1.03 KB, text/plain)
2017-09-26 08:37 UTC, Alessio
no flags Details
Patch that catches the exception (1.02 KB, patch)
2017-11-26 18:37 UTC, Angelo Naselli
no flags Details | Diff

Description Alessio 2017-09-26 08:36:48 UTC
Description of problem:
It appears after first login on Raspberry Pi 3 arm XFCE image

Version-Release number of selected component:
dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27

Additional info:
reporter:       libreport-2.9.2
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: perform
exception_type: librepo.LibrepoException
executable:     /usr/bin/dnfdragora-updater
kernel:         4.13.3-300.fc27.armv7hl
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
#1 perform in /usr/lib/python3.6/site-packages/librepo/__init__.py:1522
#2 _perform in /usr/lib/python3.6/site-packages/dnf/repo.py:229

Potential duplicate: bug 1470849

Comment 1 Alessio 2017-09-26 08:36:55 UTC
Created attachment 1330920 [details]
File: backtrace

Comment 2 Alessio 2017-09-26 08:36:57 UTC
Created attachment 1330921 [details]
File: cgroup

Comment 3 Alessio 2017-09-26 08:36:58 UTC
Created attachment 1330922 [details]
File: cpuinfo

Comment 4 Alessio 2017-09-26 08:37:00 UTC
Created attachment 1330923 [details]
File: environ

Comment 5 Alessio 2017-09-26 08:37:02 UTC
Created attachment 1330924 [details]
File: mountinfo

Comment 6 Alessio 2017-09-26 08:37:04 UTC
Created attachment 1330925 [details]
File: namespaces

Comment 7 Alessio 2017-09-26 08:37:05 UTC
Created attachment 1330926 [details]
File: open_fds

Comment 8 yucef sourani 2017-10-07 11:42:31 UTC
Similar problem has been detected:

after fedora boot ,dnfdragora crashed after restart my adsl router .

reporter:       libreport-2.9.2
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: perform
exception_type: librepo.LibrepoException
executable:     /usr/bin/dnfdragora-updater
kernel:         4.13.4-300.fc27.x86_64
package:        dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.freedesktop.DBus.Python.dnf.exceptions.RepoError: Traceback (most recent call last):
runlevel:       N 5
type:           Python3
uid:            1000

Comment 9 Carlos "casep" Sepulveda 2017-10-09 08:48:25 UTC
*** Bug 1499675 has been marked as a duplicate of this bug. ***

Comment 10 Miguel Zúñiga 2017-10-15 21:08:17 UTC
Similar problem has been detected:

After updating to Fedora 26, the error came out. For any reason, the network was not available when this happened. The network was up again by unplugging, then plugging again the network cable.

reporter:       libreport-2.9.2
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: perform
exception_type: librepo.LibrepoException
executable:     /usr/bin/dnfdragora-updater
kernel:         4.13.5-300.fc27.x86_64
package:        dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.freedesktop.DBus.Python.dnf.exceptions.RepoError: Traceback (most recent call last):
runlevel:       N 5
type:           Python3
uid:            1000

Comment 11 christian gudino 2017-10-19 14:02:57 UTC
Similar problem has been detected:

when load the system 

reporter:       libreport-2.9.2
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: perform
exception_type: librepo.LibrepoException
executable:     /usr/bin/dnfdragora-updater
kernel:         4.13.6-300.fc27.x86_64
package:        dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.freedesktop.DBus.Python.dnf.exceptions.RepoError: Traceback (most recent call last):
runlevel:       N 5
type:           Python3
uid:            1000

Comment 12 christian gudino 2017-10-19 14:04:14 UTC
*** Bug 1504116 has been marked as a duplicate of this bug. ***

Comment 13 František Zatloukal 2017-10-24 11:10:42 UTC
Similar problem has been detected:

Instant crash after first boot on BananaPi.

reporter:       libreport-2.9.2
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: perform
exception_type: librepo.LibrepoException
executable:     /usr/bin/dnfdragora-updater
kernel:         4.13.5-300.fc27.armv7hl
package:        dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.freedesktop.DBus.Python.dnf.exceptions.RepoError: Traceback (most recent call last):
runlevel:       N 5
type:           Python3
uid:            1000

Comment 14 Fedora Blocker Bugs Application 2017-10-24 13:16:28 UTC
Proposed as a Blocker for 27-final by Fedora user frantisekz using the blocker tracking app because:

 All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test.

Comment 15 Adam Williamson 2017-10-24 16:27:33 UTC
+1 blocker (Xfce on ARM is a blocking desktop...)

Comment 16 Adam Williamson 2017-10-25 21:53:58 UTC
Do we have any idea what's going on here, or any plan to deal with this if we can't fix dnfdragora?

Comment 17 František Zatloukal 2017-10-26 12:24:17 UTC
Looks like it's crashing only without working internet connection. dnfdragora can't properly handle the exception and dies when dnf can't resolve hostname.

Comment 18 Angelo Naselli 2017-10-26 16:36:00 UTC
Sorry, I didn't know anything about this issue... so i could not thing to any solutions. If the problem is the connection absence, it should not that hard to reproduce. I will check it as soon as possible, which is the f27 deadline?

Comment 19 Adam Williamson 2017-10-26 16:39:16 UTC
Well, we're doing go/no-go today, but we don't have an RC so we'll clearly be no-go and doing the go/no-go again next Thursday. It's hard to give a precise deadline as we don't hold the release for FEs, we might potentially build the final RC any time all the blockers are fixed, but the latest day we usually would build an RC for a Thursday go/no-go is Tuesday.

Comment 20 Adam Williamson 2017-10-26 20:18:27 UTC
Discussed at 2017-10-26 Fedora 27 Final go/no-go meeting, acting as a blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-meeting-1/2017-10-26/f27-final-and-server-beta-go-no-go-meeting.2017-10-26-17.00.html . This is rejected as a blocker on the basis that it only happens when a network connection is not available, a situation where the package manager is not going to be terribly useful in any case. However, it's accepted as a freeze exception as obviously encountering a crash in this case is a bad look, and it'd be nice to have it fixed for the final release.

Comment 21 ilya 2017-10-29 07:40:51 UTC
*** Bug 1507276 has been marked as a duplicate of this bug. ***

Comment 22 Folco 2017-11-03 11:35:00 UTC
I get this bug too, with a working internet connection.
I just installed the current Beta ISO today, updated after install, then Dnfdragora becomes unusable.
I don't use any proxy parameter, just direct, usual internet connection.

Comment 23 Folco 2017-11-03 13:27:26 UTC
Screenshots of the crash I get :
http://www.mirari.fr/27E2.png
http://www.mirari.fr/H0MD.png
Now I got these screenshots, I'm not that sure that it's really the exact same bug. I could open another report if needed.
But it's definitely a crash bug which makes Dnfdragora unusable.

Comment 24 Adam Williamson 2017-11-03 18:56:26 UTC
The first one of those is definitely a crash, but definitely not *this* crash, it's some sort of comps parsing error. The second isn't really a problem, it's just things working as they should: you probably ran dnfdragora while the dnf cache update that runs every so often on a timer happened to be running.

Is the first crash reproducible somehow?

Comment 25 mohamed abdelhamed 2017-11-04 18:50:19 UTC
*** Bug 1509564 has been marked as a duplicate of this bug. ***

Comment 26 Folco 2017-11-06 10:12:34 UTC
- I did a fresh install (Workstation), using the Fedora Media Writer tool, as documented here: https://getfedora.org/workstation/prerelease/
- I updated the installation when completed
- I can't get the first crash anymore
- I keep getting the "DNF is locked by another application" message when running dnfdragora, while I can use dnf in a terminal to install something

Comment 27 Adam Williamson 2017-11-07 18:24:26 UTC
Hum, that does sound like a bug (getting the 'locked by another application' message when you don't get it from another tool at the same time), but not this bug - could you report it separately? Thanks!

Comment 28 Angelo Naselli 2017-11-07 19:06:16 UTC
@Adam and all, I wasn't to reproduce this issue into mageia 6, I'm very sorry. Although i found another problem testing this one without internet connection that could be pointed to Comment #26, e.g. dbus wasn't active for i don't know why reason, and dnfdragora closed well but after that the "DNF is locked by another application" message appeared. I need to beeter investigate this

Comment 29 Folco 2017-11-07 21:06:09 UTC
@Adam: ok, done, thanks:
https://bugzilla.redhat.com/show_bug.cgi?id=1510632

Comment 30 Angelo Naselli 2017-11-11 11:08:27 UTC
hmm on comment#28 it was my fault the dnf locked issue. Could you give me a link to download a live in which i can test this issue?

Comment 32 Angelo Naselli 2017-11-11 18:48:47 UTC
thanks, it does not boot using virtual box :(

Comment 33 Folco 2017-11-11 18:54:46 UTC
I got it booting usint Virtual Box, hosted on Win 10 x64, using the second or third item of the boot menu.
But I had to update Python and Anaconda before installing to HDD, to get a working installer.

Comment 34 J. Thiem 2017-11-11 19:52:30 UTC
For what it's worth, this just happened to me on a Fedora 27 after booting which I had upgraded from a Fedora 25 a few weeks ago. I'm on x86_64 with a GNOME 3 Xorg session

Comment 35 Adam Williamson 2017-11-14 00:39:21 UTC
Can folks hitting this please explain what they did to trigger it, and whether they had a working network connection at the time? Thanks.

Comment 36 James Boyle 2017-11-14 15:28:14 UTC
Similar problem has been detected:

I booted into Fedora 27 for the first time after upgrading.  dnfdragora decided to bomb out.

reporter:       libreport-2.9.3
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: perform
exception_type: librepo.LibrepoException
executable:     /usr/bin/dnfdragora-updater
kernel:         4.13.12-300.fc27.x86_64
package:        dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.freedesktop.DBus.Python.dnf.exceptions.RepoError: Traceback (most recent call last):
runlevel:       N 5
type:           Python3
uid:            1000

Comment 37 kovivox 2017-11-15 19:13:43 UTC
*** Bug 1513694 has been marked as a duplicate of this bug. ***

Comment 38 Alex Finkel 2017-11-16 14:28:00 UTC
Similar problem has been detected:

Error occurred immediately upon login to Cinnamon session after system freshly booted.  System connected to hotel network - not yet logged in using captive portal so no actual Internet access when the error occurred.

reporter:       libreport-2.9.3
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: perform
exception_type: librepo.LibrepoException
executable:     /usr/bin/dnfdragora-updater
kernel:         4.13.12-300.fc27.x86_64
package:        dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.freedesktop.DBus.Python.dnf.exceptions.RepoError: Traceback (most recent call last):
runlevel:       N 5
type:           Python3
uid:            1000

Comment 39 Loye Young 2017-11-16 17:24:41 UTC
*** Bug 1514136 has been marked as a duplicate of this bug. ***

Comment 40 Luis Filipe Teixeira Guerra 2017-11-17 03:37:08 UTC
*** Bug 1514312 has been marked as a duplicate of this bug. ***

Comment 41 Sethanath 2017-11-18 18:17:03 UTC
*** Bug 1514822 has been marked as a duplicate of this bug. ***

Comment 42 ricky.tigg 2017-11-20 11:39:03 UTC
*** Bug 1515200 has been marked as a duplicate of this bug. ***

Comment 43 patrick.guio 2017-11-21 08:33:14 UTC
*** Bug 1515674 has been marked as a duplicate of this bug. ***

Comment 44 Anton 2017-11-21 11:26:06 UTC
*** Bug 1515772 has been marked as a duplicate of this bug. ***

Comment 45 Granata Giovanni 2017-11-22 11:20:00 UTC
Similar problem has been detected:

Just stinting the application

reporter:       libreport-2.9.3
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: perform
exception_type: librepo.LibrepoException
executable:     /usr/bin/dnfdragora-updater
kernel:         4.13.13-300.fc27.x86_64
package:        dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.freedesktop.DBus.Python.dnf.exceptions.RepoError: Traceback (most recent call last):
runlevel:       N 5
type:           Python3
uid:            1000

Comment 46 ziya 2017-11-22 18:01:15 UTC
*** Bug 1516489 has been marked as a duplicate of this bug. ***

Comment 47 João Vitor 2017-11-25 03:29:29 UTC
*** Bug 1517419 has been marked as a duplicate of this bug. ***

Comment 48 Helber Maciel Guerra 2017-11-25 12:07:58 UTC
*** Bug 1517444 has been marked as a duplicate of this bug. ***

Comment 49 Stan King 2017-11-25 17:45:23 UTC
Similar problem has been detected:

This happened right after the command-line upgrade from f26 to f27, before I could connect to a network.

My guess is that dnfdragora is stressed by the lack of a network connection.

reporter:       libreport-2.9.3
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: perform
exception_type: librepo.LibrepoException
executable:     /usr/bin/dnfdragora-updater
kernel:         4.13.13-300.fc27.x86_64
package:        dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.freedesktop.DBus.Python.dnf.exceptions.RepoError: Traceback (most recent call last):
runlevel:       N 5
type:           Python3
uid:            1000

Comment 50 Angelo Naselli 2017-11-25 19:05:57 UTC
ok clearly a problem in /usr/bin/dnfdragora-updater is there any one who can provide a patch, we haven't released it in mageia yet, and i cannot work on this before two weeks sorry.

Comment 51 ricky.tigg 2017-11-26 09:24:52 UTC
*** Bug 1517502 has been marked as a duplicate of this bug. ***

Comment 52 ilekkha 2017-11-26 09:25:01 UTC
*** Bug 1517503 has been marked as a duplicate of this bug. ***

Comment 53 vikram goyal 2017-11-26 12:08:52 UTC
*** Bug 1517528 has been marked as a duplicate of this bug. ***

Comment 54 Loye Young 2017-11-26 14:28:19 UTC
(In reply to Adam Williamson from comment #35)
> Can folks hitting this please explain what they did to trigger it, and
> whether they had a working network connection at the time? Thanks.

> what they did to trigger it,
Logged in.

> whether they had a working network connection at the time
Yes and no. I have both a wired (for intranet) and wireless (for Internet) connection. When I first log in, the wired connection is already on and working. I must manually turn on the wireless connection upon login to access the big Internet. The fault is triggered after the wired connection, but before the wireless connection.

Comment 55 Angelo Naselli 2017-11-26 17:24:37 UTC
downloaded https://download.fedoraproject.org/pub/fedora/linux/releases/27/Workstation/x86_64/iso/Fedora-Workstation-Live-x86_64-27-1.6.iso
dnfdragora is not in.
Installed on a vm and again dnfdragora is not in.

Comment 56 Kevin Kofler 2017-11-26 18:05:40 UTC
Workstation uses GNOME Software as its (only) updater and software installer. (It contains no true graphical package manager.) The KDE Spin includes the dnfdragora package manager (in addition to Plasma Discover), but has its own updater (plasma-pk-updates). You will probably want to try one of the other Spins, such as the Xfce Spin the reporter is using. As far as I know, most or all of those include the complete dnfdragora.

Comment 57 Angelo Naselli 2017-11-26 18:37:32 UTC
Created attachment 1359215 [details]
Patch that catches the exception

dnfdragora-updater patch

Comment 58 Angelo Naselli 2017-11-26 18:43:17 UTC
Kevin i've used that live just because i followed comment #31 indication...

Comment 59 ricky.tigg 2017-11-27 07:48:03 UTC
*** Bug 1517647 has been marked as a duplicate of this bug. ***

Comment 60 phoenix_mashhad 2017-11-27 08:04:13 UTC
*** Bug 1517653 has been marked as a duplicate of this bug. ***

Comment 61 Paulim_hed 2017-11-27 11:54:44 UTC
*** Bug 1517755 has been marked as a duplicate of this bug. ***

Comment 62 eiino 2017-11-27 15:19:10 UTC
*** Bug 1517846 has been marked as a duplicate of this bug. ***

Comment 63 Michal 2017-11-28 07:52:24 UTC
Similar problem has been detected:

I have logged in and Poblem Reporting opened

reporter:       libreport-2.9.3
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: perform
exception_type: librepo.LibrepoException
executable:     /usr/bin/dnfdragora-updater
kernel:         4.13.13-300.fc27.x86_64
package:        dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.freedesktop.DBus.Python.dnf.exceptions.RepoError: Traceback (most recent call last):
runlevel:       N 5
type:           Python3
uid:            1000

Comment 64 Damian 2017-11-29 08:22:08 UTC
*** Bug 1518560 has been marked as a duplicate of this bug. ***

Comment 65 Kåre Løvgren 2017-11-29 18:21:57 UTC
*** Bug 1518913 has been marked as a duplicate of this bug. ***

Comment 66 Angelo Naselli 2017-12-02 09:12:13 UTC
any news on comment#57?

Comment 67 vladlen.lerner 2017-12-04 05:57:14 UTC
*** Bug 1520233 has been marked as a duplicate of this bug. ***

Comment 68 Alex Finkel 2017-12-06 14:32:39 UTC
(In reply to Angelo Naselli from comment #66)
> any news on comment#57?

I quickly tested the patch and dnfdragora-updater seems to run fine.  I will need to do additional testing - probably with the network cable unplugged.

Comment 69 Alex Finkel 2017-12-07 16:25:40 UTC
(In reply to Alex Finkel from comment #68)
> (In reply to Angelo Naselli from comment #66)
> > any news on comment#57?
> 
> I quickly tested the patch and dnfdragora-updater seems to run fine.  I will
> need to do additional testing - probably with the network cable unplugged.

Tested the patched version successfully.   Logged into Cinnamon session with network cable unplugged and not joined to WiFi.   Dnfdragora-updater launched and did not crash.

Comment 70 marius.syvertsen 2017-12-08 11:10:19 UTC
*** Bug 1523590 has been marked as a duplicate of this bug. ***

Comment 71 lzavacky 2017-12-10 09:32:16 UTC
*** Bug 1524128 has been marked as a duplicate of this bug. ***

Comment 72 patrick.guio 2017-12-11 08:56:51 UTC
*** Bug 1524313 has been marked as a duplicate of this bug. ***

Comment 73 Douglas Silva 2017-12-11 10:55:39 UTC
*** Bug 1524367 has been marked as a duplicate of this bug. ***

Comment 74 Mike Hinz 2017-12-12 12:22:24 UTC
Similar problem has been detected:

Powered up laptop.  Logged into KDE desktop.  Crash then occured with no furhter action from me.  

reporter:       libreport-2.9.3
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: perform
exception_type: librepo.LibrepoException
executable:     /usr/bin/dnfdragora-updater
kernel:         4.13.16-302.fc27.x86_64
package:        dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.freedesktop.DBus.Python.dnf.exceptions.RepoError: Traceback (most recent call last):
runlevel:       N 5
type:           Python3
uid:            1000

Comment 75 Tintumon 2017-12-13 08:53:11 UTC
Similar problem has been detected:

dnfdragora is not updating the repos initially i installed through dnf install command and it freezed

the next dnfdragora update fixed the issue, but when i reboot after the first use, there were no errors

again on the next launch, in the middle , i lost wifi connection and eventually i closed dnfdragora.. 

then the error came

reporter:       libreport-2.9.3
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: perform
exception_type: librepo.LibrepoException
executable:     /usr/bin/dnfdragora-updater
kernel:         4.14.3-300.fc27.x86_64
package:        dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.freedesktop.DBus.Python.dnf.exceptions.RepoError: Traceback (most recent call last):
runlevel:       N 5
type:           Python3
uid:            1000

Comment 76 Angelo Naselli 2017-12-13 10:10:58 UTC
Sorry but dnfdragora package is always dnfdragora-gui-1.0.1-6.git20170505 without the patch i proposed (comment #57), so i can't see any new iformation but a different kernel running here.

Comment 77 Tintumon 2017-12-13 10:46:10 UTC
(In reply to Angelo Naselli from comment #76)
> Sorry but dnfdragora package is always dnfdragora-gui-1.0.1-6.git20170505
> without the patch i proposed (comment #57), so i can't see any new
> iformation but a different kernel running here.

oh!! i'm sorry, i dont have read/seen your proposed patch, i'll be there after applying your patch on (comment #57), thank you..

but another bug is there.. enabling and disabling repos does nit work.. :(

Comment 78 Angelo Naselli 2017-12-13 11:11:34 UTC
(In reply to Tintumon from comment #77)

> but another bug is there.. enabling and disabling repos does nit work.. :(

Unfortunately i'm not subscribed to dnfdragora bugs, and not being fedora user i'm reading bugs here only now and then... as far as i can, i'm used to follow dnfdragora issue on github...
Concerning repos, enabling/disabling feature should work but it isn't a permanent setting though, becuase dnfdaemon does not manage that (yet), see https://github.com/manatools/dnfdragora/issues/66

Comment 79 vikram goyal 2017-12-13 15:24:09 UTC
Similar problem has been detected:

I had left clicked on the Network Icon & select desconnect for the WIFI & dnf daemon was running at that time. It seems that caused this issue.

reporter:       libreport-2.9.3
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: perform
exception_type: librepo.LibrepoException
executable:     /usr/bin/dnfdragora-updater
kernel:         4.14.3-300.fc27.x86_64
package:        dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.freedesktop.DBus.Python.dnf.exceptions.RepoError: Traceback (most recent call last):
runlevel:       N 5
type:           Python3
uid:            1000

Comment 80 Alex Finkel 2017-12-14 19:45:07 UTC
Unfortunately with the patch from comment #57 applied, if I attempt to apply any updates then dnfdragora-updater dies.

Comment 81 Angelo Naselli 2017-12-14 22:37:19 UTC
please run it in a console, maybe we can have a feedback. BTW if the reason of the crash still persists now it does not crash, but it correctly exits

Comment 82 Alex Finkel 2017-12-15 14:28:08 UTC
I ran it and it successfully installed 6 updated packages without crashing/exiting:


[afinkel@manatee ~]$ dnfdragora-updater
Skipped exception: <[Errno 2] No such file or directory: './dnfdragora.yaml'> 
Skipped exception: <[Errno 2] No such file or directory: './dnfdragora.yaml'> 
<_M_> [ui] YUILoader.cc:50 loadUI(): DISPLAY: ":0"
<_M_> [ui] YUILoader.cc:51 loadUI(): XDG_CURRENT_DESKTOP: "X-Cinnamon"
<_M_> [ui] YUILoader.cc:52 loadUI(): YUI_PREFERED_BACKEND: ""
<_M_> [ui] YUILoader.cc:64 loadUI(): Detected a Gtk-based desktop environment.
<_M_> [ui] YUILoader.cc:64 loadUI(): Prefering Gtk-UI if available and no
<_M_> [ui] YUILoader.cc:64 loadUI(): user-selected override is present.
<_M_> [ui] YUILoader.cc:86 loadUI(): User-selected UI-plugin: ""
<_M_> [ui] YPath.cc:49 YPath(): Given filename: libyui-gtk.so.8
<_M_> [ui] YSettings.cc:74 progDir(): progDir: ""
<_M_> [ui] YPath.cc:65 YPath(): Preferring subdir: 
<_M_> [ui] YPath.cc:66 YPath(): Subdir given with filename: 
<_M_> [ui] YPath.cc:67 YPath(): Looking for: libyui-gtk.so.8
<_M_> [ui] YPath.cc:138 lsDir(): Looking in /usr/lib64/yui
<_M_> [ui] YPath.cc:118 YPath(): Found libyui-gtk.so.8 in /usr/lib64/yui
<_M_> [ui] YPath.cc:49 YPath(): Given filename: libyui-ncurses.so.8
<_M_> [ui] YSettings.cc:74 progDir(): progDir: ""
<_M_> [ui] YPath.cc:65 YPath(): Preferring subdir: 
<_M_> [ui] YPath.cc:66 YPath(): Subdir given with filename: 
<_M_> [ui] YPath.cc:67 YPath(): Looking for: libyui-ncurses.so.8
<_M_> [ui] YPath.cc:138 lsDir(): Looking in /usr/lib64/yui
<_M_> [ui] YPath.cc:118 YPath(): Found libyui-ncurses.so.8 in /usr/lib64/yui
<_M_> [ui] YPath.cc:49 YPath(): Given filename: libyui-qt.so.8
<_M_> [ui] YSettings.cc:74 progDir(): progDir: ""
<_M_> [ui] YPath.cc:65 YPath(): Preferring subdir: 
<_M_> [ui] YPath.cc:66 YPath(): Subdir given with filename: 
<_M_> [ui] YPath.cc:67 YPath(): Looking for: libyui-qt.so.8
<_M_> [ui] YPath.cc:138 lsDir(): Looking in /usr/lib64/yui
<_M_> [ui] YPath.cc:118 YPath(): Found libyui-qt.so.8 in /usr/lib64/yui
<_M_> [ui] YUILoader.cc:118 loadUI(): Using UI-plugin: "gtk"
<_M_> [ui] YSettings.cc:179 loadedUI(): Set loadedUI to "gtk"
<_M_> [ui] YSettings.cc:180 loadedUI(): loadedUI is now locked.
<_M_> [ui] YPath.cc:49 YPath(): Given filename: libyui-gtk.so.8
<_M_> [ui] YSettings.cc:74 progDir(): progDir: ""
<_M_> [ui] YPath.cc:65 YPath(): Preferring subdir: 
<_M_> [ui] YPath.cc:66 YPath(): Subdir given with filename: 
<_M_> [ui] YPath.cc:67 YPath(): Looking for: libyui-gtk.so.8
<_M_> [ui] YPath.cc:138 lsDir(): Looking in /usr/lib64/yui
<_M_> [ui] YPath.cc:118 YPath(): Found libyui-gtk.so.8 in /usr/lib64/yui
<_M_> [ui] YUI.cc:76 YUI(): This is libyui 3.3.3
<_M_> [ui] YUI.cc:77 YUI(): Creating UI without threads
<_M_> [gtk] YGUI.cc:48 YGUI(): This is libyui-gtk 2.44.9
<_M_> [gtk] YGUI.cc:166 checkInit(): Style "/usr/share/libyui/theme/current/wizard/style.css"
<_M_> [gtk] YGUI.cc:188 checkInit(): Style "/usr/share/libyui/theme/current/wizard/style.css" not found. Ignoring style
<WRN> [gtk] YGUtils.cc:543 loadPixbuf(): Could not load icon: /usr/share/libyui/theme/icons/32x32/apps/yast.png
<WRN> [gtk] YGUtils.cc:543 loadPixbuf(): Reason: Failed to open file '/usr/share/libyui/theme/icons/32x32/apps/yast.png': No such file or directory
<_M_> [ui] YUI.cc:230 topmostConstructorHasFinished(): Running without threads
<_M_> [ui] YSettings.cc:197 loadedUI(): loadedUI: "gtk"
<_M_> [ui] YPath.cc:49 YPath(): Given filename: libyui-mga-gtk.so.8
<_M_> [ui] YSettings.cc:74 progDir(): progDir: ""
<_M_> [ui] YPath.cc:65 YPath(): Preferring subdir: 
<_M_> [ui] YPath.cc:66 YPath(): Subdir given with filename: 
<_M_> [ui] YPath.cc:67 YPath(): Looking for: libyui-mga-gtk.so.8
<_M_> [ui] YPath.cc:138 lsDir(): Looking in /usr/lib64/yui
<_M_> [ui] YPath.cc:118 YPath(): Found libyui-mga-gtk.so.8 in /usr/lib64/yui
<_M_> [ui] YPath.cc:49 YPath(): Given filename: libyui-mga-gtk.so.8
<_M_> [ui] YSettings.cc:74 progDir(): progDir: ""
<_M_> [ui] YPath.cc:65 YPath(): Preferring subdir: 
<_M_> [ui] YPath.cc:66 YPath(): Subdir given with filename: 
<_M_> [ui] YPath.cc:67 YPath(): Looking for: libyui-mga-gtk.so.8
<_M_> [ui] YPath.cc:138 lsDir(): Looking in /usr/lib64/yui
<_M_> [ui] YPath.cc:118 YPath(): Found libyui-mga-gtk.so.8 in /usr/lib64/yui
<_M_> [ew] YExternalWidgets.cc:37 YExternalWidgets(): Creating Libyui External Widgets object
<_M_> [gtk] YMGA_GCBTable.cc:415 YMGA_GCBTable():  Slection mode 2
<_M_> [gtk] YMGA_GCBTable.cc:434 YMGA_GCBTable():  columns 7 tot 7
End found 1 groups
not in cache
on_TransactionEvent start
on_TransactionEvent download
on_TransactionEvent signature
on_TransactionEvent run transaction
on_TransactionEvent end
End found 1 groups
not in cache

Comment 83 Angelo Naselli 2017-12-17 09:27:01 UTC
sorry... i can't get it... so you meant it worked?

Comment 84 patrick.guio 2017-12-17 16:31:39 UTC
*** Bug 1526811 has been marked as a duplicate of this bug. ***

Comment 85 lzavacky 2017-12-18 05:13:33 UTC
*** Bug 1526873 has been marked as a duplicate of this bug. ***

Comment 86 Alex Finkel 2017-12-18 14:15:30 UTC
(In reply to Angelo Naselli from comment #83)
> sorry... i can't get it... so you meant it worked?

Yes, it has worked twice now.

Comment 87 rickw 2017-12-20 16:46:34 UTC
*** Bug 1527970 has been marked as a duplicate of this bug. ***

Comment 88 Philippe SNEED 2017-12-21 10:31:21 UTC
*** Bug 1528220 has been marked as a duplicate of this bug. ***

Comment 89 Hayden 2017-12-21 19:52:51 UTC
*** Bug 1528423 has been marked as a duplicate of this bug. ***

Comment 90 hv60t 2017-12-23 22:28:19 UTC
*** Bug 1528777 has been marked as a duplicate of this bug. ***

Comment 91 Lorenzo Zanetti 2017-12-24 16:50:49 UTC
Similar problem has been detected:

Just got the crash notification at startup.
Happens at times also on other systems.

reporter:       libreport-2.9.2
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: perform
exception_type: librepo.LibrepoException
executable:     /usr/bin/dnfdragora-updater
kernel:         4.13.9-300.fc27.x86_64
package:        dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.freedesktop.DBus.Python.dnf.exceptions.RepoError: Traceback (most recent call last):
runlevel:       N 5
type:           Python3
uid:            1000

Comment 92 Woi 2017-12-24 18:12:33 UTC
Similar problem has been detected:

I belive this crash was caused because no network was available when dnfdragora was loaded.

reporter:       libreport-2.9.3
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: perform
exception_type: librepo.LibrepoException
executable:     /usr/bin/dnfdragora-updater
kernel:         4.14.7-300.fc27.x86_64
package:        dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.freedesktop.DBus.Python.dnf.exceptions.RepoError: Traceback (most recent call last):
runlevel:       N 5
type:           Python3
uid:            1000

Comment 93 Fedora Update System 2017-12-29 23:22:24 UTC
dnfdaemon-0.3.18-5.fc27 dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d66bd84f06

Comment 94 Fedora Update System 2017-12-29 23:27:21 UTC
dnfdaemon-0.3.18-5.fc26 dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-8caadb4a1b

Comment 95 Fedora Update System 2017-12-30 19:54:10 UTC
dnfdaemon-0.3.18-5.fc27, dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-d66bd84f06

Comment 96 Fedora Update System 2017-12-30 20:39:57 UTC
dnfdaemon-0.3.18-5.fc26, dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-8caadb4a1b

Comment 97 Fedora Update System 2017-12-31 21:27:46 UTC
dnfdaemon-0.3.18-5.fc27, dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 98 Fedora Update System 2018-01-01 22:11:21 UTC
dnfdaemon-0.3.18-5.fc26, dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 99 Douglas 2018-01-04 11:42:04 UTC
*** Bug 1530990 has been marked as a duplicate of this bug. ***

Comment 100 tpazoliveira 2018-01-05 03:39:46 UTC
*** Bug 1531375 has been marked as a duplicate of this bug. ***

Comment 101 Hariharasudhan 2018-01-18 17:38:14 UTC
*** Bug 1536151 has been marked as a duplicate of this bug. ***

Comment 102 Liangz 2018-01-21 07:05:48 UTC
*** Bug 1536783 has been marked as a duplicate of this bug. ***

Comment 103 Americo 2018-01-24 21:35:56 UTC
*** Bug 1538348 has been marked as a duplicate of this bug. ***

Comment 104 Arif Hidayat 2018-02-03 22:14:23 UTC
*** Bug 1541664 has been marked as a duplicate of this bug. ***

Comment 105 Shaun Nipper 2018-03-10 12:26:17 UTC
*** Bug 1553983 has been marked as a duplicate of this bug. ***

Comment 106 Vince 2018-03-18 18:02:39 UTC
*** Bug 1557797 has been marked as a duplicate of this bug. ***

Comment 107 Paul Gross 2018-03-26 03:13:37 UTC
Similar problem has been detected:

I attempted to access dnfdragon after system booted.

reporter:       libreport-2.9.3
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: perform
exception_type: librepo.LibrepoException
executable:     /usr/bin/dnfdragora-updater
kernel:         4.13.9-300.fc27.x86_64
package:        dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.freedesktop.DBus.Python.dnf.exceptions.RepoError: Traceback (most recent call last):
runlevel:       N 5
type:           Python3
uid:            1000

Comment 108 tykenicol 2018-03-29 09:09:01 UTC
*** Bug 1561951 has been marked as a duplicate of this bug. ***

Comment 109 Nikolay 2018-04-06 20:58:24 UTC
*** Bug 1564676 has been marked as a duplicate of this bug. ***

Comment 110 Dipak Patil 2018-04-10 02:50:49 UTC
*** Bug 1565441 has been marked as a duplicate of this bug. ***

Comment 111 andersen.kristian.joten 2018-04-25 04:15:22 UTC
*** Bug 1571521 has been marked as a duplicate of this bug. ***

Comment 112 Breno Rangel Silveira 2018-04-26 01:09:08 UTC
*** Bug 1572018 has been marked as a duplicate of this bug. ***

Comment 113 Mukha 2018-04-28 10:58:36 UTC
*** Bug 1572877 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.