Bug 1495550 - Wi-Fi lost a link(Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32))
Summary: Wi-Fi lost a link(Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: linux-firmware
Version: 25
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-26 09:41 UTC by Andrey Chessnokov
Modified: 2017-11-01 16:38 UTC (History)
18 users (show)

Fixed In Version: linux-firmware-20170828-77.gitb78acc9.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-01 16:38:19 UTC
Type: Bug


Attachments (Terms of Use)
NetworkManager log (300.15 KB, text/plain)
2017-09-26 11:06 UTC, Andrey Chessnokov
no flags Details

Description Andrey Chessnokov 2017-09-26 09:41:47 UTC
Description of problem:
After update *-firmware-* and NetworkManager-* packages, wi-fi work unstable.
A few minutes after the connection is established, the communication is lost.

сommunication established:
ifconfig:
lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 28  bytes 2396 (2.3 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 28  bytes 2396 (2.3 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

virbr0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        inet 192.168.122.1  netmask 255.255.255.0  broadcast 192.168.122.255
        ether 52:54:00:34:8e:39  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp1s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.3.23  netmask 255.255.255.0  broadcast 192.168.3.255
        inet6 fe80::4524:7052:e4d6:e9ac  prefixlen 64  scopeid 0x20<link>
        ether 90:cd:b6:48:ce:ed  txqueuelen 1000  (Ethernet)
        RX packets 50357  bytes 70477576 (67.2 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 22615  bytes 2031391 (1.9 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

iwconfig: 
virbr0-nic  no wireless extensions.

wlp1s0    IEEE 802.11  ESSID:"neotec.wifi"  
          Mode:Managed  Frequency:2.447 GHz  Access Point: D4:CA:6D:1E:6D:E9   
          Bit Rate=1 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=70/70  Signal level=-28 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:54   Missed beacon:0

virbr0    no wireless extensions.

lo        no wireless extensions.

сommunication lost:
ifconfig:
lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 28  bytes 2396 (2.3 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 28  bytes 2396 (2.3 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

virbr0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        inet 192.168.122.1  netmask 255.255.255.0  broadcast 192.168.122.255
        ether 52:54:00:34:8e:39  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp1s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.3.23  netmask 255.255.255.0  broadcast 192.168.3.255
        inet6 fe80::4524:7052:e4d6:e9ac  prefixlen 64  scopeid 0x20<link>
        ether 90:cd:b6:48:ce:ed  txqueuelen 1000  (Ethernet)
        RX packets 66823  bytes 87221338 (83.1 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 33496  bytes 3988924 (3.8 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

iwconfig: 
virbr0-nic  no wireless extensions.

wlp1s0    IEEE 802.11  ESSID:"neotec.wifi"  
          Mode:Managed  Frequency:2.447 GHz  Access Point: D4:CA:6D:1E:6D:E9   
          Bit Rate=1 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=70/70  Signal level=-29 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:81   Missed beacon:0

virbr0    no wireless extensions.

lo        no wireless extensions.


Updated packages logs:
    Upgraded NetworkManager-1:1.4.4-5.fc25.x86_64                            @updates
    Upgrade                 1:1.4.6-1.fc25.x86_64                            @updates
    Upgraded NetworkManager-adsl-1:1.4.4-5.fc25.x86_64                       @updates
    Upgrade                      1:1.4.6-1.fc25.x86_64                       @updates
    Upgraded NetworkManager-bluetooth-1:1.4.4-5.fc25.x86_64                  @updates
    Upgrade                           1:1.4.6-1.fc25.x86_64                  @updates
    Upgraded NetworkManager-config-connectivity-fedora-1:1.4.4-5.fc25.x86_64 @updates
    Upgrade                                            1:1.4.6-1.fc25.x86_64 @updates
    Upgraded NetworkManager-glib-1:1.4.4-5.fc25.x86_64                       @updates
    Upgrade                      1:1.4.6-1.fc25.x86_64                       @updates
    Upgraded NetworkManager-libnm-1:1.4.4-5.fc25.x86_64                      @updates
    Upgrade                       1:1.4.6-1.fc25.x86_64                      @updates
    Upgraded NetworkManager-team-1:1.4.4-5.fc25.x86_64                       @updates
    Upgrade                      1:1.4.6-1.fc25.x86_64                       @updates
    Upgraded NetworkManager-wifi-1:1.4.4-5.fc25.x86_64                       @updates
    Upgrade                      1:1.4.6-1.fc25.x86_64                       @updates
    Upgraded NetworkManager-wwan-1:1.4.4-5.fc25.x86_64                       @updates
    Upgrade                      1:1.4.6-1.fc25.x86_64                       @updates
    Upgraded iwl100-firmware-39.31.5.1-74.fc25.noarch                        @updates
    Upgrade                  39.31.5.1-76.fc25.noarch                        @updates
    Upgraded iwl105-firmware-18.168.6.1-74.fc25.noarch                       @updates
    Upgrade                  18.168.6.1-76.fc25.noarch                       @updates
    Upgraded iwl135-firmware-18.168.6.1-74.fc25.noarch                       @updates
    Upgrade                  18.168.6.1-76.fc25.noarch                       @updates
    Upgraded iwl2000-firmware-18.168.6.1-74.fc25.noarch                      @updates
    Upgrade                   18.168.6.1-76.fc25.noarch                      @updates
    Upgraded iwl2030-firmware-18.168.6.1-74.fc25.noarch                      @updates
    Upgrade                   18.168.6.1-76.fc25.noarch                      @updates
    Upgraded iwl3945-firmware-15.32.2.9-74.fc25.noarch                       @updates
    Upgrade                   15.32.2.9-76.fc25.noarch                       @updates
    Upgraded iwl4965-firmware-228.61.2.24-74.fc25.noarch                     @updates
    Upgrade                   228.61.2.24-76.fc25.noarch                     @updates
    Upgraded iwl5000-firmware-8.83.5.1_1-74.fc25.noarch                      @updates
    Upgrade                   8.83.5.1_1-76.fc25.noarch                      @updates
    Upgraded iwl5150-firmware-8.24.2.2-74.fc25.noarch                        @updates
    Upgrade                   8.24.2.2-76.fc25.noarch                        @updates
    Upgraded iwl6000-firmware-9.221.4.1-74.fc25.noarch                       @updates
    Upgrade                   9.221.4.1-76.fc25.noarch                       @updates
    Upgraded iwl6000g2a-firmware-18.168.6.1-74.fc25.noarch                   @updates
    Upgrade                      18.168.6.1-76.fc25.noarch                   @updates
    Upgraded iwl6000g2b-firmware-18.168.6.1-74.fc25.noarch                   @updates
    Upgrade                      18.168.6.1-76.fc25.noarch                   @updates
    Upgraded iwl6050-firmware-41.28.5.1-74.fc25.noarch                       @updates
    Upgrade                   41.28.5.1-76.fc25.noarch                       @updates
    Upgraded linux-firmware-20170605-74.git37857004.fc25.noarch              @updates
    Upgrade                 20170828-76.gitb78acc9.fc25.noarch               @updates
    Upgraded publicsuffix-list-dafsa-20170424-1.fc25.noarch                  @updates
    Upgrade                          20170828-1.fc25.noarch                  @updates
    Upgraded iwl1000-firmware-1:39.31.5.1-74.fc25.noarch                     @updates
    Upgrade                   1:39.31.5.1-76.fc25.noarch                     @updates
    Upgraded iwl3160-firmware-1:25.30.13.0-74.fc25.noarch                    @updates
    Upgrade                   1:25.30.13.0-76.fc25.noarch                    @updates
    Upgraded iwl7260-firmware-1:25.30.13.0-74.fc25.noarch                    @updates
    Upgrade                   1:25.30.13.0-76.fc25.noarch                    @updates
    Upgraded libertas-usb8388-firmware-2:20170605-74.git37857004.fc25.noarch @updates
    Upgrade                            2:20170828-76.gitb78acc9.fc25.noarch  @updates

Version-Release number of selected component (if applicable):
Linux localhost.localdomain 4.12.13-200.fc25.x86_64 #1 SMP Thu Sep 14 16:12:37 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:
A few minutes after the connection is established, the communication is lost.

Steps to Reproduce:
1. Connect to any wi-fi network
2. Wait about 3-5 min.
3.

Actual results: сommunication is losing


Expected results: сommunication is present


Additional info:

Comment 1 Thomas Haller 2017-09-26 09:53:38 UTC
> After update *-firmware-* and NetworkManager-* packages, wi-fi work unstable.

If you think the update broke something, can you find out whether it was the firmware or NetworkManager update that broke it?

Also without logfiles of NetworkManager its rather hard to understand what is wrong. See the hint at https://cgit.freedesktop.org/NetworkManager/NetworkManager/plain/contrib/fedora/rpm/NetworkManager.conf?id=master for how to get logfiles.

Comment 2 Andrey Chessnokov 2017-09-26 10:25:22 UTC
Downgrade package linux-firmware to version 20160923 resolve the problem.

Comment 3 Thomas Haller 2017-09-26 10:38:29 UTC
which would indicate that it's not a NetworkManager issue.

One thing to try, is to disable NetworkManager changing the MAC address. You do so via a file /etc/NetworkManager/conf.d/80-no-wifi-scan-rand.conf with

  [device]
  wifi.scan-rand-mac-address=0

and restart NM.


Aside from that, logfiles are still required to understand what's happening. 

Since it looks like an issue with the driver, the logfiles of supplicant would be helpful too. See https://wiki.gnome.org/Projects/NetworkManager/Debugging#wpa_supplicant

Comment 4 Andrey Chessnokov 2017-09-26 11:06:29 UTC
Created attachment 1330998 [details]
NetworkManager log

I update linux-firmware to 20170828,

add /etc/NetworkManager/conf.d/80-no-wifi-scan-rand.conf
[device]
wifi.scan-rand-mac-address=0

[logging]
level=TRACE
domains=ALL

wait for disconnected.

Comment 5 Josh Boyer 2017-09-26 13:43:37 UTC
This is fixed in linux-firmware-20170828-77.gitb78acc9.fc25

https://bodhi.fedoraproject.org/updates/FEDORA-2017-d2803ce4f5

Comment 6 Fedora Update System 2017-09-26 13:44:29 UTC
linux-firmware-20170828-77.gitb78acc9.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d2803ce4f5

Comment 7 Fedora Update System 2017-11-01 16:38:19 UTC
linux-firmware-20170828-77.gitb78acc9.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.