Bug 149579 - rpc.svcgssd fails to start
rpc.svcgssd fails to start
Status: CLOSED DUPLICATE of bug 149645
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: nfs-utils (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-23 20:13 EST by Haibin Wang
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-02 05:24:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Haibin Wang 2005-02-23 20:13:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:

rpc.svcgssd failed to start, complaining unable to open a
/proc/net/rpc/auth.rpcsec.init/channel file, though the script under
init.d reports status OK. 

The /proc/net/rpc/auth.rpcsec.init/channel really doesn't exist,
neither does the directory auth.rpcsec.init. I assume they should be
generated by some kernel modules. 

Version-Release number of selected component (if applicable):
nfs-utils-1.0.6-39

How reproducible:
Always

Steps to Reproduce:
1./usr/sbin/rpc.svcgssd -f -v
    

Actual Results:  
WARNING: unable to locate function krb5_gss_internal_release_oid in
krb5 mechanism library: there will be problems if multiple mechanisms
are used!
failed to open /proc/net/rpc/auth.rpcsec.init/channel

Additional info:

I installed nfs-utils 1.0.6-46, it says the same thing. 
I did a goole, somebody reported a similiar bug under Fedora-2, said
this is fixed in release 1.0.6-30. I am just wondering whether this
bug belongs to nfs-utils or kernel. 

BTW, the kernel that runs on my box is: 2.6.9-1.648_ELsmp
The system is: Red Hat Enterprise Linux AS release 3.90 (Nahant)
Comment 1 Haibin Wang 2005-02-24 14:37:09 EST
I found out the cause of this problem. 

This happened cause the nfs start up script doesn't load module

rpcsec_gss_krb5 

After reading nfsv4 mailling list and try it by hand, rpc.svcgssd is
able to start up successfully. 

P.S. This bug is reproducable also on Enterprise AS 4.0. Somebody
should fix it, it costs me 3 days. 
Comment 2 Jay Turner 2005-03-02 05:24:41 EST

*** This bug has been marked as a duplicate of 149645 ***
Comment 3 Steve Dickson 2005-03-03 01:35:20 EST
This is fixed in nfs-utils-1.0.6.51


Note You need to log in before you can comment on or make changes to this bug.